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CHAPTER 1 – GETTING STARTED 

What is BrightAuthor? 
BrightAuthor is a software application that helps you create and publish digital-signage presentations for BrightSign 
players. You can play BrightAuthor presentations on any of the following BrightSign models: XD230, XD1030, XD1230, 
HD120, HD220, HD1020, HD110, HD210, HD210w, HD410, HD810, HD1010, HD1010w, and TD1012. Your 
presentations can include any of the following types of content: 

• Images 
• Pre-recorded videos 
• Live videos: Supported on the XD1230, as well as the HD810, HD1010, HD1010w (in conjunction with the Live 

Video Module accessory) 
• Audio 
• RSS and Twitter feeds 
• Dynamic playlists 
• SignChannel: Supported on the HD210, HD210w, HD220, HD1010, HD1010w, HD1020, XD230, XD1030, 

XD1230, and TD1012 
Note: Subscription is required. Go to http://www.signchannel.com/ for details. 

• Text 
• Date and time 

 
What Kind of Presentations Can I Create? 
You can create two types of presentation with BrightAuthor: 

• Non-Interactive: A slideshow of media (images, video, audio) that plays in a continuous loop. You can play non-
interactive presentations on all BrightSign models. 

• Interactive: A presentation that transitions between media based on input from a user via a button board, remote 
control, or a similar input device. All models except the HD110 support at least one type of interactive event. The 

http://store.brightsign.biz/Store-W1.aspx�
http://store.brightsign.biz/Store-W1.aspx�
http://www.signchannel.com/�


2 
 

types of interactive event supported by a player depend on the connectors and inputs that player has (for example, 
players with a USB 2.0 port support touch screen and button board events, and players with an Ethernet port 
support UDP events). 

 
What Type of Screen Layouts Can I Use? 
You can choose from a variety of ready-to-use layout templates or create your own template. Layout templates fall into 
two basic categories: 

• Full Screen: A slide show of media that occupies the full screen. 
• Multi-Zone: A presentation with different types of content in separate regions of the screen. The screen can include 

one video or background image zone, and multiple Clock, Text, Ticker, and Image zones. 

 
Step 1: Get the Hardware You Need 
To create and play presentations with BrightAuthor, you need the following: 

• Windows PC 
• BrightSign player 
• Display 
• Storage card 
• Card reader/writer (optional if using USB storage) 
• Input device (optional) 

 
Windows PC – Any Windows PC that meets or exceeds the following minimum requirements: 

• 2.3 GHz CPU 
• 2 GB RAM required (4 GB recommended) 
• 100 MB available hard disk space for program files (additional disk space required if storing content and/or 

presentations on your hard disk) 
• One of the following operating systems: 

o Windows Vista 32 or 64 bit 
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o Windows 7 32 or 64 bit  
 

BrightSign – Any of the following models with firmware version 3.10.6 or later: 
• HD110 
• HD210 and HD210w 
• HD410 
• HD810 
• HD1010 and HD1010w 
• TD1012 

 
Any of the following models with firmware version 4.2.25 or later: 

• HD120 
• HD220 
• HD1020 

 
Any of the following models with firmware version 4.2.20 or later 

• XD230 
• XD1030 
• XD1230 

 
Display – Any monitor, TV, or Elo touch screen with one of the following types of inputs: 

• VGA 
• Component (supported on HD810, HD1010, HD1010w, XD230, XD1030, and XD1230) 
• HDMI 

 
Storage for Media – Either of the following: 

• USB Flash Drive (supported on HD810, HD1010, HD1010w, HD1020, XD1030, and XD1230) 
• SD card 
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• SDHC card 
• SDXC card (supported on HD120, HD220, HD1020, XD230, XD1030, and XD1230) 

 
Card Reader/Writer – Not required if using a USB flash drive. The card reader/writer must be connected to your PC and 
must be compatible with your storage card. 
 
Input Device – All models except HD110. One or more of the following types of input devices: 

• Touch screen equipped with a touch controller that supports the standard HID specification. See this link for a list of 
all supported touch controllers (HD810, HD1010, HD1010w, HD1020, XD1030, and XD1230). 

• BrightSign’s BP200 and BP900 USB button panels (HD810, HD1010, HD1010w, HD1020, XD1030, and XD1230) 
• Many brands of USB Keyboards (HD810, HD1010, HD1010w, HD1020, XD1030, and XD1230) 
• Many brands of USB Mouse or Trackballs (HD810, HD1010, HD1010w, HD1020, XD1030, and XD1230) 
• Many brands of USB Bar Code Scanners. (supported on HD810, HD1010, HD1010w, HD1020, XD1030, and 

XD1230) 
• Quadravox Serial Button Board 
• AMX, Crestron, and similar control devices (serial & Ethernet) 
• Any GPIO (open/close contact switch) button, signal, or LED (your custom board or LED display) 
• PC (via serial port) 
• IR remote control using the NEC Remote Control Protocols (HD810, HD1010, HD1010w, and HD1020 only). You 

can purchase a compatible remote from BrightSign (see Appendix A for remote control codes). 
 

Step 2: Install the BrightAuthor Software 
Download the latest software and install it on your PC. 

1. Go to the BrightSign web site: www.brightsign.biz/support. 
2. Click the BrightAuthor Downloads link. 
3. Follow the onscreen instructions to install the software on your PC. 

http://support.brightsign.biz/entries/262256-whattouchscreens-can-i-use-with-the-brightsign�
http://brightsign.biz/products/accessories/usb-button-panels/�
http://www.brightsign.biz/support�
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Note: BrightAuthor requires the latest version of Microsoft .Net Framework. If this component is not already on your 
PC, BrightAuthor installs it during the installation. However, if BrightAuthor needs to install Microsoft .Net Framework, 
the installation may take up to 45 minutes to complete and you may need to restart your PC to complete the 
installation process. 

 

Step 3: Launch BrightAuthor 
1. Double-click the BrightAuthor icon on your desktop. 
2. (Optional) If prompted, sign in to BrightSign Network (account required). See Publishing with BrightSign Network. 

 

Step 4: Set up your BrightSign player 
1. Depending on how you want to publish your presentations, create the appropriate setup files for your BrightSign 

units. 
2. Insert the SD card or USB flash drive that contains the setup files into the BrightSign. 
3. Connect your BrightSign to a display.  

 

Step 5: Add your Content 
Your BrightAuthor presentations can include the following types of media files: 
 
Video files - BrightSign players support the following video file encodings/compressions: 

• MPEG-2 (can be saved as an .mpg, .ts, or .vob container) 
• MPEG-1 (can be saved as an .mpg container) 
• H.264 (MPEG-4, Part 10) (can be saved as a .mp4, .mov, or .ts container) 

For further details on video file encoding and support, see the support page on the BrightSign website. 
 
Audio files – BrightSign players support the following audio formats: 

• AAC (LC - Low complexity profile) at Constant Bit Rate, as part of a video file (.mp4, .mov, or .ts) at 44.1 
KHz, 48 KHz 

http://support.brightsign.biz/entries/143091-what-video-formats-and-codecs-does-the-brightsign-support�
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• MP2 (MPEG-1 Layer 2) at Constant Bit Rate, as part of a video file (.mpg, or .ts) at 44.1 KHz, 48 KHz 
• MP3 at Constant Bit Rate, 44.1 KHz, 48 KHz, 32 KHz at up to 224 Kbps bitrate, as a standalone file (i.e. not 

encoded as an audio track in a video file) 
• AC3 5.1 passed through (un-decoded, RAW data) HDMI. Audio streams in this format are supported by 

BrightSign players, but will require an AC3 decoder (HDMI AV receiver). 
• WAV 

 
Image files - For still images, use BMP, PNG, or JPEG files. The maximum supported resolution is 1920x1080. 

Note: BrightSign players do not support JPEG image files with CMYK color profiles. You can convert your CMYK 
JPEGs to RGB JPEGs using this free web-based converter.  

 

Step 6: Create your Presentations 
Now you’re ready to start using BrightAuthor to create presentations. Just add your content and follow the directions in the 
next chapter of this guide to create your presentations. 
 

Step 7: Publish your Presentations 
After creating presentations, use the publishing feature to deliver them to your BrightSign players. See Publishing 
Presentations for details. 
 

  

http://www.cmykconverter.com/�
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CHAPTER 2 – SETTING UP UNITS 

Before you can create and publish presentations, you must first set up your BrightSign players. How you set up your units 
will depend on how you want to publish presentations to the players. If you’re using BrightSign Network, Local 
Networking, or Simple File Networking to publish your presentations, you must set up your BrightSign units by adding 
them to your network. Alternatively, you can set up BrightSign players for use as standalone units that are not connected 
to a network. With this option, you would have to manually update the BrightSign player’s storage (SD card or USB flash 
drive) each time you want to update presentations. For more details on each of the publishing methods, see Publishing 
Presentations. 
 
To set up a player, you need to create setup files in BrightAuthor and add those files to a storage device (SD card or USB 
flash drive). Next, insert the storage into the BrightSign player. Keep in mind that this storage must remain inside the 
BrightSign. BrightSign units have no internal storage and therefore cannot receive content without a storage device 
connected. Once the storage device (typically an SD card) is inserted, your BrightSign player is ready to receive and play 
presentations. 
 

Adding a Player to your BrightSign Network 
To publish and manage presentations using BrightSign Network, you must first contact BrightSign to obtain an account 
name, user name, and password. 
 
After you obtain your account credentials, you can create the setup files for each unit. The setup files provide details 
about what your network and BrightSign Network connections are, where the presentations associated with the selected 
group are stored, and when the presentations are scheduled. 

1. Sign in to your BrightSign Network account. 
a. In the BrightAuthor menu bar, click Tools > Sign in to BrightSign Network. 
b. If prompted, enter your Account, User name, and Password, and then click Sign In. 

mailto:sales@brightsign.biz�
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2. On the menu bar, click Tools > Setup BrightSign Unit. 
3. Under Name Specification, do the following: 

a. Enter a Name and Description for this unit. 
b. Select whether you want to append the unit ID to the name or use only the name.  
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4. Under Network Properties, set the following: 
a. Enable Wireless: Check this box if you plan to connect to the local network using a wireless connection. In 

order to use a wireless connection, you must purchase a wireless model (HD210w, HD1010w) or purchase 
an XD Wireless Module for your BrightSign XD player. Enter the SSID and Security key if the network is 
secured. 

b. Network Connection Priority: Use the up and down arrows to prioritize either the Wired or Wireless 
connection. The BrightSign player will always attempt to download and upload using the first option. It will 
only use the second option if the first is unavailable. 

c. Time zone: Select the time zone where the unit is located. 
d. Time server: Select the clock for this unit. 

5. Click the Advanced Network Setup button to customize advanced settings for your networked player. Specify the 
following in the Unit Configuration tab: 

a. Use Proxy: Check this box if you want to use a proxy server. Type the address and port number in the 
fields below. 

b. Limit content downloads: Check this box if you want to limit when the player downloads content. This 
is helpful if you want to limit network traffic at a certain time of day. Set a time frame during which content 
downloads can occur. 

c. Limit health updates: Check this box if you want to limit when the player sends health updates to the 
BrightSign Network. This is helpful if you know a player will be powered off or otherwise disabled during 
a certain time of day. Set a time frame during which health updates can occur. 

d. Copy content from the current published schedule: Check this box if you want BrightAuthor to copy 
the current published schedule to the storage device with the setup files. This is helpful if you don’t want 
the player downloading large content files from the BrightSign Network right after it is set up. 

6. Specify the following in the Wired and Wireless tab of the Advanced Network Setup window: 
a. Data Types Enabled: Use these checkboxes to determine the types of data that will be transferred using 

the connection. You can enable/disable both downloads (Content, Text Feeds, Media Feeds) and uploads 
(Health, Log Updates). 

http://www.brightsign.biz/products/accessories/wireless-module/�
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b. Connection Settings: Indicate whether the IP address is auto-generated or static. If you’re using a static IP 
address, enter the parameters in the fields below. 

c. Rate Limit Network Download Traffic: Set the parameters for downloading content. The options are 
divided into three categories: Outside content download window and During content download window 
(both of which correspond to the Limit content downloads setting in the Unit Configuration tab) , as well 
as During initial downloads. 

o Click Unlimited download rate to set no limit. 
o Click Default limit to use the default limit on downloads. 
o Click Specify limit to enter a customized limit on downloads in the text field (in Kbits/second). 

7. Click Specify Firmware Update to indicate whether you want to update the firmware and to which version. The 
Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign unit, 
select a firmware version or select Do not update, and then click OK.  
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8. Under Unit Configuration, click Networked with BrightSign Network, and then specify the following: 
a. (Optional) Enable diagnostic web server: Check the checkbox to enable the diagnostic web server. You 

can include a username and password in the text fields below for added security. 
b. (Optional) Enable local web server: Check the checkbox to enable the local web server. You can include a 

username and password in the text fields below for added security. 
c. Group: Use the dropdown list to select a group for the unit. Groups allow you to publish presentation 

schedules to multiple units simultaneously. See Managing groups and Publishing with BrightSign Network 
for details. 

9. Under Logging, check any of the following checkboxes to enable/disable logs and specify upload settings: 
a. Enable playback logging: Creates a log that records start and end times, zone names, media types, and 

file names. 
b. Enable event logging: Creates a log that records timestamps, state names, zone names, event types, and 

event data. 
c. Enable state logging: Creates a log that records current and last state names, timestamps, and media 

types. 
d. Enable diagnostic logging: Creates a log that records timestamps, firmware and script versions, and the 

current presentation. 
e. Upload logs 

o On startup: Uploads log files each time you start the unit. 
o At specific time each day: Uploads log files daily at the specified time. Use the dropdown lists to 

pick a time. 
o Relative URL for log handler: Type the location where you want logs to be uploaded. 

8. Create and install the setup files: 
a. Click Create Setup Files. 
b. Browse to and select an SD card (recommended) or USB flash drive (HD810, HD1010, HD1010w, HD1020, 

XD1030, and XD1230 only) to store the setup files. 
c. Click OK. 
d. Turn off the BrightSign unit by unplugging the power adapter. Insert the card or flash drive into the unit. 
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e. Turn on the BrightSign unit by reconnecting the power adapter. 
Important: Do not remove the SD card or flash drive from the player. 
 

Adding a Player to your Local Network 
With local networking, the setup files provide details about where presentations are stored and whether logging options 
are enabled. 

1. In the BrightAuthor menu bar, click Tools > Setup BrightSign Unit. 
2. Under Name Specification, do the following: 

a. Enter a Name and Description for this unit. 
b. Select whether you want to append the unit ID to the name or use only the name. 

3. Under Network Properties, set the following: 
a. Enable Wireless: Check this box if you plan to connect to the local network using a wireless connection. In 

order to use a wireless connection, you must purchase a wireless model (HD210w, HD1010w) or purchase 
an XD Wireless Module for your BrightSign XD player. Enter the SSID and Security key if the network is 
secured. 

b. Network Connection Priority: Use the up and down arrows to prioritize either the Wired or Wireless 
connection. The BrightSign player will always attempt to download and upload using the first option. It will 
only use the second option if the first is unavailable. 

c. Time zone: Select the time zone where the unit is located. 
d. Time server: Select the clock for this unit. 

4. Click the Advanced Network Setup button to customize advanced settings for your networked player. Specify the 
following in the Unit Configuration tab: 

a. Use Proxy: Check this box if you want to use a proxy server. Type the address and port number in the fields 
below. 

5. Specify the following in the Wired and Wireless tab of the Advanced Network Setup window: 

http://www.brightsign.biz/products/accessories/wireless-module/�
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a. Data Types Enabled: Use these checkboxes to determine the types of data that will be transferred using 
the connection. You can enable/disable both downloads (Content, Text Feeds, Media Feeds) and uploads 
(Log Updates). 

b. Connection Settings: Indicate whether the IP address is auto-generated or static. If you’re using a static IP 
address, enter the parameters in the fields below. 
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4. Click Specify Firmware Update to indicate whether you want to update the firmware and to which version. 
The Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign 
unit, select a firmware version or Do not update, and then click OK.    

5. Under Unit Configuration, click Networked with Local File Networking, and then specify the following: 
a. (Optional) Enable diagnostic web server: Check the checkbox to enable the diagnostic web server. You 

can include a username and password in the text fields below for added security. 
b. (Optional) Enable local web server: Check the checkbox to enable the local web server. You can include a 

username and password in the text fields below for added security. 
6. Under Logging, check any of the following checkboxes to enable/disable logs and specify upload settings: 

a. Enable playback logging: Creates a log that records start and end times, zone names, media types, and 
file names. 
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b. Enable event logging: Creates a log that records timestamps, state names, zone names, event types, and 
event data. 

c. Enable state logging: Creates a log that records current and last state names, timestamps, and media 
types. 

d. Enable diagnostic logging: Creates a log that records timestamps, firmware and script versions, and the 
current presentation. 

e. Upload logs 
o On startup: Uploads log files each time you start the unit. 
o At specific time each day: Uploads log files daily at the specified time. Use the dropdown lists to 

pick a time. 
o Relative URL for log handler: Type the location where you want logs to be uploaded. 

9. Create and install the setup files: 
a. Click Create Setup Files. 
b. Browse to and select an SD card (recommended) or USB flash drive (HD810, HD1010, HD1010w, HD1020, 

XD1030, and XD1230 only) to store the setup files. 
c. Click OK. 
d. Turn off the BrightSign unit by unplugging the power adapter. Insert the card or flash drive into the unit. 
e. Turn on the BrightSign unit by reconnecting the power adapter. 

Important: Do not remove the SD card or flash drive from the player. 
 

Adding a Player to your Simple File Network 
With simple file networking, the setup file provides details about your network, the web folder associated with a unit, 
where presentations are stored, and when to check for updates. 

1. In the BrightAuthor menu bar, click Tools > Setup BrightSign Unit. 
2. Under Name Specification, do the following: 

a. Enter a Name and Description for this unit. 
b. Select whether you want to append the unit ID to the name or use only the name. 
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3. Under Network Properties, set the following: 
a. Enable Wireless: Check this box if you plan to connect to the local network using a wireless connection. In 

order to use a wireless connection, you must purchase a wireless model (HD210w, HD1010w) or purchase 
an XD Wireless Module for your BrightSign XD player. Enter the SSID and Security key if the network is 
secured. 

b. Network Connection Priority: Use the up and down arrows to prioritize either the Wired or Wireless 
connection. The BrightSign player will always attempt to download and upload using the first option. It will 
only use the second option if the first is unavailable. 

c. Time zone: Select the time zone where the unit is located. 
d. Time server: Select the clock for this unit. 

4. Click the Advanced Network Setup button to customize advanced settings for your networked player. Specify the 
following in the Unit Configuration tab: 

a. Use Proxy: Check this box if you want to use a proxy server. Type the address and port number in the fields 
below. 

b. Limit content downloads: Check this box if you want to limit when the player downloads content. This is 
helpful if you want to limit network traffic at a certain time of day. Set a time frame during which content 
downloads can occur. 

5. Specify the following in the Wired and Wireless tab of the Advanced Network Setup window: 
a. Data Types Enabled: Use these checkboxes to determine the types of data that will be transferred using 

the connection. You can enable/disable both downloads (Content, Text Feeds, Media Feeds) and uploads 
(Log Updates). 

b. Connection Settings: Indicate whether the IP address is auto-generated or static. If you’re using a static IP 
address, enter the parameters in the fields below. 

c. Rate Limit Network Download Traffic: Set the parameters for downloading content. The options are 
divided into three categories: Outside content download window and During content download window 
(both of which correspond to the Limit content downloads setting in the Unit Configuration tab) , as well 
as During initial downloads. 

o Click Unlimited download rate to set no limit. 

http://www.brightsign.biz/products/accessories/wireless-module/�
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o Click Default limit to use the default limit on downloads. 
o Click Specify limit to enter a customized limit on downloads in the text field (in Kbits/second). 

 
4. Click Specify Firmware Update to indicate whether you want to update the firmware and to which version. The 

Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign unit, 
select a firmware version or Do not update, and then click OK. 
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5. Under Unit Configuration, click Networked with Simple File Networking, and then specify the following: 
a. (Optional) Enable diagnostic web server: Check the checkbox to enable the diagnostic web server. You 

can include a username and password in the text fields below for added security. 
b. (Optional) Enable local web server: Check the checkbox to enable the local web server. You can include a 

username and password in the text fields below for added security. 
c. URL for the web folder: Set the location from which the player will download presentations. Do not use 

trailing slashes in your URL; some web servers do not support trailing slashes. 
Important: The URL for the web folder must be identical to the web folder URL you enter when publishing 
presentations. See Publishing with Simple File Networking for details. 
d. Content Check Frequency: Set how often you want the unit to check the server for updates. 

6. Under Logging, check any of the following checkboxes to enable/disable logs and specify upload settings: 
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a. Enable playback logging: Creates a log that records start and end times, zone names, media types, and 
file names. 

b. Enable event logging: Creates a log that records timestamps, state names, zone names, event types, and 
event data. 

c. Enable state logging: Creates a log that records current and last state names, timestamps, and media 
types. 

d. Enable diagnostic logging: Creates a log that records timestamps, firmware and script versions, and the 
current presentation. 

e. Upload logs 
o On startup: Uploads log files each time you start the unit. 
o At specific time each day: Uploads log files daily at the specified time. Use the dropdown lists to 

pick a time. 
o Relative URL for log handler: Type the location where you want logs to be uploaded. 

7. Create and install the setup files: 
a. Click Create Setup Files. 
b. Browse to and select an SD card (recommended) or USB flash drive (HD810, HD1010, HD1010w, HD1020, 

XD1030, and XD1230 only) to store the setup files. 
c. Click OK. 
d. Turn off the BrightSign unit by unplugging the power adapter. Insert the card or flash drive into the unit. 
e. Turn on the BrightSign unit by reconnecting the power adapter. 

Important: Do not remove the SD card or flash drive from the player. 
 

Setting up a Player for Standalone Use 
Standalone players are not connected to a network and must be updated manually. To change presentations/schedules, 
you must remove the storage card (or USB flash drive), update it on your computer, and reinsert it into the player.  
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Updating standalone units is the only case in which you should remove the storage card after setting up the unit. If your 
player has a USB flash drive slot, it is recommended that you use an SD card when setting up the unit, and keep it in the 
player as the internal storage. You can update the content on the SD card via a USB flash drive. See Publishing with 
Local Storage for details. With standalone units, the setup files provide details about where presentations are stored and 
whether logging options are enabled. 

1. In the BrightAuthor menu bar, click Tools > Setup BrightSign Unit. 
2. Under Name Specification, do the following: 

a. Enter a Name and Description for this unit. 
b. Select whether you want to append the unit ID to the name or use only the name. 

3. Under Network Properties, set the following: 
a. Enable Wireless: Check this box if you plan to connect to the local network using a wireless connection. In 

order to use a wireless connection, you must purchase a wireless model (HD210w, HD1010w) or purchase 
an XD Wireless Module for your BrightSign XD player. Enter the SSID and Security key if the network is 
secured. 

b. Network Connection Priority: Use the up and down arrows to prioritize either the Wired or Wireless 
connection. The BrightSign player will always attempt to download and upload using the first option. It will 
only use the second option if the first is unavailable. 

c. Time zone: Select the time zone where the unit is located. 
d. Time server: Select the clock for this unit. 

4. Click the Advanced Network Setup button to customize advanced settings for your networked player. Specify the 
following in the Unit Configuration tab: 

a. Use Proxy: Check this box if you want to use a proxy server. Type the address and port number in the fields 
below. 

http://www.brightsign.biz/products/accessories/wireless-module/�
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5. Specify the following in the Wired and Wireless tab of the Advanced Network Setup window: 
c. Data Types Enabled: Use these checkboxes to determine the types of data that will be downloaded using 

the connection. 
d. Connection Settings: Indicate whether the IP address is auto-generated or static. If you’re using a static IP 

address, enter the parameters in the fields below. 
6. Click Specify Firmware Update to indicate whether you want to update the firmware and to which version.  
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The Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign 
unit, select a firmware version or Do not update, and then click OK. 

7. Under Unit Configuration, click Standalone, and then specify the following: 
• (Optional) Enable diagnostic web server: Check the checkbox to enable the diagnostic web server. You 

can include a username and password in the text fields below for added security. 
• (Optional) Enable local web server: Check the checkbox to enable the local web server. You can include a 

username and password in the text fields below for added security. 
• (Optional) USB Content Update Password: Enter a password in the field to enable password protection for 

USB content updates. This feature helps to ensure that a player will not be assigned incorrect schedules or 
data when updated via USB. 

8. Under Logging, check any of the following checkboxes to enable/disable logs and specify upload settings: 
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a. Enable playback logging: Creates a log that records start and end times, zone names, media types, and 
file names. 

b. Enable event logging: Creates a log that records timestamps, state names, zone names, event types, and 
event data. 

c. Enable state logging: Creates a log that records current and last state names, timestamps, and media 
types. 

d. Enable diagnostic logging: Creates a log that records timestamps, firmware and script versions, and the 
current presentation. 

e. Upload logs 
o On startup: Uploads log files each time you start the unit. 
o At specific time each day: Uploads log files daily at the specified time. Use the dropdown lists to 

pick a time. 
o Relative URL for log handler: Type the location where you want logs to be uploaded. 

9. Create and install the setup files: 
a. Click Create Setup Files. 
b. Browse to and select an SD card (recommended) or USB flash drive (HD810, HD1010, HD1010w, HD1020, 

XD1030, and XD1230 only) to store the setup files. 
c. Click OK. 
d. Turn off the BrightSign unit by unplugging the power adapter. Insert the card or flash drive into the unit. 
e. Turn on the BrightSign unit by reconnecting the power adapter. 

Important: Do not remove the SD card or flash drive from the player.  



24 
 

CHAPTER 3 – CREATING PRESENTATIONS 

Creating a Full-Screen Presentation 
In a full-screen presentation, your images and/or videos occupy the entire screen. 

1. Create a new presentation project by navigating to File > New Presentation. 
TIP: If you don’t see New Presentation under File, make sure you have the Edit, Publish, or Manage tab selected in 
the upper-left portion of the screen. 
2. Specify the following in the New Project window. 

a. Save as: Enter a name for the presentation.  
b. Where: Select the folder where you want to store the 

presentation. Click Browse to navigate to the desired folder. 
c. BrightSign model: Select the model number of the 

BrightSign player(s) to which you will publish this 
presentation. 

d. Connector type: Select either HDMI, VGA, or Component. 
e. Screen resolution: Choose the resolution that best matches 

the native resolution of your monitor. You can view all 
available screen resolutions on the Support Section of the 
BrightSign website. 

Note: If you select HDMI or Component in the Screen 
resolution menu, you will see several options that are only 
compatible with component or composite (rather than VGA or 
HDMI) signals. See this FAQ for more information on generating 
component/composite signals. 
f. Monitor Orientation: Choose whether you would like the 

content to appear in Landscape or Portrait mode. BrightSign 

http://support.brightsign.biz/entries/22929977-can-i-use-component-and-composite-video-with-brightsign-players�
http://support.brightsign.biz/entries/275113-what-video-output-resolutions-are-supported-by-brightsign-players�
http://support.brightsign.biz/entries/22929977-can-i-use-component-and-composite-video-with-brightsign-players�
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players do not automatically rotate landscape content to display in Portrait mode (and vice versa). You will 
first need to rotate video or images in the source application (e.g. Paint Shop Pro Photoshop, Adobe After 
Effects) before publishing them to the player. 

g. Monitor overscan: Select a setting to determine how the image fills the display screen. 
• No overscan – use full screen: Displays images/video to the edge of the video signal. 
• Overscan – action safe: Restricts the image display to an area that is compatible with most displays. 
• Overscan – title safe: Restricts the image display to an area that is much smaller than the image 

generated by the video signal. 
Tip: For best results, experiment to find the overscan setting that works best with your display. 
Click Create. 

2. Click the Full screen template, and then click Choose. 
3. Add media to your Library: 

a. In the left portion of the screen, under the File tab, click Browse. 
b. Navigate to the folder where your content is stored. 
c. Click OK. 

Note: If you have a lot of large files in your content folder, it may take a while for the thumbnail images to appear. 
4. Add media files to your presentation by dragging files from the Media Library folders to the playlist area. Make sure 

you have the Files tab selected under Media Library. 
a. To select a series of adjacent media files, press Shift+Click as you select the files. 
b. To select a group of non-adjacent files, press Ctrl+Click as you select the files. 
c. To set the order in which the files play, drag them to the Playlist area in the proper order. You can change 

the order of files already in the playlist by clicking a file and 
dragging it to a new position. 

d. To refresh the Media Library folders, click the        refresh icon 
(next to the Browse button). 

e. To remove an item from a playlist, click it in the playlist area and 
press Delete on your keyboard. 

f. To change media files in the playlist without individually deleting 
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and dragging, click File > Replace media files. In the Replace Media Files window, click Browse to select 
the folder that contains the files you want to add. This can be the same folder used in your Media Library or 
a new folder. A list of all files currently added to the playlist is displayed below Presentation Media Files. 
For each file you want to replace, select a new file using the dropdown lists beneath Replacement Media 
File. 

g. To create interactive events, see Making a presentation interactive.  
2. (Optional) Rename the playlist: 

a. Click Edit in the upper-right corner of the playlist area. 
b. Enter a new name for the playlist. 
c. Click OK. 

6. (Optional) Set playback options: 
a. To edit settings for a single item, right-click the thumbnail in the 

playlist area, select Edit, and then choose the settings you want to 
apply to the selected item. 

b. To edit settings for multiple items, press Ctrl+Click to select the items in the playlist area. On the menu bar, 
click Edit > Selected Items, and then choose the settings you want to apply to the selected items. 

7. On the menu bar, click File > Save… to store your presentation. 
Note: Make sure you have the Edit tab selected in the upper-left portion of the screen. To save the presentation with a 
different name or in a different folder, select File > Save… As. To export the presentation and associated content, 
select File > Export…. 

 

Creating a Multi-Zone Presentation 
In a multi-zone presentation, BrightAuthor divides the screen into rectangles called zones. You can play different content 
in each zone, and each zone supports a specific type of content. BrightAuthor provides a handful of multi-zone templates. 
You can choose one of the existing templates, or create your own (see Customizing presentations for more details).  
 



27 
 

When using a multi-zone template, you need to know which type of content you can include in each zone. The color-
coded key at the bottom of the template screen shows the available content types, and the color-coded templates indicate 
which type of content you can include in each zone of the templates. The following list describes the available content 
types: 

• Images      : Plays images. You can include multiple Images zones. 
• Ticker       : Plays an RSS feed or pre-defined text strings. You can include multiple Ticker zones. 
• Clock      : Displays the time or date. You can include multiple Clock zones. 
• Video or Images      : Plays videos and images. 
• Video Only     : Plays videos. 
• Audio Only      : Plays audio. You can include multiple Audio Only zones. 
• Background Image      : Places an image in the background of your presentation. All other zones appear on top of 

the background image. When using a background image, you cannot include a Video Only zone or a Video or 
Images zone. You can include only one Background Image zone. 

Note: BrightSign XD230, XD1030, or XD1230 players can decode two videos at once. Therefore, if you are creating a 
presentation for an XD player, you can include two “Video or Images” zones, a “Video or Images zone” and a “Video 
Only zone”, or two “Video Only” zones. If you are using an HD player, you can include only one video zone per 
presentation. Therefore, you must choose between a Video or Images zone, a Video Only zone, or a Background 
Image zone. The HD series cannot display more than one of these zone types in the same presentation. 
1. Create a new presentation project: 

a. Select File > New Presentation 
Tip: If you don’t see New Presentation under File, make sure you have the Edit, Publish, or Manage tab 
selected in the upper-left portion of the screen. 
c. In the New Project window, enter a name for the presentation in the Save as field.  
d. In the Where field, enter the folder where you want to store the presentation. Click Browse to navigate to 

the desired folder. 
e. Select your BrightSign model, Connector type, Screen resolution, and Monitor orientation. 
f. Select a Monitor overscan setting to control how the image fills the display screen. 

• No overscan: Displays images/video to the edge of the video signal. 
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• Overscan - action safe: Restricts the image display to an area that is compatible with most displays. 
• Overscan – title safe: Restricts the image display to an area that is much smaller than the image 

generated by the video signal. 
Tip: Experiment to find the overscan setting that works best with your display. 
g. Click Create. 

2. Click the multi-zone template you want to use, and then click Choose. 
3. Add media to your Library: 

a. In the left portion of the screen, under the File tab, click Browse. 
b. Navigate to the folder where your content is stored. 
c. Click OK. 

 
Note: If you have a lot of large files in your content folder, it may take a while for the thumbnail images to appear. 
4. Add content to the zone playlist: 

a. Click the zone you want to populate. 
Note: Each zone has its own playlist. 
b. Under the File tab, drag items from the Media Library folders to the playlist area. Click Browse to change 

the Media Library folder. 
• To select a series of adjacent media files, press Shift+Click as you select the files. 
• To select a group of non-adjacent files, press Ctrl+Click as you select the files. 
• To set the order in which the files play, drag them to the Playlist area in the proper order. You can 

change the order of files already in the playlist by clicking a file and dragging it to a new position. 
• To refresh the Media Library folders, click the        refresh icon (next to the Browse button). 
• To remove an item from a playlist, click it in the playlist area and press Delete on your keyboard. 
• To change media files in the playlist without individually deleting and dragging, click File > Replace 

media files. In the Replace Media Files window, click Browse to select the folder that contains the 
files you want to add. This can be the same folder used in your Media Library or a new folder. A list of 
all files currently added to the playlist is displayed below Presentation Media Files. For each file you 
want to replace, select a new file using the dropdown lists beneath Replacement Media File. 
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• To create interactive events, see Making a presentation interactive.  
5.  Repeat step 4 for each zone in the presentation. 
6. Click the Layout tab to add new zones or adjust the position of your zones. To add a new zone, click the Add 
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Zone button. In the New Zone window, type a name for the zone in the Zone name text field, and select a zone 
type. Click OK. To adjust the position and size of zones, drag and 
resize in the preview in the right portion of the screen. See 
Customizing template layouts for further details. 

7. (Optional) Rename the playlist: 
a. Click Edit in the upper-right corner of the playlist area. 
b. Enter a new name for the playlist. 
c. Click OK. 

8. (Optional) Set playback options: 
a. To edit settings for a single item, right-click the thumbnail in the playlist area, select Edit, and then choose 

the settings you want to apply to the selected item. 
b. To edit settings for multile items, press Ctrl+Click to select 

the items in the playlist area. On the menu bar, click Edit >Selected 
Items, and then choose the settings you want to apply to the selected items. 

9. (Optional) Set zone properties. See Setting zone properties for details. 
10.  On the menu bar, click File > Save… to store your presentation. 
Note: Make sure you have the Edit tab selected in the upper-left portion of the screen. To save the presentation with a 
different name or in a different folder, select File > Save… As. To export the presentation and associated content, 
select File > Export…. 

 
HTML5 
You can use the BrightSign XD230, XD1030, or XD1230 player to display HTML5 web pages, including video, image, 
text, and JavaScript elements. For a full explanation of how to create and publish HTML5 content for BrightSign players, 
please see the HTML5 User Guide. 

http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting�
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Note: You can display HTML5 pages in Images zones and Video or Images zones. HTML5 video content that is 
embedded in an Images zone will still play. 

• State name: Specify a name for the HTML5 state. 
• Local Content: Select this option if you plan on publishing HTML5 content using page and media files located on 

the local storage of your computer. Click the browse button to locate the .htm file that you wish to display. 
• URL: Select this option if you wish to play an HTML5 page from a web address. 
Note: BrightSign XD players are not designed to be used as general-purpose web browsers. Many web pages have 
elements that will not display correctly on a BrightSign player. Make sure to thoroughly test a web page before using it 
as digital signage.  
• Enable external data: Check this box if your HTML5 page uses assets from multiple locations. 
• Enable mouse and touch events: Check this box if you want to enable interaction with the HTML5 page (clicking 

on links, interacting with JavaScript elements, etc.). See the above warning about using an XD player as a web 
browser. 

• Display cursor: Displays the cursor if you are using a mouse with your XD player. 
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RSS, Text, and Media RSS Feeds 
Networked BrightSign players can include RSS feeds. These can include standard RSS (text) or Media RSS (feeds that 
contain video or images). Alternatively, you can create your own text feeds and add them to a Ticker zone like an RSS 
feed.  
Note: Text feeds are static, whereas RSS and Media RSS feeds are updated each time the BrightSign connects to the 
server. This is ideal for instant updates from sources such as Twitter. 
 
Text Feeds 

1. Create a .txt file (using Notepad or a similar program) that contains the text you wish to display.  
a. Insert a line break between each text item in the .txt file.  
b. Save the text file and place it in your Media Library folder.  

2. Select a Ticker zone in your presentation.  
a. Click the Text tab.  
b. Drag the text file into the playlist. 

3. Repeat this step to add additional text files. 
 
RSS Feeds 

1. Select a Ticker zone in your presentation. 
2. Click the RSS tab and drag the       New RSS Feed icon into the playlist. 

a. Select a data feed from the dropdown list.  
b. Click OK.  

 
If you need to define a new data feed, click the Add Data Feed button. To learn more about creating new data feeds, see 
the Setting Presentation Properties section. If you want to add a Twitter feed, drag the Twitter icon into the playlist. When 
prompted, enter your Twitter User Name and click OK. 
Note: You can include multiple Ticker zones in your presentations. To adjust the update frequency for RSS feeds, click 
File > Presentation Properties. Under the Main tab, use the dropdown list beside RSS Update Frequency. 
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Media RSS Feeds 

1. Click the Other tab below Media Library. 
2. Drag the        Media RSS Feed icon to the playlist area.  

a. When prompted, enter the URL for the feed. 
b. Click OK. 

 

Live Video and SignChannel 
BrightSign models HD810, HD1010, and HD1010w support Live Videos using the Live Video Module. The XD1230 
supports Live Video through the HDMI Input port. All networked players support SignChannel content. A subscription is 
required to use SignChannel. 
 
Live Video 
Select a Video or Images or Video Only zone. Under the Other tab, drag the         Live Video icon to the playlist area. To 
edit the video volume and time on screen, double-click the thumbnail in the playlist area. When prompted, make the 
desired edits. 
 
SignChannel 
Under the Other tab, drag the          SignChannel icon to the playlist area.  
Note: SignChannel content can only be in one zone of your presentation. 
 

http://www.brightsign.biz/products/xd-product-line/xd1230/�
http://www.signchannel.com/�
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Dynamic Playlists 
A Dynamic Playlist enables you to easily update and share content in multiple presentations. For example, if you need to 
add daily announcements to your presentations and you don’t want to update each presentation separately, you can add 
a Dynamic Playlist to all of your presentations and insert a new video announcement in the Dynamic Playlist each day. 
When you upload the revised Dynamic Playlist to the network, every presentation that includes the Dynamic Playlist 
receives the new content, so a single update reaches multiple presentations.  
Note: To use Dynamic Playlists, you must have a BrightSign Network account. 
 
Creating a Dynamic Playlist: 

1. Click the Create tab in the upper-left portion of the screen. 
2. On the menu bar, click File > New Dynamic Playlist. You can also open previously created Dynamic Playlists by 

clicking File > Open Dynamic Playlist. You can then make edits to the playlist. 
3. Add files to your Media Library by clicking the Browse button and selecting a folder that contains the files you want 

to include in your Dynamic Playlist. 
4. Drag the files to the playlist area. 
5. Click the Upload to Network button in the upper-right portion of the screen. 
6. You will be prompted to save the playlist. Click Yes. The Save As window will open. Type a name for your playlist 

and click Save. The Save Complete window will open. Click OK. The playlist will now upload onto the BrightSign 
Network. Click OK. 

Now all presentations that contain the Dynamic Playlist will automatically receive the new content. You can change the 
content of the Dynamic playlist at any point by opening the playlist (File > Open Dynamic Playlist) and dragging new 
media files into the playlist area. 
 
Adding Dynamic Playlists: 

1. Open a presentation project. 
Note: If you don’t see Open Presentation under File, make sure you have the Edit, Publish, or Manage tab selected 
in the upper-left portion of the screen. 

http://www.brightsign.biz/products/brightsign-network/�
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2. Click the Edit tab. 
3. Under the Other tab, drag the          Dynamic Playlist icon to the playlist area. 
4. The Add Dynamic Playlist window will open. From the drop-down list, select which Dynamic Playlist you want to 

link to the current presentation. Click OK. 
 

Local Playlists 
A Local Playlist allows you to customize which Dynamic Playlist is used in a presentation depending on the player. For 
example, if you are using BrightSign players at a dozen different locations, and the presentations are the same except for 
variations in the content of the Dynamic Playlists, you only need to create, edit, and update one presentation that uses a 
Local Playlist rather than a dozen that use different Dynamic Playlists. 

1. Click the Other tab in the Media Library. 
2. Drag and drop a Local Playlist where you would normally add a Dynamic Playlist. 
3. Enter a unique State name. 
4. Select a desired Default playlist. If no Dynamic Playlist is assigned to a player in a Local Playlist, then the player 

will automatically use the Default playlist instead. 
Note: If a player is not assigned a Dynamic Playlist and no default is set for the Local Playlist, then the player will skip 
to the next item in the presentation. 
5. Select the desired Playlist for each player connected to your BrightSign Network Account. 
6. Click the OK button to save changes. 

 

Video and Mjpeg Streams 
All networked players can play Video and Mjpeg streams. 

• State Name: Specify the unique name for the stream state. 
• URL for video stream: Enter a valid URL for the stream. 
• Rotation (Mjpeg only): Specify the clockwise rotation of the streaming video. 
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• Time on screen: Specify the duration (in seconds) that the stream will be played. This option is only available in 
non-interactive presentations. To customize the duration of a stream in an interactive presentation, use a Timeout 
or Media End event. 

 

RF In (ATSC) 
Use this feature to display live video that is passed to the BrightSign player through the RF Input. This feature is available 
only on the XD1230. When creating a new RF In state, you will need to specify a Channel from the dropdown list. You 

can create channels by clicking the Add Channel button in the RF In window or by selecting Tools > ATSC Setup on the 
menu bar. 

• Name: Enter a unique name for the ATSC channel. You will see this name when selecting a channel in the RF In 
window. 

Note: If you do not have the information to fill out the following fields, see this support article for help. If you are 
connecting your player to a ZvBox, see the ZeeVee Configuration Tech Note on the BrightSign Support Website for full 
configuration information. 

http://www.brightsign.biz/products/xd-product-line/xd1230/�
http://support.brightsign.biz/entries/22908178-how-do-i-find-atsc-channel-settings-for-my-xd1230�
http://support.brightsign.biz/entries/314526-brightsign-user-guides-troubleshooting�
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• Frequency: Enter the frequency of the ATSC channel. If the frequency is measured in megahertz(MHz), you will 
need to convert the value to Hertz(Hz): For example, a frequency of 57.00MHz would be entered into this field as 
57000000Hz.  

• Encoding: Select the coding of the ATSC channel from the dropdown list. 
• Video PID: Enter the Video PID of the ATSC channel. 
• Audio PID: Enter the Audio PID of the ATSC channel. 
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CHAPTER 4 – MAKING A PRESENTATION INTERACTIVE 

You can use BrightAuthor to create interactive presentations. Interactive presentations respond to interactive events, such 
as input from buttons or other GPIO devices, or from devices connected to a BrightSign communication port. The 
supported communication methods vary by BrightSign model: 

• RS232 serial devices: HD410, HD810, HD1010, HD1010w, HD1020, XD1030, and XD1230 
• USB devices (such as touch screens, mice, keyboards, barcode scanners, IR remote controls): HD810, 

HD1010, HD1010w, HD1020, XD1030, and XD1230 (see Appendix A for remote control codes) 
• Ethernet devices: HD210, HD210w, HD220, HD1010, HD1010w, HD1020, XD230, XD1030, and XD1230 

 
To make your presentation interactive, complete the following steps: 

1. Open a presentation project. If you haven’t already created a presentation, see Creating Presentations for details. 
2. Add files to your Media Library by clicking the Browse button and selecting a folder that contains the files you want 

to include in your presentation. 
3. Click a zone you want to make interactive.  
Note: Multi-zone presentations can include both non-interactive and interactive zones. 
4. Make the zone interactive. In the upper-right portion of the screen beside Playlist type, click Interactive. 
5. Drag the desired content into the playlist area. 
6. Choose a Home Screen. The Home Screen is the first media file in the playlist. It is where the interactive 

presentation begins (within a particular zone). Home Screens usually include one of the following: 
• An attract video that loops until the user provides input 
• A list of options from which the user can choose the next action (e.g. an Interactive Menu) 

 By default, the first item you drag into an interactive playlist will become the Home Screen. It is identified by the    
       Home icon. You can change the Home Screen at any time by double-clicking the desired file in the playlist and 
 checking the Set as initial state box.   

7. Define Interactive events. Interactive events link files in the playlist and determine what must occur before a file 
transitions to another file. In the user interface, files are referred to as “states,” where the current file is the “current 
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state,” and the file transitioned to is the “next state.” In this guide, creating and linking interactive events between 
states will be referred to as “defining events”: 

a. In the Event Toolbar, click the interactive event icon that corresponds to the type of event you want to 
define. For example, to define what happens when a user presses button 1 on a button board, click         . 
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b. Click (and hold) the file name below the thumbnail image of the current state. This media file is what the 
user sees before performing the interactive event you are about to define. 

Note: The first interactive event must begin with the Home Screen. 
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c. Drag the hand pointer to the thumbnail image of the media file you want to play next (the next state). 
d. Repeat steps a – c to define the remaining interactive events. 

 
Subsequent interactive events can start with any item and correspond to any other item in the playlist. For example, you 
can set the first interaction to display an image when the user presses button 1 from the Home screen. By defining a new 
event with the same event icon, you can set a second interaction to display another media file when the user presses 
button 1 again. 
 
Note: Make sure your defined events work in a loop. In the above screenshot, a user can transition from the Home 
Screen to the other images by pressing button 1 or button 2. After a set period of time (indicated by the timeout events), 
the presentation will return to the Home Screen. 
 
You can utilize multiple interactive events to transition from state to state. 
You can also apply events to multiple items. Right-click and drag the cursor 
within the playlist area to create a selection box. Define the interactive event 
from one media file, and it will then be created for all selected files. To select 
non-consecutive files, press and hold Ctrl while clicking items. 
 

Customizing the Interactive Playlist 
In the upper-right portion of the screen, you can use the Zoom control to adjust your view of the playlist area. When you 
switch between multiple interactive zones, BrightAuthor will remember the zoom setting last used for each zone. 
 
If you don’t see the event you want in the playlist toolbar, click the arrow to the left of the Zoom control. Here, you can add 
or remove event icon buttons from your toolbar. You can also access Event icons by clicking the Events tab under Media 
Library. 
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Editing Interactive Events 
When creating an event with an Event icon from the Events tab, drag the Event icon onto the thumbnail of the media file 
you want to be the current state. An Event window will automatically open. Here, you can specify which media file you 
want to be the next state. 
 
You can further adjust how your media files transition from state to state by double-clicking the Event icons (or right-
clicking and then clicking Edit). For example, if you create an event with the Timeout Event icon, the media file displayed 
in your presentation will transition to the next state after a certain period of time. You can adjust this time period by 
double-clicking the Timeout Event icon between the two media files and changing the duration in the Timeout Event 
window. 
 
The Event window that opens when double-clicking a created Event icon is the same window that automatically opens 
when you drag an event icon from the Events tab. The window always presents options specific to the type of interactive 
event chosen. However, every Event window displays the following options: 

• Transition to new state: Use the dropdown list to specify which file in the playlist will be the next state. 
• Return to prior state: If you select this option, the presentation will revert to the previous media file when the 

interactive event is performed. 
• Remain on current state: If you select this option, the state will not change when the interactive event is 

performed. This option is useful for creating changes within one media file. You can create these changes by 
adding commands. See Adding Commands for details. 

• Advanced: Click the Advanced tab to reveal the display options and commands section. Here you can set how 
you view the interactive events between states in the playlist area. Show line draws a line between the media files. 
Show label creates a label either to the Right or Bottom of the media file, indicating transitions from states. See 
Adding Commands for details on commands.  
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Editing Media Properties 
You can edit individual files in the playlist by right-clicking and then clicking Edit. The Media Properties window will open. 

 
Here, you can view/change the State name and Current file. Use the dropdown list beside Select different file to swap 
the file with another in the playlist area. This is convenient for keeping the interactive events you have defined with the 
original file. You can also replace media files under File > Replace Media Files. See Creating Presentations for details.  
 
Use the dropdown list beside Transition to create a special transition effect when the file appears on the display. Check 
the Set as initial state checkbox to change the file to make the file the Home Screen. Use the dropdown list beside 
Transition (image files only) to create a special effect for the image. Click the Advanced tab to store the image in a 
cache, set display mode for video files (2D, 3D side-by-side, 3D top-over-bottom), or add commands. See Adding 
Commands for details. 
Note: You can delete a defined event (or file) at any time by clicking the icon/thumbnail and pressing Delete on your 
keyboard. 
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Media Lists and Play Files 
Media Lists and Play Files are convenient tools for defining interactive events with many files. They allow you to compile 
your files into one group that appears as a single thumbnail in your playlist area. Only files of the same type can be 
gathered in a Media List or Play File. Therefore, both are divided into three categories for each media type: 
 

• Media Lists: Image List, Audio List, and Video List. 
• Play Files: Image Play File, Audio Play File, and Video Play File. 

 
Under the Other tab, there is an icon for each list and file type. To create a Media List or Play File, drag the appropriate 
icon into the playlist area of a corresponding zone. 
 
Media List 
By default, each time an item transitions to a Media List, the next file in the list will play and exit the list after a timeout 
(images) or when the file finishes playing (video and audio). Alternatively, you can set the list to shuffle files or cycle 
through every file in the list before exiting and transitioning to the next state.   
 
After you set your zone to Interactive and drag a Media List icon into the playlist area, the List window will automatically 
open. Here you can set the following parameters for your List: 

• Media list name: Create a unique name for the list. 
• Set as initial state: Check this box to make the list your Home Screen. 
• Advance to next item on media end event: Check this box to set the list to cycle to the next file in the list after a 

timeout or media end event. If you leave this box unchecked, the list will play one file each time it is transitioned to 
and select the next file in the list upon subsequent transitions. 

Note: If you are creating an Image List, this parameter will say Advance to next item on Image Timeout instead. 
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• Image Timeout (seconds): This option is only available if you are creating an Image List. You can specify the 
length of time each image remains on screen. You can also use decimal values to specify the image timeout in 
milliseconds (for example, 1.500 = 1500msec). 

• Play from beginning on entry to state: Check this box to set the list to play from the beginning upon entry into 
the list. This box is only enabled if you have checked the above Advance to next item on media end event. If you 
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leave this box unchecked, subsequent transitions to the list will play the next file in the cycle after a user exits the 
list (for example, by using a command). 

• Shuffle playback: Check this box to randomize the order in which files are played from the list. 
• Event to transition to next item: Select an interactive event that allows the user to transition to the next file in the 

list. After selecting the event type, you must specify a trigger. 
• Event to transition to previous item: Select an interactive event that allows the user to transition to the previous 

file in the list. After selecting the event type, you must specify a trigger. 
Note: If you leave event transitions on the default, timeouts and media end events will automatically cause transitions. 
• Media Library: Click Browse to select the folder that contains all the files you want to include in the list. 
• Media Files: Add individual files to the list by clicking the Add File button and using the dropdown list. Only files 

contained in the folder you selected above will be available in the dropdown list.  
• Commands: Add commands to the list. See Adding Commands for details. 

 
You can edit properties of your Media Lists under File > Presentation Properties > Media List. See Setting presentation 
properties for details. 
 
Play File 
Play Files also combine files into a list you can view in one window (or as one thumbnail in the playlist area). However, 
Play Files function quite differently from Media Lists. They allow transitions to specific files within the group. In addition, 
any type of interactive event can cause a transition to a Media List. Play Files, on the other hand, can only be transitioned 
to via input from BP900/BP200, UDP, Serial, Keyboard, or USB. However, any type of event can transition out of Play File 
and to a new state. 
 
Make sure you use zones that match the Play File type you want to use. After setting your zone to Interactive and 
dragging a Play File icon to the playlist area, the Play File window will automatically open. Here you can set the following 
parameters for your List: 
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• State name: Create a unique name for the Play File. This name will show up in the thumbnail in the playlist area. 
• Transition (Image Play Files only): Use the dropdown list to create a special effect when a user transitions to an 

item in the Play File list. 
• Files: This list displays files added to your Play File. Each file has a Key and File Path. 

o Key: The key is the specific interactive event that will cause a transition to a particular file. Because you 
define the interactive events with the keys in the Play File, you do not need to specify the events again when 
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creating a transition to the Play File. For example, if you define a USB Input event that links an item to the 
Play File, the option to Specify USB Input will be disabled and replaced with <any>. When a user performs 
an event via USB that matches a key, the corresponding file will play. 

o File Path: This is the location of the file on your computer. 
o Display Mode: Only Video Play Files have a display mode. By default, files are set to 2D, but if you are 

using a 3D video, you can select 3D side-by-side or 3D top-over-bottom when adding your files. 
• Add File: Click this button to add items to the Play File. Here, you can specify the Key, File Path (use the Browse 

button to navigate to the desired file), and Display Mode if using a video file (use the dropdown list to select a 
display mode). Click OK when finished. 

 
• Import Table: Click this button to import a previously created list of files. Navigate to your saved table and click 

Open to add the files to your Play File list. This table must have the Key, File Path, File Name, and Video Display 
Mode (if applicable) properly outlined. For a detailed explanation on importing a table for a Play File state, read the 
article on our website. 

• Commands: Add commands to your Play File here. See Adding Commands for details. 
 

Click OK when you are finished. 
 

http://brightsign.zendesk.com/entries/21135706-how-do-i-create-and-import-a-table-for-a-play-file�
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Live Text 
This feature allows you to customize content for more engaging presentations. Live Text is an image laced with various 
text and/or image fields. Live Text allows you to layer both static and updateable RSS and Media RSS content on top of 
images or videos and customize the position/size of items in relation to the background. 
 
Live Text –To use Live Text, drag the Live Text icon from the Other tab to the playlist area and set the following 
parameters: 

• State name: Type a unique name for the Live Text state. 
• Set as initial state: Check this box to make the Live Text state your Home Screen. 
• Background Image: Click Browse to locate and select a background image for your Live Text. 
• Update Live Text Data: Click this button to immediately update all RSS feeds. 
• Size: Adjust the size of your text fields. W corresponds to the width of the text field, and H corresponds to the 

height of the text field. 
• Position: Adjust the position of your text fields. X corresponds to the position of the text on a horizontal axis. Y 

corresponds to the position on a vertical axis. 
Note: Input numbers in the Size and Position fields for more precise results. Alternatively, you can click and drag the 
text fields in the preview to adjust size and position. 
• Offset next: Check this box to automatically set a position for subsequent text items in relation to the most recent 

text item. Input the distance for the next text item in the X and Y fields. 
• Type: Use the dropdown list to select Fixed Text, System Variable, Live Text Data, Media Counter, or User 

Variable, RSS Feed, Media RSS Feed, or Image. 
a. Fixed Text: Select this option if you want to enter your own text. A text field will appear below Text Type 

where you can type your customized text. As you type, you can view the text in the preview image. 
b. System Variable: Select this option to display the device serial number, firmware version, or script version. 

Use the dropdown list to determine which value you would like to display. 
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c. Live Text Data: Select this option if you want to use an updateable RSS feed in the text field. Select the 
desired RSS feed from the dropdown list in the Live Data Feed Name field 
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Note: Feeds that appear in this dropdown list must first be created in the Data Feeds tab, which can be 
accessed through File > Presentation Properties. For more details on creating and customizing RSS feeds, 
see Setting Presentation Properties.  

If you know the exact title of the item you want, input it in the Item title field. Or, if you know the index 
number, input it in the Item index field. When using the Item index, subsequent RSS text fields will 
automatically contain the next item in the index (i.e. the previous index number + 1). 

d. Media Counter: Media Counters display how many times a file in the presentation has played. Each Media 
Counter field must correspond to a specific file. Use the dropdown list to pair the Media Counter field with a 
file in the presentation. To use this feature, Media Counters must first be enabled. Navigate to File > 
Presentation Properties > Variables. Then check the box labeled Automatically create media counter 
variables. 

e. User Variable: User Variables are customizable values that can be used in commands. User Variables in 
Live Text display the current value of the specified User Variable. Use the dropdown list to specify a User 
Variable for the text field. To use this feature, you must first create your User Variable(s).  

f. RSS Feed: Select this option to display an RSS feed. Click the Update RSS URL List button to create a list 
of Data Feeds to use as RSS. You can also choose whether you would like to display only the RSS title or 
display only the RSS description. You can only uncheck the title or description option if you do not have 
that field currently selected.  

g. Media RSS Feed: Select this option to display an RSS feed. Click the Update RSS URL List button to 
create a list of Data Feeds to use as Media RSS. You can also choose among displaying the RSS title, RSS 
description, and RSS image. You can only uncheck an option if you do not have that field currently 
selected. 

h. Image: Select this option to display another image over the background image. Select Browse to locate an 
image file to use in this item. 

• Validate Live Text Data: Click this button to verify that the source URL for your feed is valid. 
• Layer: Use these buttons to determine the layering of your Live Text elements. The background image will always 

be behind all other elements. 



52 
 

a. Sends the selected element behind all other elements. 
b. Sends the selected element behind the element that is directly beneath it. 
c. Sends the selected element in front of the element that is directly in front of it. 
d. Sends the selected element to the front of all other elements. 

• Set Text Parameters: While an individual text field is selected, click this button to edit parameters for that text field. 
Subsequent text fields will automatically contain the text parameters of the previous text field. You can edit the 
Number of lines, Rotation, Alignment, Foreground text color, Background text color (this appears behind the text 
field), Transparency (for background text colors), Font, and, under the Advanced tab, the Background Bitmap and 
Safe Text region. See Setting zone properties for details on text parameters.  
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o You can change the default text parameters in the Edit Preferences window: Go to Edit > Preferences and 
click on the Live Text tab. Changes to the default text parameters only apply to future Live Text states; changes 
to preexisting Live Text states will need to be made manually. 

o BrightAuthor 2.5 and earlier versions required a Background Text Color for each text field. Now you can use the 
checkbox beside Background Text Color to decide whether you want to include a Background Text Color. If you 
choose to include one, the Transparency setting will become enabled and you can edit the transparency of the 
Background Text Color. If you choose not to include a Background Text Color, characters in the text fields will 
appear directly over the background image.  

• Add Item: Click to add a new text field. Select the text field in the preview image and edit the parameters as 
explained above. 

• Previous/Next: Click these buttons to quickly switch between text fields.  
• Advanced: Click to add commands. See Adding Commands for details. 

 
As mentioned earlier, Live Text can be layered over both images or videos.  
 
Live Text Images 
If you want to use a still image behind your Live Text, you should add the Live Text to an Images zone. Complete the 
following steps for each zone you want to contain Live Text: 

a. Select an Images zone. Make the zone Interactive. Drag the Live Text icon from the Other tab. 
b. In the Add Live Text window, type a State name and then click Browse beside Background Image. Locate 

and select your desired background image file. 
c. Click Add Text Item. Adjust the Size and Position of your text field by clicking and dragging over the 

preview image, or inputting exact numbers in the corresponding fields. 
d. Select your Text Type and input the desired text. 
e. Click Set Text Parameters and edit text parameters as desired. See Setting zone properties for details on 

each parameter. Click OK when finished. 
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f. Repeat steps c through f for each text field. 
g. Click OK. 

 
Live Text Videos 
Layering Live Text over a video requires two zones because you cannot add Live Text to a Video Only zone. Instead, you 
can add Live Text to an Image zone, and place it on top of a Video Only zone. To help you position text over the video, 
you need an image file cut from the video you want to use. Complete the following steps: 

a. Under Layout, click Add Zone. Add a Video Only zone.  
b. Click Add Zone again and add an Images zone. Resize the Images zone so that it completely covers the 

Video Only zone. 
c. Click Playlist, and use the Zone dropdown list to select your Video Only zone. Drag the desired video file 

from the Media Library to the playlist area. Make the zone Interactive.  
d. Use the dropdown list to select the Images zone. Make the zone Interactive. Drag the Live Text icon from 

the Other tab. 
e. In the Add Live Text window, click Browse beside Background Image. Locate and select an image file 

taken from the video file used in the Video Only zone. 
f. Click Add Text Item. Adjust the Size and Position of your text field by clicking and dragging over the 

preview image or inputting exact numbers in the corresponding fields. 
g. Select your Text Type and input the desired text. 
h. Click Set Text Parameters and edit text parameters as desired. See Setting zone properties for details on 

each parameter. Click OK when finished. 
i. Repeat steps f through h for each text field. 
j. When all text fields are in place, click Clear beside Background Image. 
k. Click OK. 

 
Clearing the Background Image removes the image from the Image zone. The text fields will appear directly over the 
video. By temporarily including a Background Image taken from the video, you can better position the text fields in relation 
to the video playing behind the Image zone. 
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Interactive Menus 
Interactive Menus are DVD-style menus that users can navigate with interactive events. By linking separate media to 
items in the Interactive Menu, you can allow users to interactively transition to a new state of their choice. Because they 
can serve as a bridge to many items and outline everything available to the user, Interactive Menus make great Home 
Screens.  
 
To create an Interactive Menu, add a Video or Images zone to your presentation. Set the zone to Interactive and drag the 
Interactive Menu icon from the Other tab to the playlist area. The Add Interactive Menu window is divided into two tabs, 
General and Menu Items. 
 
General: In this tab, you will select an image for your Interactive Menu and define how a user navigates it. 

• State name: Create a unique name for your Interactive Menu. 
• Background Image: Click Browse to select an image you want to act as your menu display. 

Important: The background image is not simply a background for the actual menu items. It must contain all images and 
text you want displayed in the menu.  

• Set as initial state: Check this checkbox to set the Interactive Menu as the Home Screen. 
 
The Navigation section is where you define how a user navigates across the menu. Click the dropdown menu for each 
option (Up, Down, Left, Right, Enter, Back, Next clip, Previous clip) and select the type of event you want to utilize (GPIO 
Event, Serial input, etc.). A second dropdown menu or text field will appear. Specify the button or input you want to 
correspond to the action. 
 
Let’s say you want to define how to move Up in the menu, and you want to use a keyboard event. In the dropdown list 
across Up, select Keyboard Input. A text field will appear below where you can specify a button. Type “U” here. Now, 
when a user presses “U” on a keyboard, the cursor will move up along the menu items. You don’t need to define every 
possible action. You can simply leave the dropdown list on the default None. However, to create a more intuitive 
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experience between the user and menu, it might be best to define each possible action. The following actions can be 
defined in the Navigation section: 

• Up, Down, Left, Right: These are the primary actions a user will perform to navigate from one menu item to the 
next. 

• Enter: With this button, a user can select a menu item and transition to a state associated with that menu item. 
• Back: Once a user presses the defined input for Enter on a menu item, a state you have chosen in the Menu 

Items tab will play. However, if you define a Back button/input, the user can return to the menu at any point. 
• Next clip: If a user is viewing a media file associated with a menu item, pressing the defined input for Next clip will 

play the media file that corresponds to the next menu item. 
• Previous clip: Pressing the defined input for Previous clip will stop the media file currently playing, and play the 

media file associated with the previous menu item. 
• Advanced: Click this arrow to add commands to your Interactive Menu. See Adding Commands for details. Here 

you can also store the background image in a cache. Check the checkbox to save the background image for faster 
loading in the future. 
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Menu Items: In this tab, you will create the menu items and further specify how a user navigates across the menu.  
• Menu Item Number: Every menu item has a unique menu item number. The first you create is 1, the second is 2, 

and so on. Here, you can navigate between the menu items you have created by clicking the Previous and Next 
buttons. Everything else in the window corresponds to the menu item you have selected here.  

 
The Menu Items section is where you can create and adjust individual menu items. 

• Add Menu Item: Press this button to create a Menu item. The Add Menu Item window will open. There are two 
items, Active Image and Inactive Image. The Active Image serves as a cursor that visually informs the user what 
Menu item they are on. The Inactive Image is what appears beside the current menu item when the user 
navigates to a different menu item. Use the Browse buttons to select each image. Click OK to create the menu 
item. By default, subsequent menu items you create will contain the same Active and Inactive Images. 

Tip: If you want nothing to appear beside a Menu item when it is not selected, choose an Inactive image that matches the 
color of the background. 

• Position: Adjust the position of your Menu item by inputting specific numbers. The X field corresponds to the  
position of the menu item on a horizontal axis. The Y field corresponds to the position of the menu item on a 
vertical axis. Alternatively, you can click the active image in the preview image and drag it to the desired position. 
The inactive image will appear in the same spot when the menu item is not selected. 

• Offset next: Check this checkbox to specify a position for subsequent menu items in relation to the previous menu 
items. Input the data in the X and Y fields. 

• Selected Image: This is the active image you selected when creating the Menu item. Click Browse to change the 
image at any point. 

• Unselected Image: This is the inactive image you selected when creating the menu item. Click Browse to change 
the image at any point. 

• Store image in cache: Check this box to save the corresponding image in a cache so that you can use it more 
readily in the future. 
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The Navigation section is where you determine how a user moves from one menu item to the next. Although the actions 
were previously defined in the General tab, this is where you specify which menu item a specific action will bring a user. 
The possible actions are Up, Down, Left, and Right. In this section, each action has a dropdown list that displays the 
menu item number for each created menu item. By default, None is selected for each. 
 
Selecting a number in the dropdown list will allow the user to navigate from the current menu item to the specified menu 
item by performing the corresponding action. Let’s say you are adjusting the features of menu item number 1, meaning “1” 
is displayed between the Previous and Next buttons at the top of the window. If you click the dropdown list for the Down 
action and select 2, the user can now navigate from Menu item 1 to Menu item 2 by pressing the Down button. 
Remember, the buttons are whatever you previously defined in the Navigation section of the General tab. 
 
The Enter section is where you can determine what happens when a user presses the Enter button on a particular Menu 
item. Set the following parameters: 

• Play clip: Click the Browse button to select a file you want to play when the user presses the Enter button. If you 
select an image, the option to specify a timeout period will appear. 

• Transition to new state: Here a dropdown list contains all the media files previously placed in the playlist area of 
your zone. Select a file to allow the user to transition to that state after pressing Enter. 

• Return to prior state: If you select this option, the presentation will display the previous state when a user presses 
Enter. 

• Remain on current state: If you select this option, the state will not change when a user presses Enter. However, 
you can add commands to specify changes that occur while remaining on the Interactive Menu. Click the 
Advanced tab to reveal the commands section. See Adding Commands for details. 
 

Click OK when you are finished. Keep in mind that if you choose Transition to new state instead of Play clip, the state 
will not return to the Interactive Menu. 
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Event Handlers 
There are a variety of cases in which you might want your presentation to sit at a blank screen. The Event Handler fills the 
role of an empty placeholder in your presentation. Here are a few cases where an Event Handler would be convenient: 

• You want a blank screen for a Home Screen so no content will play until the presentation is activated. 
• You want to add a command that is performed before the first file in the presentation plays. 
• You want the presentation to sit at a blank screen when finished, instead of looping. 
• You want a video file to remain on the final frame upon finishing, instead of looping. 

 
Although Event Handlers contain no content, you can add commands and interactive events into and out of them. For 
example, if you set the Event Handler as the Home Screen and define a BP900 event linked from the Event Handler to 
the first presentation item, the display will sit at a blank screen until a user presses the BP900 button, and then the first 
item will begin playing. Alternatively, if you set an Event Handler as the Home Screen and add a Synchronize command to 
it, you can synchronize your presentations and/or displays before the first files begin playing. 
 
To use an Event Handler, click the Other tab under Media Library and drag the icon into the playlist area.  

1. State Name: Enter a unique name for the Media Handler state. 
2. Stop Playback: Check this box if you would like 

audio/video playback to end once a media file transitions 
to the Event Handler state. If this box is left unchecked, 
audio/video playback will continue after a transition to the 
Event Handler state and loop until the Event Handler 
state is exited. 

3. Set as initial state: Check this box if you would like to 
make the Event Handler the home state of the 
presentation. 

 



62 
 

Define interactive events into and out of the Event Handler as you would with any other state. See Making a presentation 
interactive for details. If you define a Media End event after a video and link it to an Event Handler, the video will remain 
on the last frame when finished. For other file types such as images or audio, the display will sit at a blank screen when 
the files finish playing. 

 
Commands 
Adding commands to your playlist allows you to add extended functionality to your presentations. Commands can help 
control displays and devices (Display On, GPIO On, etc.) or perform additional actions when interactive events are 
performed (Pause Video, Set Volume, etc.). 
 
You can add commands either to Interactive Events or to media files. If you add a command to the Interactive Event, the 
command will be performed when that event occurs. If you add a command to a media file, the command will be 
performed when the file plays (regardless of which state/event transitions to it).  

 
Adding Commands to an Interactive Event 
Double-click the event icon in the playlist area and click the Advanced tab. Click Add Command and use the dropdown 
list under Commands to choose the category of the command. Use further dropdown lists and fields to set additional 
Command Parameters. When adding a command to an interactive event, you can either select a Next State or choose 
to Remain on current state. 
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Adding Commands to a State or Media File 
Double-click the media file thumbnail in the playlist area and click the Advanced tab. Click Add Command and use the 
dropdown list to specify a command. Use further dropdown lists and fields to set additional parameters for the command.  
 
Note: There are a few other options under the Advanced tab. They will depend on the type of file you have selected. For 
image files, you will see a Store Image in Cache checkbox. Check this box to save the file in a cache and more readily 
use it in the future. For video files, you will see Video Display Mode. Depending on the type of video file, you can use the 
dropdown list to select 2D, 3D side-by-side, or 3D top-over-bottom. By default, 2D is selected. 
 
These are the commands you can add to your presentations: 
 
BP900/BP200 Set Output: Sends a command to a BP900 or BP200 button panel. Use the dropdown list to select the 
type and enumeration of button pad to use. See the chapter on BP900 and BP200 Button Panels for more details. 

• Button number: Use this dropdown list to choose a specific button number or to choose all buttons on the panel. 
• Action: Use this dropdown list to specify the behavior of the button. You can choose to turn the button on or off. 

You can also set the button LED to fast blink, medium blink, or slow blink. 
 
Set Audio: Changes the audio settings of a zone. 

Note: If you set a command to change the audio output or audio mode of a media file while it is playing, then the 
change will not go into effect until the media file is restarted or is played through again. 
• Zone: Specifies the zone to which the following settings will apply. 
• Audio Output: Enables or disables the Analog, HDMI, and SPDIF audio outputs. 
• Pass through: Supplies the un-decoded audio signal through the HDMI/SPDIF connector. Use this option if the 

presentation audio (for example, AC3 Dolby Digital) is being decoded on an external device. 
• PCM: Supplies the decoded audio signal through the HDMI/SPDIF connector. 
• Audio Mixing: Sends the stereo, left-only, or right-only audio signal. 
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Connector Volume: Changes the audio settings of a specific connector. 
• Set volume: Specifies the volume level. Select the Analog, HDMI, and SPDIF connector in the dropdown list and 

enter a volume value between 0 and 100 in the field. 
• Increment volume: Specifies how much the volume level increases with each interaction. Select the Analog, 

HDMI, or SPDIF connector in the dropdown list. 
• Decrement volume: Specifies how much the volume level decreases with each interaction. Select the Analog, 

HDMI, or SPDIF connector in the dropdown list. 
• Mute: Turns the connector audio output off. Use the checkboxes to select among the Analog, HDMI, and SPDIF 

connectors. 
• Unmute: Turns the connector audio output on. Use the checkboxes to select among the Analog, HDMI, and SPDIF 

connectors. 
 
Zone Volume: Sets the volume for a zone. Note that the Connector Volume command takes precedence over the Zone 
Volume command when both are used in a presentation. 

• Set: Specifies the zone to which this command applies. Enter a volume value between 0 and 100. 
• Increment: Specifies how much the volume level increases with each interaction. Use the dropdown menu to 

select the zone to which this command applies. 
• Decrement: Specifies how much the volume level decreases with each interaction. Use the dropdown menu to 

select the zone to which this command applies. 
 
Send: Sends information using the following methods: 

• UDP: Sends a command to the device using UDP protocols. 
• Send string (EOL): Sends the specified string to the specified serial port. This command adds a carrier return at 

the end of the string. 
• Serial string (no EOL): Sends the specified string to the specified serial port. This command does not add a 

carrier return at the end of the string. 
• Serial byte: Sends the specified byte to the specified serial port. 
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• Serial bytes (comma separated): Sends the specified bytes to the specified serial port in comma-separated 
format. 

 
Link: Connects presentation zones or BrightSign players 

• Synchronize: Specifies the Synchronization trigger. 
• Send zone message: Specifies the Zone Message trigger. 
• Zones: Specifies the Link Zones trigger. 

 
GPIO: Sends a GPIO command. 

• On: Turns on the specified GPIO output. Other GPIO outputs are not affected. 
• Off: Turns off the specified GPIO output. 
• Set State: Enables you to turn each GPIO line on or off. 

 
Video: Changes the video playback settings: 

• Pause video: Pauses video playback. 
• Resume video: Resumes video playback. 
• Enable monitor power save mode: Turns the monitor's power saving mode on. 
• Disable monitor power save mode: Turns the monitor's power saving mode off. 

 
BrightControl: Sends commands to monitors and other digital signage displays: 

• Display On: Turns the display on. 
• Display Off: Turns the display off. 
• Send Ascii String: Sends a CEC command. 
• Set Philips Volume: Sets Philips TV volume. 

 
Other: Sends various commands that are not contained within the above categories. 

• Pause: Pauses presentation playback for a specified number of milliseconds. 
• Reboot: Restarts the BrightSign player. 
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• Set variable: Sets a specified value for a previously created User Variable. In the Variable field, type the exact 
name of the variable between two dollar signs on each side (for example, “$$variable1$$”). BrightAuthor will not 
recognize the variable without the dollar signs. In the Value field, specify a new value for the variable  

• Reset variables: Resets all User Variables to their original values and all Media Counters to 0 
• Switch to Presentation: Switches to a different presentation. The parameters set when creating the second 

presentation must match the first presentation. These parameters include the following: BrightSign Model, 
Connector Type, Screen Resolution, Monitor Orientation, and Monitor Overscan. In addition, make sure you type 
the exact name for the second presentation when creating the command. 

 

Conditional Targets 
Conditional targets allow you to change the settings of an event transition depending on the value of a User Variable. You 
can set multiple conditional targets for a single event. 

1. Select the Advanced tab while creating or editing an event. 
2. Click the Set Conditional Targets button. 
Note: This option will only be available if you have created one or more User Variables in the File > Presentation 
Properties window.  
3. Click Add Additional Target in the Conditional Targets window, or click a preexisting Conditional Target to edit. 
4. Select the User Variable that will trigger the Conditional Target. 
5. Enter the value of the User Variable in the Equals field. The Conditional Target will only take effect when the value 

of the User Variable is equal to the number in this field. 
6. Select Transition to new state if you want to use the dropdown list to specify which file in the playlist will be the 

next state. 
7. Select Return to prior state if you want the presentation to revert to the previous media file when the interactive 

event is performed. 
8. Select Remain on current state if you want the state to remain unchanged when the interactive event is 

performed. 
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9. Select the Advanced tab to add Commands to the Conditional Target. Commands will trigger when the conditional 
target is met. See Adding Commands for more information. 

10. Click OK to save the conditional target. 
 

User Variables  
There are several ways you can change the values of User Variables in an interactive presentation. See Setting 
Presentation Properties for more information about creating User Variables and setting default values. 
 
Web Browser 
You can view and update User Variables using a web browser. To do this, your computer must be connected to the same 
local network as the BrightSign player(s) you are using: 

1. Navigate to Tools > Setup BrightSign Unit. 
2. Check the Enable local web server box.  
3. Enter a user name and password for the web server if desired. 
4. Set the rest of the options in the BrightSign Unit Setup window and complete the unit configuration process (see 

Chapter 2 for more information on setting up units). 
5. Wait for the player to complete the entire boot process. 
6. Use the address bar of a web browser to navigate to device IP port 8080. For example, if the IP address of your 

BrightSign player is 192.168.1.2, then you would enter 192.168.1.2:8080. You will be provided with a web 
page that lists all User Variables and allows you to modify them. 

 
UDP or Serial Input Event 
You can change the value of User Variables using input from UDP or serial ports: 

1. Create a new UDP Event or Serial Input Event, or edit an existing one. 
2. If you are editing a UDP Event, type <any> into the Specify UDP input field. If you are using a serial port, type 

<*> into the Specify serial input field. 
3. Expand the Advanced options and check the box labeled Assign input to variable. 
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a. Select Specify fixed variable if you want to choose a fixed User Variable in the BrightAuthor presentation. 
Use the dropdown list to choose which User Variable the UDP input will modify.  The UDP/serial string must 
be input in the form of <variable value>. 

b. Select Input specifies variable if you want the UDP/serial input string to dynamically specify which User 
Variable is being modified. The UDP/serial string must be input in the form of <variable name> : 
<variable value>. 

4. Press OK to save the settings. 
Note: If you select Input specifies variable, you can modify more than one User Variable with a single UDP Input 
Event or Serial Input Event. Use the following UDP/Serial string: <variable name> : <variable value> !! 
<variable name> : <variable value>   
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CHAPTER 5 – INTERACTIVE EVENTS 

Interactive events can include any of the following. For all interactive events, make sure you define the next state after 
dragging the icon onto the current state: 
 

Event Description 
Timeout 

 

Displays an item for a predetermined period of time before the next action occurs 
automatically. To define the length of the timeout interval, double-click the Timeout icon in 
the playlist area. In the Specify timeout (seconds) field, enter the number of seconds you 
want the item to display, and then click OK. 

Media End 

 

Sets the action that occurs after a video or audio file finishes playing. 
 
 

GPIO Event 

 

Sets the action that occurs when a specific GPIO button/input is pressed or activated. By 
default, the playlist toolbar includes several GPIO buttons that you can use to define 
interactions. 
 



70 
 

Event Description 
BP900/200 

 

Sets the action that occurs when a specific BP900 or BP200 button is pressed. There are 
six icons: BP900A, BP900B, BP900C, BP200A, BP200B, and BP200C. See BP900 and 
BP200 Button Boards for details. 

Synchronize 

 

Synchronizes content with another BrightSign player on the same network. 
 
When the Synchronize Event window opens, enter a trigger in the Specify 
synchronization keyword field, and then click OK. Note: The same event/trigger must be 
defined for each transition you want synchronized. 

UDP Input 

 

Sets the action that occurs when a BrightSign player receives input from a network device. 
Use this event when you want an external device to control BrightSign players using UDP 
(User Datagram Protocol or Universal Datagram Protocol).  
 
When the UDP Input Event window opens, enter the network address for the external 
device in the Specify UDP input field, and then click OK. 

Serial Input 

 

Sets the action that occurs when a BrightSign player receives specific input from a device 
connected to the serial port.  
 
When the Serial Input Event window opens, enter the serial string that triggers the next 
event in the Specify serial input field, and then click OK. You can also specify whether 
you want to assign input to a User Variable under the Advanced options. Select Input 
specifies variable if the name of the User Variable will be specified in the serial-input 
string or Specify fixed variable if you want to choose the User Variable in BrightAuthor. 
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Event Description 
Rectangular Touch 

 

Sets the action that occurs when the user touches the specified rectangular area on a 
touch screen. 
 
When the Add Touch Event window opens, drag the box to resize the touch area (or enter 
the exact Size and Position). To add additional touch regions to the selected item, click 
Add Touch Region, define the parameters, and then click OK. 

Keyboard Input 

 

Sets the action that occurs when a BrightSign player receives specific input from a 
keyboard. 
 
When the Keyboard Input Event window opens, enter the keyboard input that triggers the 
next event in the Specify keyboard input field, and then click OK. 

USB Input 

 

Sets the action that occurs when a BrightSign player receives input from a device 
connected to the USB port. 
 
When the USB Input Event window opens, enter the USB input that triggers the next 
event in the Specify USB input field, and then click OK. 

Remote Input 

 

Sets the action that occurs when BrightSign receives specific input from a remote control 
(IguanaWorks USB transceiver required). 
 
When the Remote Input Event window opens, enter the remote character that triggers the 
next event in the Specify remote input field, and then click OK. See Appendix A for 
remote control codes. 
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Event Description 
Zone Message 

 

When combined with Sync Events, synchronizes multiple zones across separate displays.  
 
When the Zone Message Event window opens, specify the zone message trigger. Use 
this event with multi-zone video walls. For synchronizing multi-zones in one display, use a 
Link Zones event. Note: The same event/trigger must be defined for each transition you 
want synchronized. 

Link Zones 

 

Synchronizes content in another zone.  
 
When the Link Zones Event window opens, enter the trigger in the Specify link keyword 
field, and then click OK. Note: The same event/trigger must be defined for each transition 
you want synchronized. 

GPS 

 

Sets the action that occurs when a BrightSign unit, connected to a compatible USB GPS 
device, enters or exits a defined geographical region.  
 
When the GPS Event window opens, select whether you want the event to trigger as the 
device enters the defined region or leaves the defined region. Set the center of the region 
by entering the Latitude and Longitude. Then define the circular size of the region by 
entering the Radius in Miles or Kilometers.  
Note: You can create more than one enter or exit region by adding multiple GPS events to 
a single state.  

http://support.brightsign.biz/entries/21775891-what-kind-of-usb-gps-receiver-can-i-use-with-the-brightsign�
http://support.brightsign.biz/entries/21775891-what-kind-of-usb-gps-receiver-can-i-use-with-the-brightsign�
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Event Description 
Video Time Code 

 

Performs commands at specific times during video playback. To define the commands and 
times, drag the Video Time Code icon onto the current state (video file). 
 
When the Video Time Code Events window opens, click Add Time Code, enter the 
Timeout interval, select the Command and Parameters from the corresponding lists, and 
then click OK. For more details, see Adding Commands. 
 

Time/Clock 

 

Performs commands at a specific time and date or at regular intervals on a recurring 
schedule. 
 
Single date/time event 
Specify the Date by entering it into the field or selecting it from the calendar view. Then 
specify the Time by using the dropdown menu. If you want the event to occur at an exact 
minute, type the desired time directly into the field. 
 
If you want to use the value of a User Variable to specify the date and time, select Specify 
with user variable and choose a variable you’ve created from the dropdown list. The 
value of the variable must be in this format: “yyyy-mm-ddThh:mm:ss”. For example, if 
you would like the event to occur on December 20, 2012 at 3:45PM, then you would use 
the value “2012-12-20T15:35:00”. 
 
Daily timeout event 
Choose whether you want the event to occur Once per day or to be Periodic throughout 
the day. If you select Once per day, specify the Time using the dropdown menu (or, if you 
want the event to occur at an exact minute, type the desired time directly into the field). If 
you select Periodic throughout the day, specify the Interval between events and the 
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Event Description 
times between which the interval occurs. You can also select days during which this event 
is active. 
Note: If you choose to make the timeout event Periodic throughout the day, the first 
event will occur at the beginning of the active period. 

 
User Defined Events 
This feature allows you to save interactive events you use often so that you can use them more readily in the future. All 
individual events can be added to your toolbar for immediate use, but, with User Defined Events, the parameters for your 
event are saved.  
 
For example, if you frequently use a 5 second Timeout event, you can create a User Defined Event with this specification. 
In the future, instead of having to set each Timeout event to 5 seconds, you can use your previously created User Defined 
Event. In addition, you can group multiple events into your custom event. When defining an interaction with it, any 
interactive event within the User Defined Event will cause a transition to the next state. This will save you time by 
eliminating the need for defining each individual event. Simply create a list of events, save it as a User Defined Event, and 
define the event between the two states. 
 
Click the User Events tab under Media Library. To create/edit User Defined Events, click Manage. The Manage User 
Events window will open. This window contains a list of all previously created User Defined Events. Complete any of the 
following: 
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• Create a User Defined Event: Click Add User Event. When prompted, type a unique name for your User Defined 
Event. Click Add Event and use the dropdown list to select an interactive event. Repeat for each event you want 
included in the User Defined Event. Click OK when you are finished. 

• Edit a User Defined Event: Click the appropriate name from the list in the Manage User Events window. Make the 
desired changes in the User Event window. 

• Organize User Defined Events: Click the arrows to arrange the order of the list by moving a User Defined Event 
up or down. 

• Delete User Defined Events: Click the X beside a name from the list. Or, click Delete All to erase the entire list. 
 
To use a User Defined Event in a playlist, click the User Events tab under the Media Library. All previously created User 
Defined Events will be listed here. Drag the appropriate icon from the list onto the current state. In the Events window, 
specify which media file you want to be the Next State. Follow the usual steps for defining the event (see Making a 
presentation interactive for details). 
 
You can also import previously created User Defined Events into BrightAuthor or export them from BrightAuthor. Click File 
> Import User Events / Export User Events. If you are importing, browse to the location where the events are stored. If 
you are exporting, browse to a location where you want to export all User Defined Events currently saved in BrightAuthor.  
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CHAPTER 6 – THE TD1012 

The TD1012 is a freestanding, all-inclusive digital signage solution that you can easily place on tables, counters, or 
wherever signage is most needed. The TD1012’s high resolution screen and BrightSign player are built into a durable 
steel casing and can be powered for approximately 12 hours by the rechargeable battery. 
 
Creating presentations for your TD1012 is fundamentally similar to creating presentations for any other BrightSign player. 
See Creating Presentations for details. However, the following details are unique to the TD1012: 
 

• In the New Project window, the Screen resolution dropdown list only contains 1360x768x60p. This is the only 
resolution supported by the TD1012. 

• The TD1012 does not support Audio. You may include videos in your TD1012 presentations, but no audio 
associated with the videos will play. 

Note: When creating presentations for your TD1012 unit, you may encounter audio settings. For example, the Audio 
Only zone is still available when you click Add Zone. None of these audio options apply to the TD1012. 
• The TD1012 supports wireless network connectivity only. 
• There are only two System templates included in the Template window (after clicking Create). However, you can 

still add/adjust zones and save your own custom templates. See Customizing template layouts for details.  
• The TD1012 only supports interactivity through network commands. Use the UDP Input icon to define interactive 

events. See Making a presentation interactive for details. 
Note: You can also use Timeout, Media End, Synchronize, Zone Message, Link Zones, and Video Time Code events. 
• As usual, clicking the Layout tab allows you to adjust the position and size of your zones. However, the preview 

image in the right portion of the screen is rotated 90 degrees because the preview image is always landscape 
oriented, but the screen of the TD1012 is actually a portrait display. Therefore, when adjusting zones for your 
TD1012 presentation, refer to the image on the left side of the screen. This will show you how the zones will appear 
to a viewer when the presentation is playing. 
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Publishing and customizing TD1012 presentations is no different from other BrightSign units. See Publishing 
Presentations and Customizing Presentations for details.   
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CHAPTER 7 – BP900 AND BP200 BUTTON PANELS 

The BP900 and BP200 button panels are LED-based touch devices that allow you to add interactivity to your BrightAuthor 
presentations. These button panels are compatible with any BrightSign device that has a USB port: HD810, HD1010, 
HD1010w, HD1020, XD230, and XD1230.  
 
There are a total of six event icons: BP900A, BP900B, BP900C, BP200A, BP200B, and BP200C. The letters A, B, and C 
correspond to USB ports. If the event you are defining is for a button pad connected to USB port 1, use A. If it is for a 
button pad connected to the second port, use B. Let’s say you are using an XD1230 and, therefore, have two available 
USB ports. If you want to connect two button boards, a BP900 and a BP200, you would use the BP900A and BP200B 
icons to define events for each. 
 

Using BP900 and BP200 Events 
1. Make your presentation interactive by clicking Interactive in the upper-right side of the playlist area. 
2. Define the BP900 or BP200 interactive event: 

a. Choose the proper event icon based on what kind of button pad you are using (BP900 or BP200), and how 
many button pads you are connecting.  

b. Define the BP900 or BP200 event as you would any other event. See Making a presentation interactive for 
details. 

Note: If the icon you need is not in the toolbar, click the toolbar arrow in the upper-right portion of the screen to 
add it to your toolbar. Or, you can click the Events tab and drag the icon to the playlist area. 
c. The BP900 Event or BP200 Event window will automatically open. Specify the following parameters for 

your event: 
• Specify Button Number: Select a button on the button pad that you want the user to press to 

transition to the next state. 

http://www.brightsign.biz/products/accessories/usb-button-panels/�
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• Press (First Touch): Determine whether you want the transition to occur after one push of the 
button. 

 
• Press Continuous: Determine whether you want the user to continually press the button. Specify a 

repeat interval in the text field (in milliseconds). 
• Transition to new state: Click to specify which media file in your playlist will be the next state when 

the specified button is pushed. 
• Return to prior state: Click to revert the presentation to the previous media file when the specified 

button is pushed. 
• Remain on current state: If you select this option, the state will not change when the interactive 

event is performed. This option is useful for creating changes within one media file. You can create 
these changes by adding commands. See Adding Commands for details. 
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• Advanced: Click the Advanced arrow to reveal the display options and commands section. Here you 
can set how you view the interactive events between states in the playlist area. Show line draws a 
line between the media files. Show label creates a label either to the Right or Bottom of the media 
file that indicates transitions from states. See Adding Commands for details on commands. 

d. Click OK. Repeat steps a. through c. to define the remaining button pad events.  
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CHAPTER 8 – PUBLISHING PRESENTATIONS 

After you create and save a presentation, you’re ready to publish it to your BrightSign player or players. There are four 
ways to publish a presentation: 

• Local Storage 
• BrightSign Network 
• Local Networking 
• Simple File Networking 

 
The method you use to publish should depend on several factors, such as whether your player is networked, what kind of 
network you have access to, and how many players you have.  

 

Publishing with Local Storage 
Publishing a presentation using Local Storage lets you copy your presentations to an SD card or USB flash drive. When 
you want to update your scheduled presentations, you must save the updated content on the SD card or USB flash drive 
and insert it into your BrightSign player.  
 
Unless you are updating content, an SD card or flash drive should always remain connected to the BrightSign player. 
However, if your BrightSign has a USB port, it is recommended that you create setup files with an SD card, leave it 
permanently in the player as internal storage, and use a USB flash drive whenever you need to update content. You can 
publish updated content to the USB flash drive, insert it into the BrightSign to update the SD card, and then remove the 
flash drive. To publish via Local Storage, complete the following steps: 

1. Save the presentations you want to publish by clicking File > Save… As. You will also be prompted to save a 
presentation if there are unsaved changes to the presentation when you switch to the Publish tab. 

2. Add the presentations you want to publish: 
a. Click the Publish tab. 
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b. Click Local Storage (below the Publish tab). 
c. Click Browse under Presentations to navigate to and select the folder where your presentations are stored. 

3. Create schedules for each presentation you wish to publish: 
a. Select a presentation from the list in the Presentations section. 
b. Drag the presentation to a time slot during which you want it to play.  
c. Click and drag the selection handles to adjust playing time within one day. 
Note: Alternatively, you can schedule a presentation by double-clicking a blank 
area on the schedule to open the Schedule Presentation window. 
d. If you want the presentation to be a recurring event, double-click a 

presentation timeframe in the calendar. In the Schedule Presentation 
window, set the following parameters: 

• Presentation: Specify which presentation you want to schedule. 
• Active all day, every day: Check this box if you want the 

presentation to play 24 hours a day. 
• Event time: Specify the timeframe when you want the presentation 

to play by using the dropdown lists beside Start and End. 
• Recurring Event: Check this box if you want the presentation to 

recur during specified times.  
• Recurring pattern: Specify the frequency for the recurrence. If you 

click Daily, you can specify Every day, Every weekday, or Every 
weekend. If you click Weekly, you can view a checklist of every day 
of the week. Specify the individual days of the week when you want 
the presentation to play. 

• Range of recurrence: Use the calendar beside Start to specify the first day you want the 
presentation to play. If you want the event to stop recurring at some point, click End by and use the 
calendar to specify the date. If you don’t want it to stop, click No end date. 

e. Click OK. The adjustments you made will be represented in the calendar. 
f. If prompted, indicate whether you want to replace the existing schedule and then click OK. 
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g. Repeat steps b through e for each presentation you want to schedule. 
4. (Optional) Specify debugging, logging, and firmware preferences: 

a. Under Debugging, use the checkboxes to enable/disable serial debugging and system log debugging. 
b. Click Specify Logging and use the checkboxes in the Logging window to have the player generate logs 

while it operates. 
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c. Click Specify Firmware Update and indicate whether you want to update the firmware and to which 
version. The Firmware Update window is divided by BrightSign generation. In the section that corresponds 
to your BrightSign unit, select a firmware version or Do not update and then click OK.  

5. (Optional) Check the Publish zip file for USB update box if you want to use a USB flash drive to update the SD 
card in the BrightSign player. You can use this feature to update content on a standalone device without ever 
needing to remove the SD card. 

6. (Optional) Click the Specify Password button if you are publishing a USB content update to a player or set of 
players with password protection, or if you would like to set up, change, or remove password protection for USB 
content updates. The password protection feature helps to ensure that a player will not be updated with incorrect 
schedules or data. The options shown by this button depend on whether or not you have checked the Publish zip 
file for USB update box: 

a. If the Publish zip file for USB update box is checked: Enter the USB Content Update Password. You 
must enter the same upgrade password designated for the player, or else the player content upgrade will 
fail. You can choose the password when you set the player up for standalone use or when you use the Set 
New Password feature (see below). 

Note: If no update password is currently set for the player, entering a phrase here will designate it as the new 
update password. 

b. If the Publish zip file for USB update box is unchecked: Choose one of the following: 
• Keep Password: Leaves the current content update password for the player unchanged. 
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• Set New Password: Changes the content update password for the player. Enter the new password 
in the field. 

• Clear Password: Removes the content update password. This allows USB updates to be published 
to the SD card without restriction. 

7. Publish the presentation to your storage device: 
a. Insert a storage device into your computer (SD card or USB flash drive). 
b. Under Publish to, click Browse to navigate to and select the drive where your storage device is located. 
c. Click Publish. When the Publish complete window opens, click OK. 

8. Update your BrightSign player: 
a. Turn off the BrightSign player by unplugging the power adapter. 
b. Insert the storage device from step 4 into the player. 
c. Turn on the player by reconnecting the power adapter. 
d. Leave the storage device in the player.  
Note: If an SD card is already in the player and you are updating it via USB, you don’t need to turn off the 
player. Insert the USB flash drive into the player, wait until the Update Complete message appears on the 
display, and then remove the flash drive. 

 

Publishing with BrightSign Network 
Publishing with BrightSign Network enables you to distribute your presentation to your BrightSign players using an 
Internet connection.  
 
BrightSign Network requires a subscription, so you must first contact BrightSign to obtain an account name, user name,  

http://www.brightsign.biz/products/brightsign-network/�
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and password. Once your BrightSign players are set up with BrightSign Network (see Adding BrightSign units to your 
BrightSign Network), you can upload your presentations to the BrightSign Network server, publish schedules, and 
manage content. Your players will update their content automatically whenever they connect to the server. 
 
Publishing with BrightSign Network sends presentations and schedules to groups instead of players. Groups can contain 
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any number of players, and you can move BrightSign players from one group to another at any point. See Managing your 
Network for details. To publish with BrightSign Network, complete the following steps: 

1. Sign into BrightSign Network by clicking Tools > Sign in to BrightSign Network. 
2. Open the presentation you wish to publish by selecting File > Open presentation.  
3. Click Upload to network (in the upper-right portion of the screen) to upload the presentation to the server. 
4. Specify to which group you want to publish: 

a. Click the Publish tab in the upper-left portion of the screen. 
b. Click BrightSign Network (above the calendar). 
c. Under Selected Group to Schedule, use the dropdown list to specify the 

group to which you want to publish. 
5. Create schedules for each presentation you want to publish: 

a. Select a presentation from the Presentations dropdown list. 
b. Drag the presentation to a time slot during which you want it to play. 
c. Click and drag the selection handles to adjust playing time within one day. 
Note: Alternatively, you can schedule a presentation by double-clicking a blank 
area on the schedule to open the Schedule Presentation window. 
d. If you want the presentation to be a recurring event, double-click the 

highlighted presentation name in the calendar. In the Schedule 
Presentation window, set the following parameters: 

• Presentation: Specify which presentation you want to schedule. 
• Active all day, every day: Check this box if you want the 

presentation to play 24 hours a day. 
• Event time: Specify the time during the day when you want the 

presentation to play by using the dropdown lists beside Start and 
End. 

• Recurring Event: Check this box if you want the presentation to 
recur during specified times.  
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• Recurring pattern: Specify the frequency for the recurrence. If you click Daily, you can specify 
Every day, Every weekday, or Every weekend. If you click Weekly, you can view a checklist of 
every day of the week. Specify the individual days of the week when you want the presentation to 
play. 

• Range of recurrence: Use the calendar beside Start to specify the first day you want the 
presentation to play. If you want the presentation to stop recurring at some point, click End by and 
use the calendar to specify the date. If you don’t want it to stop, click No end date. 

e. Click OK. The adjustments made will be represented in the calendar. 
f. If prompted, indicate whether you want to replace the existing schedule and then click OK. 
g. Repeat steps b through e for each presentation you want to schedule. 

6. (Optional) Specify debugging and firmware preferences: 
a. Under Debugging, use the checkboxes to enable/disable serial debugging and system log debugging. 
b. Click Specify Firmware Update and indicate whether you want to update the firmware and to which 

version. The Firmware Update window is divided by BrightSign generation. In the section that corresponds 
to your BrightSign player, select a firmware version or Do not update, and then click OK. 

7. Publish the presentation: 
a. Click Publish Schedule. When the Publish Complete window opens, click OK. 

 

Publishing with Simple File Networking 
Simple File Networking enables you to distribute your presentation to your BrightSign players via a web folder. Your 
player must be set up for Simple File Networking with the correct URL for web folder used during setup. See Adding 
BrightSign units to your Simple File Network for details. 

1. In BrightAuthor, save the presentations you want to publish by clicking File > Save… As 
2. Add the presentations you want to publish: 

a. Click the Publish tab in the upper-left side of the screen. 
b. Click Simple File Network (above the Calendar). 
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c. Under Presentations, click Browse to navigate to and select the folder where your presentations are 
stored. 

3. Create schedules for each presentation you want to publish: 
a. From the list under Presentations, select a presentation. 
b. Drag the presentation to a time slot during which you want it to play. 
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c. Click and drag the selection handles to adjust playing time within one day. 
Note: Alternatively, you can schedule a presentation by double-clicking a blank area on the schedule to open 
the Schedule Presentation window. 
d. If you want the presentation to be a recurring event, double-click the highlighted presentation name in the 
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calendar. In the Schedule Presentation window, set the following parameters: 
• Presentation: Specify which presentation you want to schedule. 
• Active all day, every day: Check this box if you want the presentation to play 24 hours a day. 
• Event time: Specify the time during the day when you want the presentation to play by using the 

dropdown lists beside Start and End. 
• Recurring Event: Check this box if you want the presentation to recur during specified times.  
• Recurring pattern: Specify the frequency for the recurrence. If you click Daily, you can specify 

Every day, Every weekday, or Every weekend. If you click Weekly, you can view a checklist of 
every day of the week. Specify the individual days of the week when you want the presentation to 
play. 

• Range of recurrence: Use the calendar beside Start to specify the first day you want the 
presentation to play. If you want the event to stop recurring at some point, click End by and use the 
calendar to specify the date. If you don’t want it to stop, click No end date. 

e. Click OK. The adjustments made will be represented in the calendar. 
f. If prompted, indicate whether you want to replace the existing schedule and then click OK. 
g. Repeat steps b through e for each presentation you want to schedule. 

4. (Optional) Specify debugging and firmware preferences: 
a. Under Debugging, use the checkboxes to enable/disable serial debugging and system log debugging. 
b. Click Specify Firmware Update and indicate whether you want to update the firmware and to which 

version. The Firmware Update window is divided by BrightSign generation. In the section that corresponds 
to your BrightSign unit, select a firmware version or Do not update, and then click OK. 

5. Publish the presentation: 
a. Under Simple File Networking Parameters, click Set Parameters. 
b. Under Unit Configuration: 

• URL for web folder: Type the URL for your web folder. This must match the URL you entered when 
setting up your device for Simple File Networking. 

• Content Check Frequency: Use the dropdown list to specify how often you want the player to 
connect to the server to check for content and scheduling updates. 
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• (Optional) Limit content downloads: Check this box and use the dropdown lists beside Start of 
range and End of range to specify the times during the day when content can be downloaded. 

c. (Optional) Under Logging, check any of the following 
boxes to enable the corresponding logs: 

• Enable playback logging: Creates a log that 
records start and end times, zone names, media 
types, and file names. 

• Enable event logging: Creates a log that records 
timestamps, state names, zone names, event types, 
and event data. 

• Enable state logging: Creates a log that records 
current and last state names, timestamps, and 
media types. 

• Enable diagnostic logging: Creates a log that 
records timestamps, firmware and script versions, 
and the current presentation. 

d. Under Upload Logs, use the following checkboxes to 
determine the settings for uploading logs to the server. 

• On startup: Uploads log files each time you start 
the unit. 

• At specific time each day: Uploads log files daily at the specified time. Use the dropdown menus to 
determine a time. 

e.  (Optional) Under Rate Limit Network Download Traffic, set parameters for download traffic. The options 
are divided into Outside content download window, During content download window, and During 
initial downloads. 

• Click Unlimited download rate to set no limit. 
• Click Default limit to use the default limit on downloads. 
• Click Specify limit to enter a customized limit on downloads in the text field (in Kbits/seconds). 
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e. Click OK. 
f. Under Publish to, click Browse to navigate to and select the location where you want to store the files. 

• If you have a mapped drive or shortcut that points to your web folder, publish to that location. 
• If you use FTP to transfer files to your web folder, publish to a folder on your computer and then use 

FTP software to copy the files to your web folder. 
g. Click Publish. When the Publish Complete window opens, click OK. 

 

Publishing with Local Networking 
Publishing a presentation with a local network lets you distribute your presentation to BrightSign players without using an 
Internet connection. This is convenient if you only have a small number of BrightSign players that are all on the same local 
network. With Local Networking, the BrightSign player does not need to poll the web server to receive updates. You can 
simply select a BrightSign player using BrightAuthor and publish a presentation directly to it. Updates will then be sent to 
the BrightSign player immediately. 

1. Save the presentation you want to publish by clicking File > Save As 
2. Add the presentation you want to publish: 

a. Click the Publish tab in the upper-left side of the screen. 
b. Click Local Network (above the Calendar). 
c. Under Presentations, click Browse to navigate to and select the folder where your presentations are 

stored. 
3. Create schedules for each presentation you want to publish: 

a. From the list under Presentations, select a presentation. 
b. Drag the presentation to a time slot during which you want it to play. 
c. Click and drag the selection handles to adjust playing time within one day. 
Note: Alternatively, you can schedule a presentation by double-clicking a blank area on the schedule to open 
the Schedule Presentation window. 
d. If you want the presentation to be a recurring event, double-click the highlighted presentation name in the 

calendar. In the Schedule Presentation window, set the following parameters: 
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• Presentation: Specify which presentation you want to schedule. 
• Active all day, every day: Check this box if you want the presentation to play 24 hours a day. 
• Event time: Specify the time during the day when you want the presentation to play by using the 

dropdown lists beside Start and End. 
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• Recurring Event: Check this box if you want the presentation to recur during specified times.  
• Recurring pattern: Specify the frequency for the recurrence. If you click Daily, you can specify 

Every day, Every weekday, or Every weekend. If you click Weekly, you can view a checklist of 
every day of the week. Specify the individual days of the week when you want the presentation to 
play. 

• Range of recurrence: Use the calendar beside Start to specify the first day you want the 
presentation to play. If you want the presentation to stop recurring at some point, click End by and 
use the calendar to specify the date. If you don’t want the presentation to stop, click No end date. 

e. Click OK. The adjustments made will be represented in the calendar. 
f. If prompted, indicate whether you want to replace the existing schedule and then click OK. 
g. Repeat steps b through e for each presentation you want to schedule. 

4. (Optional) Specify debugging and firmware preferences: 
a. Under Debugging, use the checkboxes to enable/disable serial 

debugging and system log debugging. 
b. Click Specify Firmware Update and indicate whether you want to update 

the firmware and to which version. The Firmware Update window is 
divided by BrightSign generation. In the section that corresponds to your 
BrightSign player, select a firmware version or Do not update, and then 
click OK. 

5. Publish the presentation: 
a. Under Publish, select a BrightSign player. 

• If publishing to a new player, click New unit. Then click the      
button. The Add BrightSign Unit window will open. Type the IP 
address of the new BrightSign unit, and click OK. 

• If you want to publish to a previously added BrightSign player, click 
Networked units. Select a unit from the list of all networked units. 
Click to refresh the list. 

b. Click Publish. When the Publish Complete window opens, click OK. 
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Note: When publishing to a new player, the BrightSign Unit Setup window will open after you click Publish. 
See Adding BrightSign Players to your Local Network for details.  
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CHAPTER 9 – CUSTOMIZING PRESENTATIONS 

This chapter will describe the different ways you can customize your presentations. 
 

Setting Zone Properties 
Whether you’re creating a single-zone or a multi-zone presentation, you can customize the settings for each zone.  

1. Open a presentation project by clicking File > Open Presentation. 
2. Click on the Edit tab and then the Playlist subgroup. 
3. Below Zone in the upper-left portion of the screen, click the zone whose properties you want to change. 
4. Click Zone Properties. Different options will appear depending on the type of zone that is selected 

 

Editing Video Only and Video or Images Zones 
The settings that appear in this window will the depend on the model of BrightSign player you are using: 
 
HD110, HD210 

• View mode: Use the dropdown list to specify a setting for videos. 
o Scale to fit: Scales the video to fill the screen without maintaining the aspect ratio. The video may appear 

stretched. 
o Letterboxed and centered: Centers the video and adds black borders on the top and bottom. The aspect ratio 

is maintained. 
o Fill screen and centered: Centers the video and fills the screen. The aspect ratio is maintained. 

• Audio settings: Use the dropdown list to specify the type of audio you want to use in the zone. 
• Image mode: Use the dropdown list to specify a setting for images. 
Note: This option also appears when editing Images zones, but not when editing Video Only zones.  

o Center image: Centers the image without scaling. This may result in cropping if the image is too large. 
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o Scale to fit: Scales the image to fit the zone. The image is displayed as large as possible with the correct 
aspect ratio. 

o Scale to fill and crop: Scales the image to completely fill the zone while maintaining the aspect ratio. 
o Scale to fill: Scales the image to fill the zone without maintaining the aspect ratio. 

• Initial volume (Audio): Set the initial volume for audio files (0-100).  
• Initial volume (Video): Set the initial volume for video files (0-100). 

 
HD810, HD1010 

• View mode: Use the dropdown list to specify a setting for videos. 
o Scale to fit: Scales the video to fill the screen without maintaining the aspect ratio. The video may appear 

stretched. 
o Letterboxed and centered: Centers the video and adds black borders on the top and bottom. The aspect ratio 

is maintained. 
o Fill screen and centered: Centers the video and fills the screen. The aspect ratio is maintained. 

• Audio settings: Use the dropdown list to specify the type of audio you want to use in the zone. 
• Image mode: Use the dropdown list to specify a setting for images. 
Note: This option also appears when editing Images zones, but not when editing Video Only zones.  

o Center image: Centers the image without scaling. This may result in cropping if the image is too large. 
o Scale to fit: Scales the image to fit the zone. The image is displayed as large as possible with the correct 

aspect ratio. 
o Scale to fill and crop: Scales the image to completely fill the zone while maintaining the aspect ratio. 
o Scale to fill: Scales the image to fill the zone without maintaining the aspect ratio. 

• Initial volume (Audio): Set the initial volume for audio files (0-100).  
• Initial volume (Video): Set the initial volume for video files (0-100). 
• Live video: Set attributes for live video feeds. Use the dropdown lists to select the Input and Video Standard 

types. In the text fields, enter parameters for Brightness, Contrast, Saturation, and Hue. 
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HD120, HD220, HD1020, XD230 
• View mode: Use the dropdown list to specify a setting for videos. 

o Scale to fit: Scales the video to fill the screen without maintaining the aspect ratio. The video may appear 
stretched. 

o Letterboxed and centered: Centers the video and adds black borders on the top and bottom. The aspect ratio 
is maintained. 

o Fill screen and centered: Centers the video and fills the screen. The aspect ratio is maintained. 
• Audio Output: Enables or disables the Analog and HDMI audio outputs for the zone. 

o Pass through: Supplies the un-decoded audio signal through the HDMI connector. Use this option if the zone 
audio (for example, AC3 Dolby Digital) is being decoded on an external device. 

o PCM audio: Supplies the decoded audio signal through the HDMI connector. 
• Audio Mixing: Sends the stereo, left-only, or right-only audio signal. 
• Image mode: Use the dropdown list to specify a setting for images. 
Note: This option also appears when editing Images zones, but not when editing Video Only zones.  

o Center image: Centers the image without scaling. This may result in cropping if the image is too large. 
o Scale to fit: Scales the image to fit the zone. The image is displayed as large as possible with the correct 

aspect ratio. 
o Scale to fill and crop: Scales the image to completely fill the zone while maintaining the aspect ratio. 
o Scale to fill: Scales the image to fill the zone without maintaining the aspect ratio. 

• Initial volume (Audio): Set the initial volume for audio files (0-100).  
• Initial volume (Video): Set the initial volume for video files (0-100). 

 
XD1030, XD1230 

• View mode: Use the dropdown list to specify a setting for videos. 
o Scale to fit: Scales the video to fill the screen without maintaining the aspect ratio. The video may appear 

stretched. 
o Letterboxed and centered: Centers the video and adds black borders on the top and bottom. The aspect ratio 

is maintained. 
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o Fill screen and centered: Centers the video and fills the screen. The aspect ratio is maintained. 
• Audio Output: Enables or disables the Analog, HDMI, and SPDIF audio outputs for the zone. 

o Pass through: Supplies the un-decoded audio signal through the HDMI/SPDIF connector. Use this option if the 
zone audio (for example, AC3 Dolby Digital) is being decoded on an external device. 

o PCM audio: Supplies the decoded audio signal through the HDMI/SPDIF connector. 
• Audio Mixing: Sends the stereo, left-only, or right-only audio signal. 
• Image mode: Use the dropdown list to specify a setting for images. 
Note: This option also appears when editing Images zones, but not when editing Video Only zones.  

o Center image: Centers the image without scaling. This may result in cropping if the image is too large. 
o Scale to fit: Scales the image to fit the zone. The image is displayed as large as possible with the correct 

aspect ratio. 
o Scale to fill and crop: Scales the image to completely fill the zone while maintaining the aspect ratio. 
o Scale to fill: Scales the image to fill the zone without maintaining the aspect ratio. 

• Initial volume (Audio): Set the initial volume for audio files (0-100).  
• Initial volume (Video): Set the initial volume for video files (0-100). 

 
Editing Ticker Zones 

• Number of lines: Set the number of lines of text in the Ticker zone. 
• Time to display each line: Set how long each line displays in the Ticker zone (in seconds). 
• Rotation: Use the dropdown list to select the angle of text in the Ticker zone. 
• Alignment: Use the dropdown list to set whether text is left aligned, right aligned, or centered in the Ticker zone. 
Note: If you’re using a right-to-left language (such as Hebrew or Arabic) in your ticker zone, the right/left alignment 
settings will be inverted. For example, setting a ticker zone with an Arabic RSS feed to “Right aligned” will actually 
align the text to the left side of the zone.  
• Text appearance: Set whether text is animated or static in the Ticker zone. 
• Foreground text color: Click Choose and select a color for text in Ticker or Clock zones. 
• Background text color: Click Choose and select the color behind text in Ticker or Clock zones. 
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• Transparency: Set the transparency of the Background text color in Ticker or Clock zones. 
• Font: Click Browse and set a font for text in Ticker or Clock zones. You can use any TrueType font. Click Reset to 

System Font to reset the font. 
 
Advanced: Click the Advanced arrow to reveal the following options: 
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• Background bitmap: Click Browse to navigate to and select a file for a background image. Click Yes or No to 
determine whether you want to stretch the image to fill the zone. You can add a background bitmap to Ticker or 
Clock zones. 

• Safe text region: Define the location (X,Y fields) and size (Width, Height fields) of the text region within the zone. 
 

Editing Other Zones 
The settings in the Edit Zone window correspond to the type of zone you have selected. Here is a list of all the settings 
you can edit for other types of zones: 

• Images zone: Image mode. 
• Audio Only zone: Audio settings, initial volume (audio) 
• Clock zone: Rotation, foreground text color, background text color, transparency, font, background bitmap, and 

safe text region. 
• Background Image zone: You cannot click Zone Properties for a Background Image zone. Choose a 

background image by selecting the Background Image Zone and dragging a file to the playlist area. If you only 
want a background color (instead of an image), do not add a Background Image zone. The background screen 
color can be changed in the Presentation Properties window. See Setting presentation properties for details. 

5. Click OK. 
6. Repeat steps 2 – 4 for each zone you want to edit in your presentation. 

 

Customizing Template Layouts 
If the predefined zone template layouts do not meet your needs, you can create your own templates. Complete the 
following steps: 
 

1. Create a presentation project by clicking File > New Presentation and select a template that is most similar to the 
layout you want to use. 

2. Click Layout (below the Edit tab) and create a template by doing any of the following: 
• Change the position of a zone by clicking the zone and dragging it to the desired position. Alternatively, you  
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can enter the Position information in the left side of the screen. X corresponds to the position on a 
horizontal axis, and Y corresponds to the position on a vertical axis. 

• Add a zone by clicking Add zone, typing a Zone name, selecting the Zone type, and then clicking OK. 
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• Make two or more zones the same size by pressing Ctrl+Click to select the zones you want to resize. On 
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the menu bar, click Format > Make same size and select a resize option. 
• Align two or more zones by pressing Ctrl+Click to select the zones you want to align. On the menu bar, 

click Format > Align and then select an alignment option. 
• Center two or more zones by pressing Ctrl+Click to select the zones you want to center. On the menu bar, 

click Format > Center in form and then select Horizontally or Vertically. 
Tip: You can layer zones on top of each other. For example, you can place a Ticker or Clock zone on top of a 
Video Only zone, and then edit the transparency in the Ticker or Clock zone to control how much of the 
underlying video is visible. 
• Remove an unwanted zone by clicking it in the preview image and then pressing Delete on your keyboard. 
• Rename a zone by clicking it in the preview image, and then typing in the Name text field on the left side of 

the screen. 
Note: The preview image is always displayed as a landscape. If your display is a portrait and you have selected 
this monitor orientation when creating the project, refer to the portrait image in the left side of the screen to see 
how your zones will appear to a viewer. 

3. Click Save Template (in the lower-left portion of the screen). Enter a name for the template, and then click OK. 
4. To use a custom template in a new presentation, click the View dropdown list in the upper-right corner of the 

Template window. Select User Defined Templates to view your templates. Click a template and then click 
Choose to use it in the presentation. 

 

Setting Presentation Properties 
You can edit properties that apply to an entire presentation. These are based on your current default property settings. To 
change the default settings, see Setting default properties.  
 
To edit presentation properties, complete the following steps: Open a presentation project by clicking File > Open 
Presentation; on the menu bar, click File > Presentation Properties. 
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Main 
Set any of the following: 

• Connector type: Use the dropdown list to indicate the type of connector you are using for your display 
(HDMI, VGA, or Component). 

• Screen resolution: Use the dropdown list to set a resolution supported by your display. 
• RSS update frequency: Use the dropdown list to set how often you want the BrightSign to check for RSS 

feed updates. 
• Background screen color: Click Choose to select a background color that appears behind your zones. 
• Language: Use the dropdown list to select a language for your presentation. 

 
I/O  
Click Input or Output next to each GPIO port to indicate whether the port is sending or receiving information. 
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Interactive 
Set any of the following: 

• Serial: For each serial port: Port (number), Baud rate, Data bits, Parity, and Stop bits. Toggle between 
Binary and ASCII mode (Protocol), and set EOL characters (CR, LF, LF + CR) for Send and Receive EOL. 
Check the Invert Signals checkbox to invert the send pin and receive pin of the serial port. 
Note: the standard part is port 0 and the 5V TTL port is port 1. 

• UDP: Set the UDP Destination Address (type below Specific IP Address in dotted quad form, or click All 
devices on the local subnet), the UDP Destination Port, and the UDP Receiver Port. 

• Touch: Select a cursor option to set whether the cursor is always hidden, always visible, or present only if 
there is more than one touch region on the screen (auto display cursor). Check the Flip coordinates 
checkbox to reverse the coordinates of the check screen. Use this option only if the touch screen 
coordinates appear to be reversed. 
 

Buttons  
Use the dropdown list to select the type of button panel you wish to configure. Click Automatically configure which 
buttons are enabled or Specify which buttons are enabled and check the boxes to manually enable buttons. 
Repeat for each button panel you plan to connect to the player. 

  
Audio  
Set any of the following: 
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• Set the Minimum Volume and Maximum Volume for the Audio output (0 – 100). 
• Set the Minimum Volume and Maximum Volume for the HDMI audio output (0 – 100). 
 

Media List 
Set any of the following: 

• Return to start after inactivity: Check the Yes box to set Media Lists to return to the start of the list after a 
designated period of inactivity. 

• Inactivity timeout (seconds): If you checked Yes above, type a number in the text field to specify the 
period of inactivity before Media Lists restart. 
 

Autorun 
Click Standard Autorun or Select custom Autorun to specify a different autorun file for the presentation. Click Browse 
to locate and select the autorun file. 

 
Image Cache 
A list of all media files in your playlist is displayed here. Check the boxes to store certain files in an image cache for faster 
loading. 
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Variables  
Use this tab to create User Variables and enable Media Counters. 

• Media Counter: A value that records how many times a file in the presentation has played. They can be 
viewed in Live Text or extracted from the BrightSign via USB. Media Counters are not recorded unless you 
check the Automatically create media counter variables checkbox in the Variables tab. When enabled, 
Media Counters are recorded for every file in the presentation. However, in Live Text, only Media Counters 
that are individually added can be viewed. For details on retrieving all Media Counters via USB, see Using 
advanced tools.  

• User Variable: A customizable value that can be used in commands or displayed in Live Text. When used 
in Live Text, User Variables display the current value of the variable. This value can continually change 
during a presentation. The value of a User Variable can be changed during a presentation by using the Set 
Variable or Reset Variable commands.  
 
User Variables can be used in the following commands: Set Volume, Increment Volume, Decrement 
Volume, Send UDP, Serial-send string (EOL), Serial-send string (no EOL), Serial-send byte, Serial-send 
bytes (comma separated), Synchronize, Send Zone Message, Link Zones, GPIO On, GPIO Off, GPIO Set 
State, BrightControl – Send Ascii String, BrightControl – Philips Set Volume, Pause. 
 
For example, if you add a Set Volume command to your presentation and use a static value like 50, the 
volume will always be set to 50 when the command occurs. If you use a User Variable instead, the volume 
will be set to the current value of the variable, which could be any number of values based on your Set 
Variable commands and when the User Variable is used. 
 
To utilize a User Variable in a command, add the desired command as you normally would. See Adding 
Commands for details. In the Parameters field, type the exact name of the variable in between two dollar 
signs on each side (e.g. “$$variable1$$”). BrightAuthor will not recognize the variable without these dollar 
signs. 
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To create a User Variable, click the Add Variable button in the Variables tab. 
• Name: Enter a unique name for the User Variable. 
• Default Value: This is the value of the User Variable if it is not modified. Whenever a User Variable is 

reset (via the Reset Variable command), it will return to this default value. 
• Networked: Check this box if you would like the User Variable to be updatable via a Data Feed. 
• Data Feed: Select the data feed that contains your User Variable information. Every RSS entry has 

<title> and <description> tags: use the <title> tag to designate the name of the User 
Variable being modified; use the <description> tag to change the value of the User Variable. 

Note: The BrightSign Network provides a simple way to create and host RSS text feeds. In the 
BrightSign Network Web UI, use the Title field to designate the name of the User Variable and the Value 
field to change the value of the User Variable.  

To delete a User Variable, click the X beside the appropriate variable. 
 

http://support.brightsign.biz/entries/21875958-how-do-i-create-live-text-feeds-in-the-brightsign-network-web-ui�
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Data Feeds  
Create and edit data feeds, which you can use when creating Live Text elements, RSS content, and networked User 
Variables. Click Add Live Data Feed to bring up the feed-creation window: 

• Feed Name: Give the data feed a name. You will be able to locate the data feed by this name when you are 
creating a Live Text element, specifying an RSS feed, or creating Networked User Variables. 

• Url: Paste the web address of the RSS feed into this field.  
• Live Data Feed: If you have a BrightSign Network subscription, you can easily publish RSS feeds to the 

BrightSign Network servers. See the Live Text FAQ for instructions on creating RSS feeds in the BrightSign 
Network Web UI and using them in BrightAuthor. 

• Dynamic Playlist: If you have a BrightSign Network subscription, you can use Dynamic Playlists as Data 
Feeds. 

• Refresh: If you have recently created or renamed Dynamic Playlists or Live Text feeds using the BrightSign 
Network, click this button to update the content in the Live Data Feed and Dynamic Playlist dropdown lists 

http://support.brightsign.biz/entries/21875958-how-do-i-create-live-text-feeds-in-the-brightsign-network-web-ui�
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• Validate: Click this button to ping the web address you entered in the Url, Live Data Feed, or Dynamic 
Playlist field. Use this feature to check whether you entered the address of your RSS feed correctly. 

• Update Interval: Use the dropdown list to specify how often you want the content of an RSS feed to be 
refreshed using the provided URL. 

• Plugin Script: This is an advanced feature: You may optionally choose to have the RSS feed parsed by a 
piece of customized BrightScript code. This occurs after the feed is retrieved from the network and before it 
is provided to the Live Text object. To add a plugin, specify the location of the file that contains the 
BrightScript code by clicking the Browse button. 
Note: The parser file must have a .brs extension.  

• Parser Function Name: Enter the name of the subroutine that parses the RSS feed. The following 
parameters can be used with the subroutine: 

o xmlFileName$ — The name of the xml file. This information is provided by the autorun.  
o itemsByIndex — An array of the descriptions. The script should fill in this array if the Live Text 

object is using the “item index” to display items from this feed. 
o itemsByTitle —An associative array of titles and descriptions. The script should fill in this array if 

the Live Text object is using the “item title” to display items from this feed. 
o userVariables — An associative array of current User Variables (which are provided by autorun). 

This is provided in case you want to analyze or modify the User Variables.  
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The following piece of example code can be used to parse RSS text: 

 

Editing Preferences 
Whenever you create a new project, the presentation settings are based on the default settings. If you often use the same 
set of properties, you can save time by changing the default property settings to what you use most often. Keep in mind 
that changing the default settings does not adjust the current project. Changes will only apply to new presentations. To 
edit default settings, complete the following steps: 

1. Navigate to Edit > Preferences on the menu bar. 
2. Click the Video tab and set the following video settings: 

• Volume: Specify a value between 0 and 100. 
• Live video – time on screen: Set a default period for live videos to remain on screen (in seconds). 

3. Click the Images tab and set the following: 
• Slide transition: Use the dropdown list to set an effect for image transitions. 
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• Slide delay interval: Set how long each image displays (in seconds). 
4. Click the Interactive tab and set a default timeout period for media files (in seconds). 
5. Click the Clock tab and use the dropdown list to set a language and utilize its predefined date and time format. To 

customize the format, click Customize, enter your desired date and time format, and then click OK. 
6. Click the Live Text tab and set the following: 

• Alignment: Use the dropdown list to set whether Live Text is left aligned, right aligned, or centered. 
• Foreground text color: Click Choose and select a color for Live Text (the letters). 
• Background text color: Use the checkbox to determine whether you want to include a background text 

color for text fields. Click Choose and set a default color for the backgrounds. 
• Transparency: Drag the bar to set the transparency for background text colors.  
Note: Transparency does not appear in the Live Text image preview. You will need to publish the presentation 
to a BrightSign player to view the level of transparency. 
• Font: Click Browse and set a font for Live Text. You can use any TrueType font. Click Reset to System 

Font to reset the font. 
• Font size: Click Automatic or Fixed 

point size to enter a value for Live Text 
font size (1-500). 

Note: Changes to the default text 
preferences apply only to Live Text states 
created after presentation preferences are 
saved; these changes are not applied to 
preexisting Live Text states.  

7. Click the Networking tab and check the boxes 
to enable/disable the following: BrightSign 
Network, Local Networking, Bonjour, and Simple 
File Networking.  
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Note: If you are publishing with Local Networking but are not seeing your BrightSign players on the network, disabling 
Bonjour can help. 
8. Click the UI tab and set the following: 

• Publishing: Check the boxes to indicate whether you want to Show file overwrite dialog and/or Copy and 
replace duplicate files when publishing locally. 

• Save properties: Check the box to choose to Show save properties dialog. 
• Transitions: Set the display mode for transitions in your interactive playlist. You can select Automatic, 

Always display line, or Always display label. You can set whether you want labels to be on the Right or 
Bottom of files in your playlist area. 

9. Click OK. 
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CHAPTER 10 – MANAGING YOUR NETWORK 

You can use BrightAuthor to manage your BrightSign Network and local networks. 
 

Permissions 
Administrators of BrightSign Network accounts can create separate accounts with access to their BrightSign Networks. 
These accounts (called User Accounts) can be assigned to roles with various sets of permissions in both the BrightSign 
Network WebUI and in BrightAuthor. 
 
Access to the BrightSign Network features in BrightAuthor will depend on permissions that were determined by the 
Account Administrator. Regardless of permissions, BrightAuthor appears the same to all users. However, attempting to 
use blocked features will result in an error message. If you are an Account Administrator, you must use the web UI to 
change a User Account’s permissions in BrightAuthor. 

 
Viewing Unit Statuses 
You can view the status of all units on your BrightSign Network or Local Network in BrightAuthor. A range of colors 
(green, yellow, red) are used to indicate the status of a BrightSign player. Please see this help article for more information 
on what each color means. 
 
Local Network – Viewing unit status on your Local Network lets you view all units and their info, view active presentations 
for units, specify a username and password for units, and remove units from the network. 

1. Sign in to BrightSign Network by clicking Tools > Sign in to BrightSign Network. 
2. Click the Manage tab. 
3. Click Local Network (below the Manage tab). Here, a list of all units on the Local Network is displayed. The list 

contains all unit names, descriptions, uptimes, and current active presentations. 

http://support.brightsign.biz/entries/21994646-what-do-the-status-colors-next-to-players-and-groups-mean�
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4. Right-click a unit to Remove the unit, Show all units, Specify a username and password, or view Info. Clicking 
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Info opens the Unit Properties window. Here, you can view the unit ID, IP address, BrightSign model, firmware 
version, and autorun version. 

 
BrightSign Network – You can view the activity status of all units in your BrightSign Network, the groups to which units 
are assigned, the scheduled presentations for each group, the last connection time for each unit, and the frequency with 
which each unit connects to the network. 

1. Sign in to BrightSign Network by clicking Tools > Sign in to BrightSign Network. 
2. Click the Manage tab. 
3. Click Status (below the Manage tab). 
4. Click the arrow beside a group to view details: the devices in a group, their activity status, etc. 
5. Right-click a device in a group to Edit, Delete, access Info, or check the Download progress. 
6. (Optional) Sort the list by clicking the column you want to use as the sorting criteria. For example, to sort by status, 

click the Status column. Click again to switch between ascending and descending order. 

 
Managing Groups 
You can use Groups to distribute presentations to a specific set of BrightSign players. Publishing a presentation to a 
group delivers it to all BrightSign players within that group. BrightAuthor includes two default groups: Default and 
LocalTest. However, you can create as many groups as you need. 

1. Sign in to BrightSign Network by clicking Tools > Sign in to BrightSign Network. 
2. Click the Manage tab. 
3. Click Status (below the Manage tab). 
4. Do any of the following: 

• To create a group, click Add Groups (in the lower-left corner of the screen). Type a name for the group, and 
then click OK. 

• To delete a group, right-click a group, and then click Delete. 
• To move a device to a different group, click the arrow for the group that contains the device. Then click the 

device and drag it to the desired new group. 
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Viewing Presentations 
The Presentations tab allows you to see all presentations uploaded to the network, as well as which groups the 
presentations belong to, which presentations are active, and when they were last modified.  

1. Sign in to BrightSign Network by clicking Tools > Sign in to BrightSign Network. 
2. Click the Manage tab. 
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3. Click Presentations (below the Manage tab). 
4. Click the arrow beside a presentation to view which groups are currently using the presentation. 
5. (Optional) Sort the list of presentations by clicking the column you want to use as the sort criteria. For example, to 

sort by name, click the Name column. Click again to switch between ascending and descending order. 
 

Viewing your Library 
Viewing your library lets you see all the content you’ve uploaded to your BrightSign Network. 

1. Sign in to BrightSign Network by clicking Tools > Sign in to BrightSign Network. 
2. Click the Manage tab. 
3. Click Library (below the Manage tab). Here, all files uploaded to the network are displayed. Files with a green 

check mark are currently active. Do any of the following: 
• Switch between thumbnail and list view: Click the icons in the upper-right portion of the screen. 
• View item info: Right-click an item and click Info. Here you can view file size, type, date modified, date 

uploaded, all presentations using the file, and all Dynamic Playlists using the file. 
• Delete an item: Right-click a file and click Delete. Keep in mind that you can only delete files that aren’t 

currently active. 
• Refresh the library: Click Refresh in the upper-right portion of the screen. 

 

Viewing Dynamic Playlists 
You can view all Dynamic Playlists, the presentations that contain Dynamic Playlists, and the time/date when playlists 
were last modified. 

1. Sign in to BrightSign Network by clicking Tools > Sign in to BrightSign Network. 
2. Click the Manage tab. 
3. Click Dynamic Playlist (below the Manage tab). Here, a list of all dynamic playlists is displayed. Playlists with a 

green checkmark are currently part of a presentation. Do any of the following: 
• Delete a playlist: Right-click a dynamic playlist and then click Delete to erase it. 
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• View info: Right-click a dynamic playlist and then click Info to see when the dynamic playlist was last 
modified and a list of all presentations that contain the dynamic playlist. 

• Sort the list: You can adjust the list of dynamic playlists by clicking the column you want to use as the sort 
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criteria. For example, to sort by name, click the name column. Click again to switch between ascending and 
descending order. 
 

Using Advanced Tools 
Advanced tools let you remotely control units on your BrightSign Network or set up a USB flash drive to retrieve device 
data and perform device actions. After you set up a USB flash drive, inserting it in a BrightSign player will extract the 
specified data or perform the specified actions (e.g. reboot the player). The Advanced Tools window is divided into three 
tabs: the Setup USB Drive tab, as well as the Update Autorun and Unit Control tabs, which are only available if you 
have a BrightSign Network account. 
 
Complete the following steps to set up a USB flash drive: 

1. Click Tools > Advanced. 
2. Click the Setup USB Drive tab. The following checkboxes determine what 

actions you want to occur when the USB flash drive is inserted into the player: 
• Copy variables database: Extracts the data for all User Variables and 

Media Counters. 
• Copy log files: Extracts all log files. 
• Delete log files: Deletes all log files on the BrightSign player. 
• Reset Variables: Resets all User Variables to their default values. 
• Reboot: Reboots the BrightSign player. 
• Display status on screen during data capture: Displays the status on 

the display while the USB flash drive is inside the BrightSign player. 
3. Click Setup drive and navigate to the location of the USB flash drive on your 

computer. 
4. When the Setup Complete window opens, click OK. 
5. Remove the USB flash drive from your computer and insert it in the player.  
6. If you are extracting data from the player, reinsert the USB flash drive into your computer to retrieve the data. 
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Complete the following steps to control players linked to your BrightSign Network account: 

1. Sign in to BrightSign Network by clicking Tools > Sign in to BrightSign Network. 
2. Click Tools > Advanced. 
3. Click the Update Autorun tab. A list of all your groups is displayed here. 

Check the checkboxes and then click Update now to update the Autorun 
version for those groups. 

4. Click the Unit Control tab. 
5. In the Serial Number field, type the serial number of the unit you want to 

control. 
6. Click the Action dropdown list to select the action you want to perform: 

• Reboot unit: Restarts the BrightSign. 
• Upload logs: Uploads log files based on the upload logs setting you 

selected when setting up the unit. 
• Recover – reformat: Puts the unit in recovery mode and reformats the 

unit’s storage card. 
• Recover – don’t reformat: Puts the unit in recovery mode and downloads the latest Autorun script to the 

storage card without reformatting it. 
7. (Optional) Click Add action to add another action, or remove an action by clicking Remove action. 
8. Click Close.  
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CHAPTER 11 – FREQUENTLY ASKED QUESTIONS 

For additional Frequently Asked Questions, go to http://support.brightsign.biz/forums. 
 
Can I use BrightAuthor with the HD600 or HD2000? 

No. Currently, BrightAuthor only supports the following BrightSign players: HD110, HD120, HD210, HD210w, 
HD220, HD410, HD810, HD1010, HD1010w, HD1020, and TD1012. 

 
Can I open the autoplay.xml file using BrightAuthor? 

No. The autoplay.xml file that is generated when you publish a presentation is a playlist file. This file includes only 
the information required for playback on a BrightSign player. It is not the same as a presentation project file.  

 
How do I use a different font? 

To use a different font, browse to a folder on your computer that has a true type font (e.g. in a Ticker zone, click 
Zone Properties, and then click Browse beside font). This font will be copied to the SD card when you publish the 
presentation. You can use your own custom fonts or download free TrueType fonts from the web. 
 

Can I export a template? 
Yes. Although there isn’t a template export option, you can save a presentation project with the desired template 
layout, and then transfer it to another computer. You can then open the project in BrightAuthor, and then save the 
template (Layout > Save Template). 

 
Can I use the scheduling feature on the HD110 or HD410? 

All units manufactured and purchased since November 2010 have a real time clock that supports scheduling. Older 
HD110 and HD410 models do not support scheduling. 

 

http://support.brightsign.biz/forums�
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Why does BrightAuthor take a long time to process my folder? 
If the folder you selected has a large number of images and videos, the Media Library may take a few minutes to 
update. Please be patient. 

 
Why can’t BrightAuthor locate my files when I try to publish my presentation? 

If you copy a presentation project from one computer to another, or move or rename files used in a BrightAuthor 
project, BrightAuthor cannot locate the files, and you will receive an error message when you try to publish. To 
resolve the error, you must remove the files from each zone’s playlist in the presentation and then add them again.  

 
Why are some of my videos missing thumbnails in the Files tab? 

The thumbnails are generated by codecs installed on your computer. You can download codecs to resolve the 
problem. For example, if you’re missing thumbnails for your transport streams, you can try downloading a codec 
such as K-Lite. 

 
What do I do if BrightAuthor crashes while I’m using it? 

For any errors or crashes you encounter while using BrightAuthor, please post a description of the problem in the 
forums (http://support.brightsign.biz/forums) or send us an email at support@brightsign.biz and include the 
following information: 

 
• Steps to duplicate the problem (or indicate that you can’t duplicate it) 
• Any error dialogs you saw, including text in the dialog 
• The contents of your event log right after the crash. You can find the log in this folder: 

C:\Users\Owner\AppData\Local\BrightSign\BrightAuthor\  
o Look for a subfolder named after the BrightAuthor version number, such as 2.4.0. 

• A copy of the presentation project where you experienced the problem 
 

  

http://support.brightsign.biz/forums�
mailto:support@brightsign.biz�
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APPENDIX A – REMOTE CONTROL PROTOCOLS 
Complete the following steps to set up your BrightSign player to communicate with a remote control: 
Create an interactive presentation (see Making a presentation interactive). 

1. Define an interactive event with the Remote Input event. 
2. In the Remote Input Event window, specify the remote input with any of the following remote control codes: 

WEST 
EAST 
NORTH 
SOUTH 
SEL 
EXIT 
PWR 
MENU 
SEARCH 
PLAY 
FF 
RW 
PAUSE 
ADD 
SHUFFLE 
REPEAT 
VOLUP 
VOLDWN 
BRIGHT 

3. Repeat the above steps for each remote input you want to define. 
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CHANGE LOG 

Version 3.5 
April 11, 2013 

• Revised Chapter 2 > Setting up a Player for Standalone Use Chapter 8 > Publishing with Local Storage to 
include information about publishing with USB drives and using password protection for these content updates. 

• Added additional information about using Portrait Orientation to Chapter 3 > Creating a Full-Screen 
Presentation. 

• Revised the explanation in Chapter 4 > Event Handlers to include new Stop Playback functionality. 
• Added a note to Capter 5 > Ticker Zones explaining how to use alignment settings with right-to-left languages. 


