# TABLE OF CONTENTS

**Chapter 1 – Getting Started**

What is BrightAuthor? ............................................................................................................................ 1
What Kind of Presentations Can I Create?............................................................................................. 1
What Type of Screen Layouts Can I Use? ............................................................................................. 2
Step 1: Get the Hardware You Need ...................................................................................................... 2
Step 2: Install BrightAuthor ..................................................................................................................... 4
Step 3: Launch BrightAuthor .................................................................................................................. 5
Step 4: Set up your BrightSign player .................................................................................................... 5
Step 5: Add your Content ....................................................................................................................... 5
Step 6: Create your Presentations ......................................................................................................... 7
Step 7: Publish your Presentations ........................................................................................................ 7

**Chapter 2 – Setting up BrightSign Players**

Adding a Player to the BrightSign Network ............................................................................................ 9
Adding a Player to your Local Network ................................................................................................ 15
Adding a Player to your Simple File Network ....................................................................................... 20
Setting up a Player for Standalone Use ............................................................................................... 26

**Chapter 3 – Creating Presentations**

Creating a Full-Screen Presentation .................................................................................................... 31
<table>
<thead>
<tr>
<th>Chapter 5 – Interactive Events</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timeout</td>
<td>87</td>
</tr>
<tr>
<td>Media End</td>
<td>87</td>
</tr>
<tr>
<td>GPIO Event</td>
<td>87</td>
</tr>
<tr>
<td>BP900/200</td>
<td>88</td>
</tr>
<tr>
<td>Synchronize</td>
<td>88</td>
</tr>
<tr>
<td>UDP Input</td>
<td>88</td>
</tr>
<tr>
<td>Serial Input</td>
<td>89</td>
</tr>
<tr>
<td>Rectangular Touch</td>
<td>89</td>
</tr>
<tr>
<td>Keyboard Input</td>
<td>90</td>
</tr>
<tr>
<td>USB Input</td>
<td>90</td>
</tr>
<tr>
<td>Remote Input</td>
<td>90</td>
</tr>
<tr>
<td>Zone Message</td>
<td>91</td>
</tr>
<tr>
<td>Link Zones</td>
<td>91</td>
</tr>
</tbody>
</table>
CHAPTER 1 – GETTING STARTED

What is BrightAuthor?
BrightAuthor is a software application that helps you create and publish digital-signage presentations for BrightSign players. You can play BrightAuthor presentations on all BrightSign models. Your presentations can include various types of content:

- Images
- Videos
- Live video: Supported on the XD1230, XD1132, and 4K1142
- Audio
- HTML5 pages
- Streaming audio/video over IP
- Text
- Date and time
- RSS, MRSS, and Twitter feeds
- BrightSign Network features: Dynamic Playlists, Live Text feeds (RSS), Live Media feeds (MRSS)
- SignChannel: Supported on all XD and 4K models, as well as the HD222, HD1022, HD220, HD1020, and LS422

Note: A subscription is required to use SignChannel. Go to http://www.signchannel.com/ for details.

What Kind of Presentations Can I Create?
You can create three types of presentation in BrightAuthor:

- Non-Interactive: A playlist of media (images, video, audio) that plays in a continuous loop. You can play non-interactive presentations on all BrightSign models.
- Interactive: A presentation that transitions between media based on input from a user via a button board, touchscreen, remote control, or similar input device. All models support at least one type of interactive event. The types of interactive event supported by a player depend on the connectors and inputs that player has (for example,
players with a USB 2.0 port support touch screen and button board events, and players with an Ethernet port support UDP events).

- **BrightWall™**: A non-interactive playlist of media (images, video, live video) that is closely synchronized across multiple players. BrightWall presentations are supported on all 4K and XD models, as well as the HD222, HD1022, HD220, HD1020, and LS422.

**What Type of Screen Layouts Can I Use?**

You can choose from a variety of ready-to-use layout templates. You can also create your own template. Layout templates fall into two basic categories:

- **Full Screen**: A simple, looping playlist of media that occupies the full screen (or plays over audio).
- **Multi-Zone**: A presentation with different types of content in separate regions of the screen. The screen can include multiple Clock, Text, Ticker, and Image zones, as well as (depending on the player model) multiple video zones.

**Step 1: Get the Hardware You Need**

To create presentations with BrightAuthor and publish them to your player, you will need the following:

- Windows PC
- BrightSign player
- Display
- Storage device
- Card reader/writer (optional if using USB storage)
- Input device (optional)

**Windows PC** – Any Windows PC that meets or exceeds the following *minimum* requirements:

- 2.3 GHz CPU
- 2 GB RAM required (4 GB recommended)
- 100 MB available hard disk space for program files (additional disk space required if storing content and/or presentations on your hard disk)
• One of the following operating systems:
  o Windows Vista 32 or 64 bit
  o Windows 7 32 or 64 bit
  o Windows 8 32 or 64 bit

**BrightSign Player** – Any of the following models:
• 4K242, 4K1042, 4K1142
• XD232, XD1032, XD1132
• XD230, XD1030, XD1230
• HD222, HD1022
• HD120, HD220, HD1020, HD970, AU320
• LS322, LS422

**Display** – Any monitor, TV, or touchscreen with one of the following types of inputs:
• HDMI
• VGA (on all model lines except 4Kx42)
• Component (supported with a VGA converter on all model lines except 4Kx42)

**Storage Device** – Any of the following:
• USB Flash Drive (supported on the 4K242, 4K1042, 4K1142, XD1132, XD1032, XD1030, XD1230, HD1022, HD1020, LS322, LS422)
• SD card
• SDHC card
• SDXC card
• μSD card (4K and XD models only)
• mSATA drive (4K models only)

**Note:** We recommend formatting your SD, SDHC, or SDXC card using FAT32. Formatting your card using NTFS
allows you to play media files that are 4GB or larger in size, but the player will not be able to receive network updates or generate logs.

**Card Reader/Writer** – Only required if using an SD card. The card reader/writer must be connected to your PC and must be compatible with your storage card.

**Input Device** – Required for interactive presentations only. BrightSign players support one or more of the following types of input devices:

- Touchscreen equipped with a supported touch controller. See this [link](#) for a list of all supported touch controllers. (4K1042, 4K1142, XD1032, XD1132, XD1030, XD1230, HD1022, HD1020, LS422)
- BrightSign’s [BP200 and BP900](#) USB button panels (4K1042, 4K1142, XD1032, XD1132, XD1030, XD1230, HD1022, HD1020, LS322, LS422)
- Many brands of USB Keyboards (4K1042, 4K1142, XD1032, XD1132, XD1030, XD1230, HD1022, HD1020, LS322, LS422)
- Many brands of USB Mouse or Trackball (4K1042, 4K1142, XD1032, XD1132, XD1030, XD1230, HD1022, HD1020, LS422)
- Many brands of USB Bar Code Scanners (4K1042, 4K1142, XD1032, XD1132, XD1030, XD1230, HD1022, HD1020, LS322, LS422)
- Quadravox Serial Button Board
- AMX, Crestron, and similar control devices
- Any GPIO (open/close contact switch) button, signal, or LED (your custom board or LED display)
- PC (via UDP or serial)
- IR input/output devices using the NEC or Pronto Hex remote control protocols (all 4K and XD models, as well as the HD1022, HD1020, HD810, HD1010, HD1010w).

**Step 2: Install BrightAuthor**

Download the latest software and install it on your PC.
1. Go to the BrightSign Support page.
2. Click the Software Downloads link and select the appropriate BrightAuthor version for download.
3. Follow the onscreen instructions to install the software on your PC.

**Note**: BrightAuthor requires the latest version of Microsoft .Net Framework. If this component is not already on your PC, BrightAuthor installs it during the installation. However, if BrightAuthor needs to install Microsoft .Net Framework, the installation may take up to 45 minutes to complete and you may need to restart your PC to complete the installation process.

**Step 3: Launch BrightAuthor**
1. Double-click the BrightAuthor icon on your desktop.
2. (Optional) If prompted, sign in to BrightSign Network (account required). See the Publishing with BrightSign Network section for more details.

**Step 4: Set up your BrightSign player**
1. Depending on how you want to publish your presentations, create the appropriate setup files for your BrightSign player.
2. Insert the SD card or USB flash drive that contains the setup files into the player.
3. Connect your player to a display and power it on.

**Step 5: Add your Content**
BrightAuthor presentations can include the following types of media files:

**Video files**
BrightSign players support the following video file encodings/compressions:
- MPEG-2: Can be saved as an .mpg, .ts, .m2ts or .vob container.
- MPEG-1: Can be saved as an .mpg container.
- (4K models only) H.265 (HEVC): Can be saved as an .ts, .mov, or .mkv container
- H.264 (MPEG-4, Part 10): Can be saved as a .mp4, .mov, or .ts container.

**Note:** .mov files with compressed “atoms” (i.e. metadata) are not currently supported.

- WMV: .wmv video only files (.wma audio files are not supported). Support includes videos exported from Powerpoint.

For further details on video file encoding and support, see the support page on the BrightSign website.

**Audio files**

BrightSign players support the following audio formats:

- AAC (LC - Low complexity profile) at a Constant Bit Rate, as part of a video file (.mp4, .mov, or .ts) at 44.1 KHz, 48 KHz
- MP2 (MPEG-1 Layer 2) at a Constant Bit Rate, as part of a video file (.mpg or .ts) at 44.1 KHz, 48 KHz
- MP3 at a Constant Bit Rate (44.1 KHz, 48 KHz, or 32 KHz at up to a bitrate of 224 Kbps) as a standalone file (i.e. not encoded as an audio track in a video file)
- AC3 5.1 passed through (un-decoded, RAW data) HDMI. Audio streams in this format are supported by BrightSign players, but will require an AC3 decoder (HDMI AV receiver).
- WAV

**Image files**

For still images, use BMP, PNG, or JPEG files. The maximum supported resolution is 1920x1080: If you attempt to add an image file larger than this resolution, BrightAuthor will give you the option to create a downscaled copy of the image.

**Note:** BrightSign players do not support JPEG image files with CMYK color profiles. You can convert your CMYK JPEGs to RGB JPEGs using this free web-based converter.

**HTML5 files**

See the HTML5 Best Practices guide for more information on the HTML features that can be used with the BrightSign player.
Step 6: Create your Presentations
Now you’re ready to start using BrightAuthor to create presentations. Just add your content and follow the directions in the next chapters of this guide to create your presentations.

Step 7: Publish your Presentations
After creating presentations, use the publishing feature to deliver them to your BrightSign players. See Publishing Presentations for details.
CHAPTER 2 – SETTING UP BRIGHTSIGN PLAYERS

Before you can publish presentations, you must first set up your BrightSign players. How you set up your units will depend on how you want to publish presentations to your players:

- **BrightSign Network**: The BrightSign Network is a cloud based content-management system (CMS) that allows you to remotely schedule presentations, distribute content, assign players to groups, and monitor player health the health status of each player.

- **Local Network**: With local file networking, you can use BrightAuthor to schedule presentations and distribute content to players over your local network.

- **Simple File Network**: Simple file networking allows you to schedule presentations and distribute content remotely using your own web server.

- **Standalone**: The standalone method allows you to publish presentations directly to your player using an SD card or USB drive. Use this method if your player doesn’t have a network connection or if you do not plan to update the presentation frequently.

If you’re using the BrightSign Network, Local Networking, or Simple File Networking to publish your presentations, you must set up your BrightSign units by adding them to your local network. Alternatively, you can set up BrightSign players for use as standalone units that are not connected to a network. With this option, you will need to manually update the player storage (SD card or USB flash drive) each time you want to update presentations. For more details on the publishing process, see Publishing Presentations.

To set up a player, you need to create setup files in BrightAuthor and add those files to a storage device (SD card or USB flash drive). Next, insert the storage into the BrightSign player. Keep in mind that this storage must remain inside the player. BrightSign players have no internal storage and, therefore, cannot download or play content without a storage device connected. Once the storage device (typically an SD card) is inserted, your BrightSign player is ready to receive and play presentations.
Adding a Player to the BrightSign Network
To publish and manage presentations using BrightSign Network, you must first contact BrightSign to obtain an account name, user name, and password.

After you obtain your account credentials, you can create the setup files for each unit. The setup files provide details about what your network and BrightSign Network connections are, where the presentations associated with the selected group are stored, and when the presentations are scheduled.

1. Sign in to your BrightSign Network account.
   a. In the BrightAuthor menu bar, click Tools > Sign in to BrightSign Network.
   b. If prompted, enter your Account, User name, and Password, and then click Sign In.
2. On the menu bar, click Tools > Setup BrightSign Unit.
3. Under Name Specification, do the following:
   a. Enter a Name and Description for this unit.
   b. Select whether you want to append the unit ID to the name or use only the name.
4. Under Network Properties, set the following:
   a. Enable Wireless: Check this box if you plan to connect to the local network using a wireless connection. In order to use a wireless connection, you must purchase a Wireless Module for your BrightSign player. Enter an SSID and Security key if the player is connecting to a secured network.
   b. Network Connection Priority: Use the up and down arrows to prioritize either the Wired or Wireless connection. The BrightSign player will always attempt to download and upload using the first option. It will only use the second option if the first is unavailable.
   c. Time zone: Select the time zone where the unit is located.
   d. Time server: Select the clock for this unit.
5. Click the Advanced Network Setup button to customize advanced settings for your networked player. Specify the following in the Unit Configuration tab:
   a. Specify hostname: Check this box if you want to specify a custom hostname for the player on the network. By default, the player serial number is used to generate a unique hostname.
b. **Use Proxy**: Check this box if you want the player to connect using a proxy server. Type the address and port number of the proxy in the fields below. If you need to provide a user name and password, use this format: `<user name>:<password>@<proxy server address>` (e.g. “admin:root@myproxy.com”).

c. **Limit content downloads**: Check this box if you want to restrict player content downloads to a certain time of day. This is helpful if you want to limit network traffic during peak hours. Use the **Start Of Range** and **End Of Range** parameters to specify a time frame during which content downloads can occur.
d. **Limit health updates**: Check this box if you want to limit when the player sends health updates to the BrightSign Network. This is helpful if you know a player will be powered off or otherwise disabled during a certain time of day. Use the **Start Of Range** and **End Of Range** parameters to specify a time frame during which content downloads can occur.

e. **Copy content from the current published schedule**: Check this box if you want BrightAuthor to copy the current published schedule to the storage device with the setup files. This is helpful if you don’t want the player downloading large content files from the BrightSign Network right after it is set up.

6. Specify the following in the **Wired** and **Wireless** tab of the **Advanced Network Setup** window:

a. **Data Types Enabled**: Use these checkboxes to determine the types of data that will be transferred using the connection. You can enable/disable both downloads (**Content**, **Text Feeds**, **Media Feeds**) and uploads (**Health**, **Log Updates**).

b. **Connection Settings**: Indicate whether the IP address is auto-generated (via DHCP) or static. If you’re using a static IP address, enter the parameters in the fields below.

c. **Rate Limit Network Download Traffic**: Set rate limitations for downloading content. The options are divided into three categories: **Outside content download window** and **During content download window** (both of which correspond to the **Limit content downloads** setting in the **Unit Configuration** tab), as well as **During initial downloads**.
   i. Click **Unlimited download rate** to set no limit.
   ii. Click **Default limit** to use the default limit (2000 Kbit/s) on downloads.
   iii. Click **Specify limit** to enter a customized limit on downloads in the text field (in Kbits/second).

7. Select the **Diagnostics** tab in the **Advanced Network Setup** window if you would like the player to perform network diagnostics when first booting up.

a. **Enable network diagnostics**: The player will display the network diagnostics screen during setup.
   i. **Test Ethernet**: The player will indicate whether or not it was able to attain an IP address over Ethernet.
   ii. **Test Wireless**: The player will indicate whether or not it was able to attain an IP address over wireless.
   iii. **Test Internet Connection**: The player will indicate whether or not it was able to attain a connection to remote services.
8. Click **Specify Firmware Update** to indicate whether you want to update the firmware and to which version. The Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign unit, select a firmware version or select **Do not update**, and then click **OK**.

9. Under **Unit Configuration**, click **Networked with BrightSign Network**, and then specify the following:
   a. (Optional) **Enable diagnostic web server**: Check this box to enable the **Diagnostic Web Server**. You can include a username and password in the text fields below for added security.
   b. (Optional) **Enable local web server**: Check this box to enable the **Local Web Server**. You can include a username and password in the text fields below for added security.
   c. (Optional) **Enable Update Notifications**: Check this box to have the player automatically refresh the **User Variables webpage** whenever variable values change on the player.

10. Select the **Networked with the BrightSign Network** option.
   a. **Group**: Select this option to include the player in a standard BSN group. Use the dropdown list to select a BSN group for the unit. Groups allow you to publish presentation schedules to multiple units simultaneously. See [Manage > Status](#) and [Publishing with BrightSign Network](#) sections for details.
   b. **BrightWall Group**: Select this option to include the player in a BSN BrightWall group. Use the dropdown list to
select a BrightWall group for the unit. Each BrightWall group includes one or more BrightWall(s) that share a common configuration file, and each BrightWall in a BrightWall group plays the same presentation.

i. **BrightWall Name**: Use the dropdown list to assign the player to a BrightWall within the BrightWall group. If you haven’t created the BrightWall yet, click **Add BrightWall** and enter the **BrightWall name**. Note that a new BrightWall will utilize the configuration file that is assigned to the BrightWall group.

ii. **Screen Number**: Specify the section of the BrightWall to which the player belongs. Screens are numbered by row, starting from the top-left section of the BrightWall (the example diagram to the right shows the numbering of a 4x3 BrightWall).

c. **Content Check Frequency**: Specify how often the player should communicate with the BSN servers to determine if there is new scheduled content to download.

d. **Update Health Frequency**: Specify how often the player should send health status updates to the BSN servers. This determines how up-to-date the **Player Status colors** are.

11. Under **Logging**, check any of the following boxes to enable/disable logs and specify upload settings:

a. **Enable playback logging**: Creates a log that records start and end times, zone names, media types, and file names.

b. **Enable event logging**: Creates a log that records timestamps, state names, zone names, event types, and event data.

c. **Enable state logging**: Creates a log that records current and last state names, timestamps, and media types.

d. **Enable diagnostic logging**: Creates a log that records timestamps, firmware and script versions, and the current presentation.

e. **Upload logs**:

   i. **On startup**: Uploads log files each time the player is powered on.

   ii. **At specific time each day**: Uploads log files daily at the specified time. Use the dropdown lists to pick a time.

12. Check the **Enable remote snapshot** box to enable the Remote Snapshot feature, which allows you to remotely monitor the contents of the presentation display.

   **Note**: *The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.*

   a. **Remote snapshot every [ ] minutes**: Specify how often the player should take a snapshot of the presentation display.
b. **Save up to [ ] images (1 - 100) on local storage**: Specify how many JPEG images can be stored on the local storage of the player.

c. **JPEG quality level [ ] (0 - 100)**: Specify the quality level (and thus the file size) of each image file.

d. **Display snapshots in portrait mode**: Check this box to have the player rotate the snapshots to portrait mode before saving and uploading them.

13. Use the **RF Channel Scan Data (optional)** field if you need to publish the same **RF channel scan** settings to multiple XD1230 players. See **Publishing Channel Scan Results** for more details.

14. Use the **Screen Color** option to specify what screen color the player should display after it has successfully completed the setup process. When the player displays this color, it is ready to receive content.

15. Create and install the setup files:

   a. Click **Create Setup Files**.
   b. Browse to and select an SD card (recommended) or USB flash drive to store the setup files.

   **Note**: *We recommend formatting your SD, SDHC, or SDXC card using FAT32. Formatting your card using NTFS allows you to play media files that are 4GB or larger in size, but the player will not be able to receive network updates or generate logs.*

   c. Click **OK**.
   d. Turn off the BrightSign unit by unplugging the power adapter (or Ethernet cable if the player is being powered by PoE).
   e. Insert the card or flash drive into the unit.
   f. Turn on the BrightSign unit by reconnecting the power.

   **Important**: *Do not remove the SD card or flash drive from the player.*
Adding a Player to your Local Network

With Local File Networking, you can use BrightAuthor to schedule presentations and distribute content to players over the local network.

1. In the BrightAuthor menu bar, click **Tools > Setup BrightSign Unit**.
   a. Under **Name Specification**, do the following:
      b. Enter a **Name** and **Description** for this unit.

2. Select whether you want to append the unit ID to the name or use only the name.

3. Under **Network Properties**, set the following:
   a. **Enable Wireless**: Check this box if you plan to connect to the local network using a wireless connection. In order to use a wireless connection, you must purchase a **Wireless Module** for your BrightSign player. Enter an **SSID** and **Security key** if the player is connecting to a secured network.
   b. **Network Connection Priority**: Use the up and down arrows to prioritize either the **Wired** or **Wireless** connection. The BrightSign player will always attempt to download and upload using the first option. It will only use the second option if the first is unavailable.
   c. **Time zone**: Select the time zone where the unit is located.
   d. **Time server**: Select the clock for this unit.

4. Click the **Advanced Network Setup** button to customize advanced settings for your networked player. Specify the following in the **Unit Configuration** tab:
   a. **Specify hostname**: Check this box if you want to specify a custom hostname for the player on the network. By default, the player serial number is used to generate a unique hostname.
   b. **Use Proxy**: Check this box if you want the player to connect using a proxy server. Type the address and port number of the proxy in the fields below. If you need to provide a user name and password, use this format: `<user name>:<password>@<proxy server address>` (e.g. “admin:root@myproxy.com”).

5. Specify the following in the **Wired** and **Wireless** tab of the **Advanced Network Setup window**:
   a. **Data Types Enabled**: Use these checkboxes to determine the types of data that will be transferred using the connection. You can enable/disable both downloads (**Content, Text Feeds, Media Feeds**) and uploads (**Log Updates**).
b. **Connection Settings**: Indicate whether the IP address is auto-generated (via DHCP) or static. If you’re using a static IP address, enter the parameters in the fields below.

6. Select the **Diagnostics** tab in the **Advanced Network Setup** window if you would like the player to perform network diagnostics when first booting up.
   
   a. **Enable network diagnostics**: The player will display the network diagnostics screen during setup.
      
      i. **Test Ethernet**: The player will indicate whether or not it was able to attain an IP address over Ethernet.
      
      ii. **Test Wireless**: The player will indicate whether or not it was able to attain an IP address over wireless.
iii. **Test Internet Connection**: The player will indicate whether or not it was able to attain a connection to remote services.

7. Click **Specify Firmware Update** to indicate whether you want to update the firmware and to which version. The Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign unit, select a firmware version or **Do not update**, and then click **OK**.

![Firmware Update Window]

8. Under **Unit Configuration**, click **Networked with Local File Networking**, and then specify the following:
   a. (Optional) **Enable diagnostic web server**: Check this box to enable the [Diagnostic Web Server](#). You can include a username and password in the text fields below for added security.
   b. (Optional) **Enable local web server**: Check this box to enable the [Local Web Server](#). You can include a username and password in the text fields below for added security.
   c. (Optional) **Enable Update Notifications**: Check this box to have the player automatically refresh the [User Variables webpage](#) whenever variable values change on the player.

9. Under **Logging**, check any of the following boxes to enable/disable logs and specify upload settings:
a. **Enable playback logging**: Creates a log that records start and end times, zone names, media types, and file names.

b. **Enable event logging**: Creates a log that records timestamps, state names, zone names, event types, and event data.

c. **Enable state logging**: Creates a log that records current and last state names, timestamps, and media types.

d. **Enable diagnostic logging**: Creates a log that records timestamps, firmware and script versions, and the current presentation.

10. Check the **Enable remote snapshot** box to enable the Remote Snapshot feature, which allows you to remotely monitor the contents of the presentation display.

   **Note**: The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.

   a. **Remote snapshot every [ ] minutes**: Specify how often the player should take a snapshot of the presentation display.

   b. **Save up to [ ] images (1 - 100) on local storage**: Specify how many JPEG images can be stored on the local storage of the player.

   c. **JPEG quality level [ ] (0 - 100)**: Specify the quality level (and thus the file size) of each image file.

   d. **Display snapshots in portrait mode**: Check this box to have the player rotate the snapshots to portrait mode before making them available.

11. Use the **RF Channel Scan Data (optional)** field if you need to publish the same RF channel scan settings to multiple XD1230 players. See Publishing Channel Scan Results for more details.

12. Use the **Screen Color** option to specify what screen color the player should display after it has successfully completed the setup process. When the player displays this color, it is ready to receive content.

13. Create and install the setup files:

   a. Click **Create Setup Files**.

   b. Browse to and select an SD card (recommended) or USB flash drive to store the setup files.

   **Note**: We recommend formatting your SD, SDHC, or SDXC card using FAT32. Formatting your card using NTFS allows you to play media files that are 4GB or larger in size, but the player will not be able to receive network updates or generate logs.

   c. Click **OK**.
d. Turn off the BrightSign unit by unplugging the power adapter (or Ethernet cable if the player is being powered by PoE).
e. Insert the card or flash drive into the unit.
f. Turn on the BrightSign unit by reconnecting the power.

**Important:** *Do not remove the SD card or flash drive from the player.*
Adding a Player to your Simple File Network

With simple file networking, the setup file provides details about your network, the web folder associated with a unit, where presentations are stored, and when to check for updates.

1. In the BrightAuthor menu bar, click Tools > Setup BrightSign Unit.
2. Under Name Specification, do the following:
   a. Enter a Name and Description for this unit.
   b. Select whether you want to append the unit ID to the name or use only the name.
3. Under Network Properties, set the following:
   g. Enable Wireless: Check this box if you plan to connect to the local network using a wireless connection. In order to use a wireless connection, you must purchase a Wireless Module for your BrightSign player. Enter an SSID and Security key if the player is connecting to a secured network.
   a. Network Connection Priority: Use the up and down arrows to prioritize either the Wired or Wireless connection. The BrightSign player will always attempt to download and upload using the first option. It will only use the second option if the first is unavailable.
   b. Time zone: Select the time zone where the unit is located.
   c. Time server: Select the clock for this unit.
4. Click the Advanced Network Setup button to customize advanced settings for your networked player. Specify the following in the Unit Configuration tab:
   a. Specify hostname: Check this box if you want to specify a custom hostname for the player on the network. By default, the player serial number is used to generate a unique hostname.
   b. Use Proxy: Check this box if you want the player to connect using a proxy server. Type the address and port number of the proxy in the fields below. If you need to provide a user name and password, use this format: <user name>:<password>@<proxy server address> (e.g. “admin:root@myproxy.com”).
   c. Limit content downloads: Check this box if you want to restrict player content downloads to a certain time of day. This is helpful if you want to limit network traffic during peak hours. Use the Start Of Range and End Of Range parameters to specify a time frame during which content downloads can occur.
5. Specify the following in the Wired and Wireless tab of the Advanced Network Setup window:
a. **Data Types Enabled**: Use these checkboxes to determine the types of data that will be transferred using the connection. You can enable/disable both downloads (**Content**, **Text Feeds**, **Media Feeds**) and uploads (**Log Updates**).

b. **Connection Settings**: Indicate whether the IP address is auto-generated (via DHCP) or static. If you’re using a static IP address, enter the parameters in the fields below.

c. **Rate Limit Network Download Traffic**: Set rate limitations for downloading content. The options are divided into
three categories: **Outside content download window** and **During content download window** (both of which correspond to the **Limit content downloads** setting in the **Unit Configuration** tab), as well as **During initial downloads**.

i. Click **Unlimited download rate** to set no limit.

ii. Click **Default limit** to use the default limit (2000 Kbit/s) on downloads

iii. Click **Specify limit** to enter a customized limit on downloads in the text field (in Kbits/second).

6. Select the **Diagnostics** tab in the **Advanced Network Setup** window if you would like the player to perform network diagnostics when first booting up.

a. **Enable network diagnostics**: The player will display the network diagnostics screen during setup.

   i. **Test Ethernet**: The player will indicate whether or not it was able to attain an IP address over Ethernet.

   ii. **Test Wireless**: The player will indicate whether or not it was able to attain an IP address on the wireless network.

   iii. **Test Internet Connection**: The player will indicate whether or not it was able to attain a connection to remote services.

7. Click **Specify Firmware Update** to indicate whether you want to update the firmware and to which version. The Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign unit, select a firmware version or **Do not update**, and then click OK.

8. Under **Unit Configuration**, click **Networked with Simple File Networking**, and then specify the following:

a. (Optional) **Enable diagnostic web server**: Check this box to enable the **Diagnostic Web Server**. You can include a username and password in the text fields below for added security.

b. (Optional) **Enable local web server**: Check this box to enable the **Local Web Server**. You can include a username and password in the text fields below for added security.

c. (Optional) **Enable Update Notifications**: Check this box to have the player automatically refresh the **User Variables webpage** whenever variable values change on the player.

d. **URL for the web folder**: Set the location from which the player will download presentations. Do not use trailing slashes in your URL; some web servers do not support trailing slashes.
Important: The URL for the web folder must be identical to the web folder URL you enter when publishing presentations. See Simple File Networking for details.

e. **Content Check Frequency**: Set how often you want the unit to check the server for updates.

f. (optional) **Simple File Networking Authentication**: Enables digest authentication between the BrightSign player and the web server.
   
   i. **Enable basic authentication**: Passes credentials to the web server in unsecured packets that are easily readable by others. Use this option only if it is absolutely required by the configuration of your web server.

9. Under **Logging**, check any of the following boxes to enable/disable logs and specify upload settings:

   a. **Enable playback logging**: Creates a log that records start and end times, zone names, media types, and file names.

   b. **Enable event logging**: Creates a log that records timestamps, state names, zone names, event types, and event data.

   c. **Enable state logging**: Creates a log that records current and last state names, timestamps, and media types.

   d. **Enable diagnostic logging**: Creates a log that records timestamps, firmware and script versions, and the current presentation.
e. **Upload logs**
   i. **On startup**: Uploads log files each time the player is powered on.
   ii. **At specific time each day**: Uploads log files daily at the specified time. Use the dropdown lists to pick a time.
   iii. **Relative URL for log handler**: Specify the location on the server where you want logs to be uploaded and parsed.

10. Check the **Enable remote snapshot** box to enable the Remote Snapshot feature, which allows you to remotely monitor the contents of the presentation display.

   **Note**: The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.

   a. **Remote snapshot every [ ] minutes**: Specify how often the player should take a snapshot of the presentation display.
   b. **Save up to [ ] images (1 - 100) on local storage**: Specify how many JPEG images can be stored on the local storage of the player.
   c. **JPEG quality level [ ] (0 - 100)**: Specify the quality level (and thus the file size) of each image file.
   d. **Display snapshots in portrait mode**: Check this box to have the player rotate the snapshots to portrait mode before saving and uploading them.
   e. **Relative URL for remote snapshot handler**: Specify the location on the server where you want snapshots to be uploaded.

11. Use the **RF Channel Scan Data (optional)** field if you need to publish the same RF channel scan settings to multiple XD1230 players. See Publishing Channel Scan Results for more details.

12. Use the **Screen Color** option to specify what screen color the player should display after it has successfully completed the setup process. When the player displays this color, it is ready to receive content.

13. Create and install the setup files:
   a. Browse to and select an SD card (recommended) or USB flash drive to store the setup files.

      **Note**: We recommend formatting your SD, SDHC, or SDXC card using FAT32. Formatting your card using NTFS allows you to play media files that are 4GB or larger in size, but the player will not be able to receive network updates or generate logs.
   b. Turn off the BrightSign unit by unplugging the power adapter (or Ethernet cable if the player is being powered by PoE).
c. Insert the card or flash drive into the unit.
d. Turn on the BrightSign unit by reconnecting the power.

**Important:** *Do not remove the SD card or flash drive from the player.*
Setting up a Player for Standalone Use

Standalone players are not connected to a network and must be updated manually. To change presentations/schedules, you must remove the storage card (or USB flash drive), update it on your computer, and reinsert it into the player.

Updating standalone units is the only case in which you should remove the storage card after setting up the unit. If your player has a USB flash drive slot, it is recommended that you use an SD card when setting up the unit, and keep it in the player as the internal storage. You can update the content on the SD card via a USB flash drive. See Publishing with Local Storage for details. With standalone units, the setup files provide details about where presentations are stored and whether logging options are enabled.

1. In the BrightAuthor menu bar, click Tools > Setup BrightSign Unit.

2. Under Name Specification, do the following:
   a. Enter a Name and Description for this unit.
   b. Select whether you want to append the unit ID to the name or use only the name.

3. Under Network Properties, set the following:
   a. Enable Wireless: Check this box if you plan to connect to the local network using a wireless connection. In order to use a wireless connection, you must purchase a Wireless Module for your BrightSign player. Enter an SSID and Security key if the player is connecting to a secured network.
   b. Network Connection Priority: Use the up and down arrows to prioritize either the Wired or Wireless connection. The BrightSign player will always attempt to download and upload using the first option. It will only use the second option if the first is unavailable.
   c. Time zone: Select the time zone where the unit is located.
   d. Time server: Select the clock for this unit.

4. Click the Advanced Network Setup button to customize advanced settings for your networked player. Specify the following in the Unit Configuration tab:
   a. Specify hostname: Check this box if you want to specify a custom hostname for the player on the network. By default, the player serial number is used to generate a unique hostname.
b. **Use Proxy**: Check this box if you want the player to connect using a proxy server. Type the address and port number of the proxy in the fields below. If you need to provide a user name and password, use this format: `<user name>:<password>@<proxy server address>` (e.g. “admin:root@myproxy.com”).

5. Specify the following in the **Wired** and **Wireless** tab of the **Advanced Network Setup window**:
   
a. **Data Types Enabled**: Use these checkboxes to determine the types of data that will be downloaded using the connection.

   b. **Connection Settings**: Indicate whether the IP address is auto-generated (via DHCP) or static. If you’re using a static IP address, enter the parameters in the fields below.
6. Select the **Diagnostics** tab in the **Advanced Network Setup** window if you would like the player to perform network diagnostics when first booting up.
   
a. **Enable network diagnostics**: The player will display the network diagnostics screen during setup.
   
i. **Test Ethernet**: The player will indicate whether or not it was able to attain an IP address over Ethernet.
   
ii. **Test Wireless**: The player will indicate whether or not it was able to attain an IP address over wireless.
   
iii. **Test Internet Connection**: The player will indicate whether or not it was able to attain a connection to remote services.

7. Click **Specify Firmware Update** to indicate whether you want to update the firmware and to which version. The Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign unit, select a firmware version or **Do not update**, and then click **OK**.

8. Under **Unit Configuration**, click **Standalone**, and then specify the following:
   
a. (Optional) **Enable diagnostic web server**: Check this box to enable the **Diagnostic Web Server**. You can include a username and password in the text fields below for added security.
b. (Optional) **Enable local web server**: Check this box to enable the [Local Web Server](#). You can include a username and password in the text fields below for added security.

c. (Optional) **USB Content Update Password**: Enter a password in the field to enable password protection for [USB content updates](#). This feature helps to ensure that a player will not be assigned incorrect schedules or data when updated via USB.

9. Under **Logging**, check any of the following boxes to enable/disable logs and specify upload settings:

   a. **Enable playback logging**: Creates a log that records start and end times, zone names, media types, and file names.

   b. **Enable event logging**: Creates a log that records timestamps, state names, zone names, event types, and event data.

   c. **Enable state logging**: Creates a log that records current and last state names, timestamps, and media types.

   d. **Enable diagnostic logging**: Creates a log that records timestamps, firmware and script versions, and the current presentation.

10. Use the **RF Channel Scan Data (optional)** field if you need to publish the same [RF channel scan](#) settings to multiple XD1230 players. See [Publishing Channel Scan Results](#) for more details.

11. Use the **Screen Color** option to specify what screen color the player should display after it has successfully completed the setup process. When the player displays this color, it is ready to receive content.

12. Create and install the setup files:

   a. Click **Create Setup Files**.
   
   b. Browse to and select an SD card (recommended) or USB flash drive to store the setup files.

   **Note:** We recommend formatting your SD, SDHC, or SDXC card using FAT32. Formatting your card using NTFS allows you to play media files that are 4GB or larger in size, but the player will not be able to receive network updates or generate logs.

   c. Turn off the BrightSign unit by unplugging the power adapter (or Ethernet cable if the player is being powered by PoE).

   d. Insert the card or flash drive into the unit.

   e. Turn on the BrightSign unit by reconnecting the power.
**Important:** *Do not remove the SD card or flash drive from the player.*
CHAPTER 3 – CREATING PRESENTATIONS

Creating a Full-Screen Presentation

In a full-screen presentation, your images and/or videos occupy the entire screen.

1. Create a new presentation project by navigating to File > New Presentation.

   **Tip:** If you don’t see New Presentation under File, make sure you have the Edit, Publish, or Manage tab selected in the upper-left portion of the screen.

2. Specify the following in the New Project window.

   a. **Save as:** Enter a name for the presentation.

   b. **Where:** Select the folder where you want to store the presentation. Click Browse to navigate to the desired folder.

   c. **BrightSign model:** Select the model number of the BrightSign player(s) to which you will publish this presentation.

   d. **Connector type:** Select either HDMI, VGA, or Component.

   e. **Screen resolution:** Choose the resolution that best matches the native resolution of your monitor. You can view all available screen resolutions on the Support Section of the BrightSign website.

   **Note:** If you select HDMI or Component in the Screen resolution menu, you will see several options that are only compatible with component or composite (rather than VGA or HDMI) signals. See this FAQ for more information on generating component/composite signals.
f. **Monitor Orientation**: Choose whether you would like the content to appear in Landscape or Portrait mode. BrightSign players do not automatically rotate landscape content to display in Portrait mode (and vice versa). You will first need to rotate video or images in the source application (e.g. Paint Shop Pro, Photoshop, Adobe After Effects) before publishing them to the player.

g. **Monitor overscan**: Select a setting to determine how the image fills the display screen.
   i. **No overscan – use full screen**: Displays images/video to the edge of the video signal
   ii. **Overscan – action safe**: Restricts the display area to a size that is compatible with most displays
   iii. **Overscan – title safe**: Restricts the display area to a size that is much smaller than the image generated by the video signal.

   **Tip**: Experiment to find the overscan setting that works best with your display.

3. Click **Create** when you are finished configuring the presentation. The **Template** window will open.

4. Click the **Full screen** template, and then click **Choose**.

5. Add media to your Library:
   a. In the left portion of the screen, under the File tab, click **Browse**.
   b. Navigate to the folder where your content is stored.
   c. Click **OK**.

   **Note**: If you have many large files in your content folder, it may take a while for the thumbnail images to appear.

6. Select the **Files** tab selected under **Media Library** and add media files to your presentation by dragging files from the Media Library folders to the playlist area. You can also drag and drop media files directly from a Windows Explorer window.
   a. To select a series of adjacent media files, press Shift+Click as you select the files.
   b. To select a group of non-adjacent files, press Ctrl+Click as you select the files.
   c. To set the order in which the files play, drag them to the Playlist area in the proper order. You can change the order of files already in the playlist by clicking a file and dragging it to a new position.
   d. To refresh the **Media Library** folders, click the refresh icon (next to the **Browse** button).
   e. To remove an item from a playlist, click it in the playlist area and press **Delete** on your keyboard.
   f. To change media files in the playlist without individually deleting and dragging, click **File > Replace media files**. In the Replace Media Files window, click **Browse** to select the folder that contains the files you want to
add. This can be the same folder used in your Media Library or a new folder. A list of all files currently added to the playlist is displayed below Presentation Media Files. For each file you want to replace, select a new file using the dropdown lists beneath Replacement Media File.

g. To create interactive events, see Chapter 4 – Making a Presentation Interactive.

7. (Optional) Rename the playlist:
   a. Click Edit in the upper-right corner of the playlist area.
   b. Enter a new name for the playlist.
   c. Click OK.

8. (Optional) Set playback options:
   a. To edit settings for a single item, right-click the thumbnail in the playlist area, select Edit, and then choose the settings you want to apply to the selected item.
      i. **Image files**: Specify the Time on Screen, the Transition effect to the image from the previous media item, and the Transition Duration.
      ii. **Video files**: Specify the Volume of the video.
      iii. **Audio files**: Specify the Volume of the audio track.
   b. To edit settings for multiple items, press Ctrl+Click to select the items in the playlist area. On the menu bar, click Edit > Selected Items, and then choose the settings you want to apply to the selected items.

9. On the menu bar, click File > Save… to store your presentation.

**Note**: Make sure you have the Edit tab selected in the upper-left portion of the screen. To save the presentation with a different name or in a different folder, select File > Save… As. To export the presentation and associated content, select File > Export….

**Creating a Multi-Zone Presentation**

In a multi-zone presentation, BrightAuthor divides the screen into rectangles called zones. You can play different content in each zone, and each zone supports a specific type of content. BrightAuthor provides a handful of multi-zone templates.
You can choose one of the existing templates, or create your own (see Chapter 10 – Customizing Presentations for more details).

When using a multi-zone template, you need to know which type of content you can include in each zone. The color-coded key at the bottom of the template screen shows the available content types, and the color-coded templates indicate which type of content you can include in each zone of the templates. The following list describes the available content types:

- **Images**: Displays images. You can include multiple Images zones in a presentation.
- **Ticker**: Displays RSS feeds or pre-defined text strings. You can include multiple Ticker zones in a presentation.
- **Clock**: Displays the time or date. You can include multiple Clock zones in a presentation.
- **Video or Images**: Displays images, video, and audio.
- **Video Only**: Displays videos and audio.
- **Audio Only**: Plays audio. You can include multiple Audio Only zones in a presentation.
- **Enhanced Audio**: Plays audio in a cross-faded playlist. You can include one Enhanced Audio zone in a presentation.
- **Background Image**: Places an image in the background of your presentation. All other zones appear on top of the background image.

**Note:** BrightSign 4K and XD models can decode two videos at once. Therefore, if you are creating a presentation for one of these models, you can include two “Video or Images” zones, a “Video or Images zone” and a “Video Only zone”, or two “Video Only” zones. If you are using an HD player, you can include only one video zone per presentation. Therefore, you must choose between a “Video or Images” zone, a “Video Only” zone, or a “Background Image” zone.

1. Create a new presentation project:
   a. Navigate to **File > New Presentation**.
   **Tip:** If you don’t see New Presentation under File, make sure you have the Edit, Publish, or Manage tab selected in the upper-left portion of the screen.
b. In the **New Project** window, enter a name for the presentation in the **Save as** field.
c. In the **Where** field, enter the folder where you want to store the presentation. Click **Browse** to navigate to the desired folder.
d. Select your **BrightSign model**, **Connector type**, **Screen resolution**, and **Monitor orientation**.
e. Select a **Monitor overscan** setting to control how the image fills the display screen.
   - **No overscan**: Displays images/video to the edge of the video signal.
   - **Overscan – action safe**: Restricts the image display to an area that is compatible with most displays.
   - **Overscan – title safe**: Restricts the image display to an area that is much smaller than the image generated by the video signal.
   
   **Tip**: *Experiment to find the overscan setting that works best with your display.*
g. Click **Create**.

2. Click the multi-zone template you want to use, and then click **Choose**.

3. Add media to your Library:
   a. In the left portion of the screen, under the **File** tab, click **Browse**.
   b. Navigate to the folder where your content is stored.
   c. Click **OK**.

   **Note**: *If you have a lot of large files in your content folder, it may take a while for the thumbnail images to appear.*

4. Add content to the zone playlist:
   a. Click the zone you want to populate.

   **Note**: *Each zone has its own playlist.*
   
   b. Select the Files tab selected under Media Library and add media files to your presentation by dragging files from the Media Library folders to the playlist area. You can also drag and drop media files directly from a Windows Explorer window. To select a series of adjacent media files, press **Shift+Click** as you select the files.

   i. To select a group of non-adjacent files, press **Ctrl+Click** as you select the files.
ii. To set the order in which the files play, drag them to the Playlist area in the proper order. You can change the order of files already in the playlist by clicking a file and dragging it to a new position.

iii. To refresh the Media Library folders, click the refresh icon (next to the Browse button).

iv. To remove an item from a playlist, click it in the playlist area and press Delete on your keyboard.

v. To change media files in the playlist without individually deleting and dragging, click File > Replace
media files. In the Replace Media Files window, click Browse to select the folder that contains the files you want to add. This can be the same folder used in your Media Library or a new folder. A list of all files currently added to the playlist is displayed below Presentation Media Files. For each file you want to replace, select a new file using the dropdown lists beneath Replacement Media File.

**Note:** Optionally, you can check the Preserve State Names box to preserve the names already given to media states in an Interactive Playlist rather than having media states automatically take on the names of the new media files.

5. To create interactive events, see Chapter 4 – Making a Presentation Interactive.

6. Repeat step 4 for each zone in the presentation.

7. Click the Layout tab to add new zones or adjust the position of your zones. To add a new zone, click the Add Zone button. In the New Zone window, type a name for the zone in the Zone name text field, and select a zone type. Click OK. To adjust the position and size of zones, drag and resize in the preview in the right portion of the screen. See Customizing Zone Layouts for further details.

8. (Optional) Rename the playlist:
   a. Click Edit in the upper-right corner of the playlist area.
   b. Enter a new name for the playlist.
   c. Click OK.

9. (Optional) Set playback options:
   a. To edit settings for a single item, right-click the thumbnail in the playlist area, select Edit, and then choose the settings you want to apply to the selected item.
   b. To edit settings for multiple items, press Ctrl+Click to select the items in the playlist area. On the menu bar, click Edit >Selected Items, and then choose the settings you want to apply to the selected items.

10. (Optional) Set zone properties. See Setting Zone Properties for details.

11. On the menu bar, click File > Save… to store your presentation.

**Note:** Make sure you have the Edit tab selected in the upper-left portion of the screen. To save the presentation with a different name or in a different folder, select File > Save… As. To export the presentation and associated content, select File > Export….
Customizing Zone Layouts

If the predefined zone template layouts do not meet your needs, you can create your own zone layout. You can then save it as a custom template that you can use when creating presentations in the future. Complete the following steps to customize zone layouts:

1. Once you have created a presentation project via File > New Presentation, click Layout (below the Edit tab) and customize the layout by doing any of the following:
   a. Change the position of a zone: Click the zone and drag it to the desired position. Alternatively, you can enter the Position information in the left side of the screen. X corresponds to the position on a horizontal axis, and Y corresponds to the position on a vertical axis.
   b. Add a zone: Click Add zone, type a Zone name, select the Zone type, and then click OK.
   c. Make zones equal in size: Press Ctrl+Click to select the zones you want to resize. On the menu bar, click Format > Make same size and select a resize option.
   d. Align multiple zones: Press Ctrl+Click to select the zones you want to align. On the menu bar, click Format > Align and then select an alignment option.
   e. Center two or more zones: Press Ctrl+Click to select the zones you want to center. On the menu bar, click Format > Center in form and then select Horizontally or Vertically.

Tip: You can layer zones on top of each other. For example, you can place a Ticker or Clock zone on top of a Video Only zone, and then edit the transparency in the Ticker or Clock zone to control how much of the underlying video is visible.

f. Edit the z-order of video zones: (4K and XD models only): Use the Video Position Z option to edit the z-position of two Video Only and/or Video or Images zones. This allows you to overlay one video zone on top of another. This setting only affects a Video or Images zone when it is displaying a video.

g. Edit the z-order of the a graphics zone: Use the Graphics plane z position option to edit the z-position of an Images, Video or Images, Ticker, or Clock zone. This allows you to place the zone in front of the video zone(s), behind the video zone(s), or between two video zones. This setting only affects a Video or Images zone when it is displaying an image. Note that the z-order of graphics zones in relation to each other can still
be unpredictable; if you want to place a graphical element on top of an image, we recommend using a Background Image zone instead.

h. Remove an unwanted zone: Click the zone in the preview image and press the **Delete** key on your keyboard.

i. Rename a zone: Click the zone in the preview image, then type in the **Name** text field on the left side of the screen.
Note: The preview image is always displayed as a landscape. If your display is a portrait and you have selected this monitor orientation when creating the project, refer to the portrait image in the left side of the screen to see how your zones will appear to a viewer.

2. To save the layout as a template, click **Save Template** (in the lower-left portion of the screen). Enter a name for the template, and then click **OK**.

3. To use a custom template in a new presentation, click the **View** dropdown list in the upper-right corner of the **Template** window. Select **User Defined Templates** to view your templates. Click a template and then click **Choose** to use it in the presentation.

---

### Creating Dynamic Playlists and Live Data Feeds

**Note:** A [BrightSign Network subscription](https://www.brightsign.com/network) is required to create and publish Dynamic Playlists and Live Data Feeds.

The **Create** tab allows you to generate playlists and feeds that are hosted remotely. You can edit these playlists/feeds in BrightAuthor or the BrightSign Network WebUI, and the changes will be automatically distributed to all players that use them on the BrightSign Network.

#### Dynamic Playlists

A Dynamic Playlist enables you to easily update and share content in multiple presentations. For example, if you need to add daily announcements to your presentations and you don’t want to update each presentation separately, you can add a single Dynamic Playlist to all of your presentations. When you edit the Dynamic Playlist and upload it to the BrightSign Network, every presentation that includes the Dynamic Playlist receives the new content. In this way, a single update can reach multiple presentations.

Follow these steps to create and upload a Dynamic Playlist:

1. Click the **Create** tab and select **Dynamic Playlist**.
2. On the menu bar, click **File > New Dynamic Playlist**. You can also open a previously created Dynamic Playlist by clicking **File > Open Dynamic Playlist**. You can then make edits to the playlist.
3. If you’re creating a new Dynamic Playlist, choose either **Image or Video** or **Audio Only** option. Audio content cannot be mixed with image/video content (and vice versa). Dynamic Playlists containing audio can be added to Audio Only, Enhanced Audio, Video or Image, and Video Only zones, while Dynamic Playlists containing image/video content can be added to Images, Video or Images, or Video Only zones.

4. Add files to your Media Library by clicking the **Browse** button and selecting a folder that contains the files you want to include in your Dynamic Playlist.

5. Drag the desired media files to the playlist area.

6. Click the **Upload to Network** button in the upper-right portion of the screen.

7. You will be prompted to save the playlist. Click **Yes**. The **Save As** window will open. Type a name for your playlist and click **Save**. The **Save Complete** window will open. Click **OK**. The playlist will now upload onto the BrightSign Network.

Now all presentations that contain the Dynamic Playlist will automatically receive the new content. You can change the content of the Dynamic playlist at any point by opening the playlist (**File** > **Open Dynamic Playlist**) and dragging new media files into the playlist area.

Follow these steps to add a Dynamic Playlist to a presentation:

1. While in the **Edit** tab, navigate to **File > Presentation Properties > Data Feeds**.

2. Click **Add Data Feed**.

3. Enter a **Feed name**. This does not need to be the same name given to the Dynamic Playlist.

4. Under **Feed specification**, select **Dynamic Playlist** and choose the playlist from the dropdown menu.

5. Use the **Update Interval** dropdown menu to determine how often the player should check in with the BrightSign Network servers to update the Dynamic Playlist.

6. Click **OK**. The Dynamic Playlist can now be added to your presentation via **Live Text** and **Media RSS Feed** states.

**Live Data Feeds**

Similar to an RSS feed, a Live Data Feed consists of an indexed list of Titles and Values. Each Title is associated with a single Value. Live Data Feeds can have numerous applications in a presentation. They can be used as updatable text.
feeds in Ticker zones or as individual text widgets in a Live Text state. They can even be used to remotely update the values of User Variables.

Follow these steps to create and upload a Live Data Feed.

1. Click the Create tab and select Live Data Feed.
2. On the menu bar, navigate to File > New Data Feed. You can also open a previously created Data Feed by navigating to File > Open Data Feed. You can then make edits to the feed.
3. Click the + Add Item button to create a new feed entry.
4. Enter a Title for the feed entry. The title, as well as the index number, allows you to pick a specific entry to display when using RSS feeds in Live Text.
5. Enter a Value for the feed entry. This is the portion of the feed that will be displayed on screen.
6. Use the up and down arrows to reorder the list of entries. You can also use the X button to delete an entry.
7. When you are finished adding entries, click the Upload to network button in the upper-right portion of the screen (you must be connected to the BrightSign Network). You will be prompted to save the feed as an XML file before uploading it to the network. The name you give to this XML file will be the name associated with this feed on the BrightSign Network.
8. (Optional) You can save a copy of the feed any time by navigating to File > Save New Feed or File > Save New Feed As. You can later retrieve the feed by navigating to File > Open Live Data Feed.

Follow these steps to use a Live Data Feed in a presentation:

1. While in the Edit tab, navigate to File > Presentation Properties > Data Feeds.
2. Click Add Data Feed.
3. Enter a Feed name. This does not need to be the same name given to the Live Data Feed.
4. Under Feed Specification, select Live Data Feed and choose the feed from the dropdown menu.
5. Use the Update Interval dropdown menu to determine how often the player should check in with the BrightSign Network servers to update the Live Data Feed.
6. Click OK. The Live Data Feed can now be added to your presentation via Live Text and RSS Feed states.
RSS Feeds and Text Feeds

Ticker zones can be used to display dynamic text (RSS feeds) or static text feeds. To display text over an image or video, you must use a Live Text state.

RSS Feeds
RSS feeds are updated each time the BrightSign player connects to the server. An RSS Feed state can display either Live Text Data or a third-party RSS feed.

1. Select a Ticker zone in your presentation.
2. Click the RSS tab and drag the New RSS Feed icon onto the playlist.
   a. Select a Data Feed from the dropdown list.
   b. If you have not added a Data Feed to the presentation yet, click Add Data Feed.
   c. Click OK.

   Note: BrightAuthor does not prevent you from inputting an MRSS Data Feed into an RSS state (or vice versa). However, the presentation will fail to display any content if it is published in this state.

Text Feeds
Text Feeds are static text files located on the local storage of the player.

1. Create a .txt file (using Notepad or a similar program) that contains the text you wish to display.
   a. Insert a line break between each text item in the .txt file.
   b. Save the text file and place it in your Media Library folder.
2. Select a Ticker zone in your presentation.
3. Click the Text tab in the Media Library.
4. Drag the text file into the playlist.

Twitter
You can use your Twitter account to create a data feed from a remote source. Twitter feeds can only be created in a Ticker zone.

1. Select a Ticker zone in your presentation.
2. Click the **RSS** tab and drag the 🚀 *Twitter* icon onto the playlist.
3. Enter your **Twitter User Name** and click **Authenticate**. Another window will open asking if you would like to authorize BrightSign to use your Twitter account.
4. Enter your Twitter account login information and click **Authorize app**.
5. Specify an **Update Interval** for the Twitter feed.
6. Determine whether or not you want to limit the feed to the **most recent number of tweets**. Specify in the field how many recent tweets can be displayed.
7. Click **OK** when finished.

**Media RSS Feeds**
You can use Media RSS Feed states to display the content in **Dynamic Playlists** or MRSS feeds. A MRSS feed can be hosted on a third-party server or the **BrightSign Network** (using the Live Media feature).

1. Click the **Other** tab below **Media Library**.
2. Drag the 📺 **Media RSS Feed** icon to the playlist area.
   a. Select a **Data Feed** from the dropdown list. If you are using the Media RSS Feed in an Audio Only or Enhanced Audio zone, ensure that the MRSS feed or Dynamic Playlist will contain audio files only.
   b. If you have not added a Data Feed to the presentation yet, click **Add Data Feed**.
   c. Click **OK**.

   **Note**: *BrightAuthor does not prevent you from inputting an RSS Data Feed into an MRSS state (or vice versa). However, the presentation will fail to display any content if it is published in this state.*

**HTML5**
You can use the BrightSign 4Kx42, XDx32, XDx32, and HDx22 models to display HTML web pages, including video, image, text, and JavaScript elements. For a full explanation of how to create and publish HTML content for BrightSign players, please see the **HTML5 Best Practices** guide.

**Note**: *HTML video content will play even if it is embedded in an Images zone.*

- **State name**: Specify a name for the HTML state.
• **HTML5 Site**: Select an HTML site from the dropdown menu. To populate this list with sites, navigate to **File > Presentation Properties > HTML Sites**.

• **Enable external data**: Check this box if your HTML page uses assets from multiple locations.

• **Enable mouse and touch events**: Check this box if you want to enable interaction with the HTML5 page (clicking on links, interacting with JavaScript elements, etc.).

**Note**: *BrightSign models are not designed to be used as general-purpose web browsers. Many web pages have elements that will not display correctly on a BrightSign player. Make sure to thoroughly test a web page before using it as digital signage.*

• **Display cursor**: Displays the cursor if you have connected a USB mouse with your player.

• **Custom fonts**: By default, text in an HTML page will displayed using the standard font provided by WebKit. Click **Add Font** to add custom TrueType Font (.ttf) files to the HTML page. When the presentation is published, the font file(s) will act as though they are located in the same file directory as the *index.html* file (i.e. they can be accessed with the standard *font-family* attribute in HTML/CSS).

• **Enable native video plane playback**: Enables HWZ mode on all `<video>` elements contained within the page. This increases the frame rate and quality of HTML video playback, but can also cause problems with CSS page
transforms and other page elements. By default, it will place the video on top of all other video and graphics in the presentation. For a complete explanation of HWZ mode, refer to the HTML5 Best Practices guide.

- **Specify user stylesheet**: Specifies a user stylesheet for the HTML page associated with the state. Use the **Browse** button to select the .css file you wish to utilize as the user stylesheet. Every HTML5 state can have a different user stylesheet, even if the states are being used to display the same HTML5 page.

**Live Video**
The 4K1142, XD1132, and XD1230 models support Live Video through the HDMI Input port.

**Note**: We do not recommend displaying a Live Video state at the same time as an RF In state (in two different video zones, for example).

To add a Live Video state, select a Video or Images or Video Only zone. Under the **Other** tab, drag the Live Video icon to the playlist area. To edit the video volume and time on screen, double-click the thumbnail in the playlist area.

**SignChannel**
To add a SignChannel state, select a Video or Images or Video Only zone. Under the **Other** tab, drag the SignChannel icon to the playlist area.

**Note**: SignChannel content can only be in one zone of your presentation.

**Local Playlists**
A Local Playlist allows you to customize which Dynamic Playlist is used in a presentation depending on the player. For example, if you are using BrightSign players at a dozen different locations, and the presentations are the same except for variations in the content of the Dynamic Playlists, you only need to create, edit, and update one presentation that uses a Local Playlist rather than a dozen that use different Dynamic Playlists.

1. Click the **Other** tab in the Media Library.
2. Drag and drop a Local Playlist where you would normally add a Dynamic Playlist.
3. Enter a unique State name.
4. Select a desired **Default playlist**. If no Dynamic Playlist is assigned to a player in a Local Playlist, then the player will automatically use the **Default playlist** instead.

**Note:** *If a player is not assigned a Dynamic Playlist and no default is set for the Local Playlist, then the player will skip to the next item in the presentation.*

5. Select the desired **Playlist** for each player connected to your BrightSign Network Account.

6. Click the **OK** button to save changes.

### Video and Mjpeg Streams

All networked players can play Video and Mjpeg streams. See [this FAQ](#) to learn more about supported video streaming formats and codecs.

**Note:** *Unlike other video types, there is no limit on the amount of Mjpeg streams you can display on screen. However, adding more than a certain number of windows (depending on the player model and stream quality) will begin to reduce the framerate of the videos.*

- **State Name**: Specify the unique name for the stream state.
- **URL for video stream**: Enter a valid URL for the stream. Alternatively, a **User Variable** can be used specify the entire URL or replace part of the URL. To include the Value of the variable in the URL, enter the Name between two sets of dollar signs (e.g. "http://www.example.com/streams/$$my_URLvariable$$").
- **Rotation (Mjpeg only)**: Specify the clockwise rotation of the streaming video.
- **Time on screen**: Specify the duration (in seconds) that the stream will be played. This option is only available in non-interactive presentations. To customize the duration of a stream in an interactive presentation, use a **Timeout** or **Media End** event.

### Audio Stream

All networked players players can stream audio from a remote source. To add a stream, specify a **State name** and a **URL for stream**. If you are adding a stream to a non-interactive playlist, specify a **Time to play** (in seconds). For more information on supported formats, codecs, and bitrates, please see the [Audio Streaming Support FAQ](#).
RF In (ATSC)

Note: The RF In state was changed significantly in BrightAuthor version 3.7.0.12. If you have an RF In project from an earlier version of BrightAuthor, you will need to recreate the presentation with a new version of BrightAuthor.

Note: We do not recommend displaying an RF In state at the same time as a Live Video state (in two different video zones, for example).

This state displays live video that is passed to the BrightSign player through the RF Input. This feature is available only on the XD1230. Before you can display video from the RF Input, you must first perform a channel scan on the player while it is connected to the cable source: You can do this prior to publishing the presentation (via the RF Channel Scan interface) or during the presentation (via the Tuner Scan state).

Note: A Media End event will trigger on an RF In state only if the video bit rate of the tuner input drops to 0Mbs.

1. (Optional) If you’ve already performed a channel scan on the player, you can use the “ScanResults.xml” file generated by the scan on the SD card to enable the Channel name and Select different virtual channel options:
   a. Click the Browse button next to Specify RF channel scan file.
   b. Locate the SD card or USB flash drive you used to perform a channel scan on the player.
   c. Open the “ScanResults.xml” located in the directory.

2. In the Select channel section, determine which channel will be played upon entering the RF In state.
   a. First scanned channel: Displays the first channel detected during the channel scan (i.e. the smallest detectable channel number).
   b. Channel name: Displays the channel with the specified name. To use this option, you must first specify a
“ScanResults.xml” file in the **Specify RF channel scan file** field.

c. **Virtual channel**: Displays the channel based on its virtual number:
   
i. **Current virtual channel**: Manually enter the virtual number of the channel. You should only use this number if you are familiar with the channel map of the cable source.
   
   ii. **Select different virtual channel**: Select the virtual number of the channel based on the results of the channel scan. To use this option, you must first specify a “ScanResults.xml” file in the **Specify RF channel scan file** field.

d. **User variable**: Displays the channel based on the value of a User Variable. The system software can recognize both channel name and virtual channel number as the value of a User Variable. Before you can enable this option, you must first designate one or more User Variables.

3. In the **On entry to this state** section, choose the behavior of the RF In state:

   a. **Remain on last tuned channel**: Choose this option if you would like the player to remain on the same channel that was displayed the last time the player was in the RF In state. The state will use your **Select channel** settings if it is the first time the presentation is entering the RF In state.

   b. **Retune as specified above**: Choose this option if you would like the player to retune using your **Select channel** settings every time the presentation enters the RF In state.

4. Specify **channel up** and **channel down** event triggers if you would like viewers to be able to flip through channels like a traditional cable box.

5. Check the **Overscan** box if you would like to apply overscan settings to the RF video input.

### Tuner Scan

You can use this state to perform a channel scan of the cable source while an interactive presentation is running. Use a Media End event to exit this state once the channel scan concludes. If you use another interactive event (e.g. Serial Input, UDP Input) to exit the Tuner Scan state before it concludes, the scan will be canceled and the results will not be written to the player.
• **Channel Map**: Select QAM, ATSC, or ATSC and QAM (consult your service provider for details).
• **Modulation Type**: Select QAM 64, QAM 256, or QAM 64 and QAM 256 (consult your service provider for details).
• **First RF Channel** (optional): You can choose to limit the range of the channel scan by selecting the first channel to scan.
• **Last RF Channel** (optional): You can choose to limit the range of the channel scan by selecting the last channel to scan.

**Note**: Each channel takes approximately one second to scan. Specifying upper and lower limits will reduce the amount of time it takes to perform the scan. You should only use these two options if you are familiar with the channel map of the cable source.
You can use BrightAuthor to create interactive presentations. Interactive presentations respond to interactive events, such as input from buttons or other GPIO devices, or from devices connected to a BrightSign communication port. The supported communication methods vary by BrightSign model:

- **USB devices (such as touch screens, mice, keyboards, barcode scanners, IR remote controls):** 4K1042, 4K1142, XD1032, XD1132, XD1030, XD1230, HD1022, HD1020, LS322, LS422
- **Networked devices:** All 4K and XD models, as well as the HD222, HD1022, HD220, HD1020, LS322, LS422, and AU320
- **RS232 serial devices:** 4K1042, 4K1142, XD1032, XD1132, XD1030, XD1230, HD1022, HD1020, and AU320
- **GPIO devices:** All current models
- **Infrared (IR) devices:** All 4K and XD models

To make your presentation interactive, complete the following steps:

1. Open a presentation project. If you haven’t already created a presentation, see [Creating Presentations](#) for details.
2. Add files to your Media Library by clicking the **Browse** button and selecting a folder that contains the files you want to include in your presentation.
3. Click a zone you want to make interactive. **Note:** *Multi-zone presentations can include both non-interactive and interactive zones.*
4. Make the zone interactive. In the upper-right portion of the screen beside **Playlist type**, click **Interactive**.
5. Drag the desired content into the playlist area.
6. Choose a Home Screen. The Home Screen is the first media file in the playlist. It is where the interactive presentation begins (within a particular zone). Home Screens usually include one of the following:
   a. An attract video that loops until the user provides input
   b. A list of options from which the user can choose the next action (e.g. an **Interactive Menu**).
By default, the first item you drag into an interactive playlist will become the Home Screen. It is identified by the **Home** icon. You can change the Home Screen at any time by double-clicking the desired file in the playlist and checking the **Set as initial state** box.

7. Define Interactive events. Interactive events link files in the playlist and determine what must occur before a file
transitions to another file. In the user interface, files are referred to as “states,” where the current file is the “current state,” and the file transitioned to is the “next state.” In this guide, creating and linking interactive events between states will be referred to as “defining events”:

a. In the **Event Toolbar**, click the interactive event icon that corresponds to the type of event you want to define. For example, to define what happens when a user presses button 1 on a button board, click .

![Diagram showing defined events between files](image.png)
b. Click (and hold) the file name below the thumbnail image of the current state. This media file is what the user sees before performing the interactive event you are about to define.

**Note:** The first interactive event must begin with the Home Screen.

c. Drag the hand pointer to the thumbnail image of the media file you want to play next (the next state).

d. Repeat steps a – c to define the remaining interactive events.

Subsequent interactive events can start with any item and correspond to any other item in the playlist. For example, you can set the first interaction to display an image when the user presses button 1 from the Home screen. By defining a new event with the same event icon, you can set a second interaction to display another media file when the user presses button 1 again.

**Note:** Make sure your defined events work in a loop. In the above screenshot, a user can transition from the Home Screen to the other images by pressing button 1 or button 2. After a set period of time (indicated by the timeout events), the presentation will return to the Home Screen.

You can utilize multiple interactive events to transition from state to state. You can also apply events to multiple items. Right-click and drag the cursor within the playlist area to create a selection box. Define the interactive event from one media file, and it will then be created for all selected files. To select non-consecutive files, press and hold **Ctrl** while clicking items.

**Customizing the Interactive Playlist**

In the upper-right portion of the screen, you can use the **Zoom** control to adjust your view of the playlist area. When you switch between multiple interactive zones, BrightAuthor will remember the zoom setting last used for each zone.
If you don’t see the event you want in the playlist toolbar, click the arrow to the left of the Zoom control. Here, you can add or remove event icon buttons from your toolbar. You can also access Event icons by clicking the Events tab under Media Library.

**Editing Interactive Events**

When creating an event with an icon from the Events tab, drag the Event icon onto the thumbnail of the media file you want to be the current state. An Event window will automatically open. Here, you can specify which media file you want to be the next state.

You can further adjust how your media files transition from state to state by double-clicking the Event icons (or right-clicking and then clicking Edit). For example, if you create an event with the Timeout Event icon, the media file displayed in your presentation will transition to the next state after a certain period of time. You can adjust this time period by double-clicking the Timeout Event icon between the two media files and changing the duration in the Timeout Event window.

**Note:** To find descriptions of all interactive events, please see Chapter 5.

The Event window that opens when double-clicking a created Event icon is the same window that automatically opens when you drag an event icon from the Events tab. The window always presents options specific to the type of interactive event chosen. However, every Event window displays the following options:

- **Transition to new state**: Use the dropdown list to specify which file in the playlist will be the next state.
- **Return to prior state**: If you select this option, the presentation will revert to the previous media file when the interactive event is performed.
- ** Remain on current state**: If you select this option, the state will not change when the interactive event is performed. This option is useful for creating changes within one media file. You can create these changes by adding commands. See Adding Commands for details on commands.
Editing Media Properties

You can edit individual files in the playlist by right-clicking the file icon and selecting **Edit**. The **Media Properties** window will open.

- **State name**: The current state name as it appears in the interactive playlist. You can edit the name in this field.
- **Current file**: The filename of the current file associated with the state. This field cannot be edited.
- **Select different file**: Use the dropdown menu to select a different media file to associate with the state. This is useful for preserving events and commands that were defined for the original file. The change will *not* go into effect until the **Update** button is pressed (even if you click **OK**). If you need to replace all instances of a particular media file within your presentation, navigate to **File > Replace Media Files** (see [Creating Presentations](#) for more details).
- **Transition** *(Image states only)*: Use the dropdown list to select a special transition effect that will occur when the image appears on the display.
- **Transition duration** *(Image states only)*: Specify how long the transition effect will take to complete. This duration should be less than the amount of time the image is displayed on screen.
- **Loop media**: *(Video states only)* Choose this option if you want the video to loop indefinitely when no Media End event is attached to the state.
• **Hold last video frame**: (Video states only) Choose this option if you want the last frame of the video to be displayed indefinitely if no Media End event is attached to the state.

Click the **Advanced** tab to store the image in a cache, set display mode for video files (2D, 3D side-by-side, 3D top-over-bottom), or add commands.

**Note**: You can delete a defined event (or file) at any time by clicking the icon/thumb and pressing **Delete** on your keyboard.

### Copying, Exporting, and Importing States

All states can be copied, exported, and imported. Copying or exporting a state (or set of states) will also copy all commands and notes attached to that state. This process will only preserve events that transition among the set of copied/exported states.

- **Copying**: With a state selected, right-click the state and select **Copy**, navigate to **Edit > Copy**, or press Ctrl+C. You can also copy multiple states at a time by holding down Ctrl while selecting the desired states.
- **Pasting**: Right-click a playlist or Super State canvas and select **Paste**, navigate to **Edit > Paste**, or press Ctrl+V. Note that a pasted state will appear on the same canvas position as the original state; if the original state has not moved, it may be difficult to tell that the paste action occurred.
- **Exporting**: With a state selected, right-click the state and select **Export** or navigate to **Edit > Export**. You can also place multiple states into a single export file by holding down Ctrl while selecting the desired states. The exported state(s) will be saved as a single file with a `.bse` extension in the specified directory.
- **Importing**: Right-click a playlist or Super State canvas and select **Paste**, or navigate to **Edit > Paste**. You will be prompted to select the `.bse` file containing the state(s) you wish to export.

### Video Lists, Image Lists, and Audio Lists

Media Lists are convenient tools for defining interactive events with many files. They allow you to compile your files into one group that appears as a single thumbnail in your playlist area. By default, each time an item transitions to a Media List, the next file in the list will play and exit the list after a timeout (images) or when the file finishes playing (video and
audio). Alternatively, you can set the list to shuffle files or cycle through every file in the list before exiting and transitioning to the next state.

Only files of the same type can be gathered in a Media List. Under the Other tab, there is an icon for each list type (Video List, Image List, Audio List). To create a Media List, drag the appropriate icon into the playlist area of a corresponding zone.

You can edit properties of your Media Lists under File > Presentation Properties > Media List. See Chapter 11 > Presentation Properties for details.

After you set your zone to Interactive and drag one of the Media List icons into the playlist area, the List window will automatically open. Here you can set the following parameters for your List:

- **Media list name**: Create a unique name for the list.
- **Set as initial state**: Check this box to make the list your Home Screen.
- **Advance to next item on media end event**: Check this box to have the Media List cycle to the next file in the list after an image times out or an audio/video file ends. If you leave this box unchecked, the Media List will play one file each time it is transitioned to, remaining on that file until the playlist transitions away from the Media List state. **Note**: An Audio List in an Enhanced Audio zone cycles through all files in the list by default, so the **Advance to next item on media end event** option is not available for Enhanced Audio zones. In an Enhanced Audio zone, a Media End event attached to an Audio List will only trigger once all files in the list have been played. **Note**: If you are creating an Image List, the above parameter will be listed as **Advance to next item on Image Timeout** instead.
- **Image Timeout (seconds)**: This option is only available if you are creating an Image List. You can specify the length of time each image remains on screen. You can also use decimal values to specify the image timeout in milliseconds (for example, 1.500 = 1500msec).
- **Play from beginning on entry to state**: Check this box to have the Media List start from the beginning each time it is transitioned to. This box is only enabled if you have checked the above **Advance to next item on media end**
event (unless you are using an Enhanced Audio zone). If you leave the **Play from beginning on entry to state** box unchecked, subsequent transitions to the list will play the next file in the list.

- **Shuffle playback**: Check this box to randomize the order of media items in the Media List each time the Media List is transitioned to.
- **Event to transition to next item**: Select an interactive event that allows the user to transition to the next file in the list. After selecting the event type, you must specify a trigger.
- **Event to transition to previous item**: Select an interactive event that allows the user to transition to the previous file in the list. After selecting the event type, you must specify a trigger.

![Image List](image.png)

**Note**: *If you leave event transitions on the default, timeouts and media end events will automatically cause transitions.*

- **Populate from media library**: Select this option to populate the Media List using content stored on your computer.
  - **Media Library**: Click **Browse** to select the folder that contains all the files you want to include in the list.
- **Media Files**: Add individual files to the list by clicking the **Add File** button and using the dropdown list. Only files contained in the folder you selected above will be available in the dropdown list. Click **Add All Content From Media Library** to add all compatible media files from the directory specified in the **Media Library** field.

  - **Populate from data feed**: Select this option if you would like to populate the Media List using media files specified in a BSN Data Feed (this feature does not support MRSS feeds). You will first need to add the Data Feed to your presentation by navigating to **File > Presentation Properties > Data Feeds**. You will also need to set the **Data feed content usage** for use with Media Lists. Upon playing the presentation, the player will retrieve the media from the download URLs specified in the **Value** field of each item in the Data Feed (i.e. the RSS `<description>` field).
Video Play Files, Image Play Files, and Audio Play Files
Like Media Lists, Play Files combine files into a list you can view in one window (or as one thumbnail in the playlist area). However, unlike Media Lists, Play Files allow transitions to specific files within the group, rather than the list as a whole.

Play Files can only be transitioned to using input from BP900/BP200, UDP, Serial, Keyboard, or USB. The input data from the controller will determine which media item in the Play File will be displayed: For example, you can use a Keyboard Input event to playback “Video 1” if the “A” key is pressed or “Video 2” if the “B” key is pressed. Any type of event can transition out of a Play File state and into a new state.
Note: For BP200/BP900 events, you must specify each Key using both the panel enumeration and button number: For example, if you have a single BP200/BP900 panel connected to the player and want button 3 to trigger an image, you would specify the Key as "0-3"; on the other hand, if you have a second BP200/BP900 panel connected to the player and want button 3 on the second panel to trigger the image, you would specify the Key as "1-3".

Make sure you use zones that match the Play File type you want to use. After setting your zone to Interactive and dragging a Play File icon to the playlist area, the Play File window will automatically open. Here you can set the parameters for your Play File list.

- **State name**: Create a unique name for the Play File. This name will show up in the thumbnail in the playlist area.
- **Transition** (Image Play Files only): Use the dropdown list to create a special effect when a user transitions to an item in the Play File list.
- **Specify Local Files**: Select this option if you would like to create the Play File using files from your computer. If you choose this option, the Play File table will remain static when it is published to the player; the only way to change it is to republish the presentation. The Specify data feed option (described below) allows for dynamic Play File tables.
- **Display default media if input does not match any keys**: Check this box to display the specified media file when the input data does not match any existing keys in the Play File state. If this box is not checked, nothing will happen when the input data does not match an existing key.
- **Use variable to specify key**: Check this box to have a User Variable specify the media-file key. The input data from the controller will be ignored, though input of some kind must be received to trigger the interactive event. For example, if a Keyboard event is attached to a Play File state with this option is enabled, any key press will initialize a transition to the Play File state; the value of the specified User Variable will then be checked against the keys in the Play File to determine if any playback should occur.

Note: If you attach a command that modifies the User Variable value (e.g. Set Variable, Increment Variable) to an event that transitions to the Play File state, the media-file keys will still be compared against the old variable value. However, if the Display default media option is enabled, the new User Variable value will be used instead.
• **Add File**: Click this button to add media items to the Play File.

• **Files**: This list displays files added to your Play File. Each file has a **Key** and **File Path**.
  - **Key**: The string that will trigger the media item to play if it is matched by the input from the BP900/BP200, UDP Input, Serial Input, Keyboard Input, or USB Input event. Because you define the interactive events with the keys in the Play File, you do not need to specify the events again when creating a transition to the Play File. For example, if you define a USB Input event that links an item to the Play File, the option to **Specify USB Input** will be disabled and replaced with `<any>`. When a user performs an event via USB that matches a key, the corresponding file will play.
  - **Show in BrightSign App**: Check this box if you want to display a UDP command in BrightSign App instances that connect to the player.
  - **Label**: The label of the interactive button as it will appear in the BrightSign App.
  - **File Path**: The location of the file on your computer. Click the **Browse** button to locate the file you wish to use.
  - **Display Mode** (Video Play Files only): By default, files are set to 2D, but if you are using a 3D video, you can select **3D side-by-side** or **3D top-over-bottom** when adding your files.

• **Import Table**: Click this button to import a previously created Play File table (.csv file). Navigate to your saved table and click **Open** to add the files to your Play File list. This table must have the Key, File Path, File Name, and Video Display Mode (if applicable) properly outlined. You can use a table that was exported from another Play File state with the **Export Table** function, or you can create a Play File table using Notepad or Excel.

• **Export Table**: Click this button to create a .csv file that includes information about the current Play File table.
This file can then be imported to other Play File states that have the same media type.

- **Specify data feed**: Select this option if you would like to populate the Play File using media files specified in a Data Feed. You will first need to add the Data Feed to your presentation by navigating to **File > Presentation Properties > Data Feeds**. You will also need to set the **Data feed content usage** for use with Play Files. Upon playing the presentation, the player will retrieve the media from the download URLs specified in the `<description>` field of each item in the RSS feed. The Play File will then use the value in the `<title>` field to determine the key that triggers the media item to play.

**Note**: In order to populate a Media List from a Data Feed, you will need to check the **Download content specified in data feed** box when adding the **Data Feed** to your presentation.

**Live Text**

Live Text is an image that can be overlaid with various text and/or image fields. You can layer both static text and updateable RSS and MRSS content on top of images and customize the position/size of items in relation to the background. You can even use Live Text to overlay content on top of a video in another zone.

**Live Text** – To add a Live Text state to your presentation, drag the Live Text icon from the **Other** tab to the playlist area and set the following parameters:

- **State name**: Enter a unique name for the Live Text state.
- **Set as initial state**: Check this box to make the Live Text state your Home Screen.
- **Background Image**: Click **Browse** to locate and select a background image for your Live Text.

**Note**: **Image Mode** settings that would normally crop displayed images (i.e. “Center Image” and “Scale to Fill and Crop”) are not applied to the background image of a Live Text state. To get consistent performance between images and Live Text states, you will need to resize images accordingly.

- **Update Live Text Data**: Click this button to have all Live Text Data fields display their current value on the BrightSign Network.
- **Size**: Adjust the size of your text fields. **W** corresponds to the width of the text field, and **H** corresponds to the height of the text field.
• **Position**: Adjust the position of your text fields. \( X \) corresponds to the position of the text on a horizontal axis, and \( Y \) corresponds to the position on a vertical axis.  

**Note**: Input numbers in the Size and Position fields for more precise results. Alternatively, you can click and drag the text fields in the preview area to adjust sizing and position.

• **Offset next**: Check this box to automatically set a position for new text items in relation to the most recently created text item. Input the offset distance for the next text item in the \( X \) and \( Y \) fields.

• **Type**: Use the dropdown list to select the source of the content in the selected field:
a. **Fixed Text**: Select this option if you want to display simple, static text. A text field will appear below **Text Type**, where you can type your customized text. As you type, you can view the text in the preview image.

b. **System Variable**: Select this option to display the device serial number, firmware version, script version, or other **System Variable** value. Use the dropdown list to determine which value you would like to display.

c. **Live Text Data**: Select this option if you want to use a **Data Feed** in the text field. Select the desired feed from the **Data Feed Name** dropdown menu. Then, specify which text item to display from the Data Feed using either the **Item title** or the **Item index**. The displayed Data Feed item will remain fixed and will not cycle through feed items like an RSS ticker (use the **RSS Feed** type for this functionality). However, you can update the text by modifying the feed source and changing the description associated with the item title or index.

**Note**: *When you specify the **Item index**, subsequent RSS text fields will automatically contain the next item in the index (i.e. the previous index number + 1).*

d. **Media Counter**: Media Counters display how many times a file in the presentation has played. Each Media Counter field must correspond to a specific file. Use the dropdown list to pair the **Media Counter** field with a file in the presentation. To use this feature, Media Counters must first be enabled: Navigate to **File > Presentation Properties > Variables**, then check the box labeled **Automatically create media counter variables**.

e. **User Variable**: User Variables are customizable values that can be used in commands. User Variable fields in Live Text display the current value of the specified User Variable. Use the dropdown list to specify a User Variable for the text field. To use this feature, you must first **create your User Variable(s)**.

f. **RSS Feed**: Select this option to display an RSS feed. Click the **Update RSS URL List** button to create a list of **Data Feeds** to use as RSS sources. You can also choose whether you would like to display only the **RSS title** or display only the **RSS description**. You can only uncheck the title or description option if you do not have that field currently selected. To edit the amount of time each RSS item is displayed, click **Set Text Parameters** and modify the **Time to Display Each Line** field.

g. **Media RSS Feed**: Select this option to display a Media RSS (MRSS) feed. Click the **Update RSS URL List** button to create a list of **Data Feeds** to use as Media RSS sources. You can also choose among displaying the **media RSS title**, **media RSS description**, and **media RSS image**, as well as any **Custom Fields**.
created for media entries in the MRSS feed. You can only uncheck an option if you do not have that field currently selected.

**Note:** BrightAuthor does not prevent you from inputting an RSS feed URL into an MRSS field (or vice versa); however, the presentation will fail to display any content if it is published in this state.

h. **Image:** Select this option to display another image over the background image. Select **Browse** to locate an image file to use in this item.

- **Validate Live Text Data:** Click this button to verify that the source URL for your feed is valid.
- **Layer:** Use these buttons to determine the layering of your Live Text elements. The background image will always be behind all other elements.

  a. Sends the selected element behind all other elements.
  b. Sends the selected element behind the element that is directly beneath it.
  c. Sends the selected element in front of the element that is directly in front of it.
  d. Sends the selected element to the front of all other elements.

- **Set Text Parameters:** While an individual text field is selected, click this button to edit parameters for that text field. Subsequent text fields will automatically contain the text parameters of the previous text field. You can edit the Number of lines, Rotation, Alignment, Foreground text color, Background text color (this appears behind the text field), Transparency (for background text colors), Font, and, under the **Advanced** tab, the Background Bitmap and Safe Text region. See **Setting Zone Properties** for details on text parameters.
  o The first text item you create will use the default text parameters set in the **Edit Preferences** window (**Edit > Preferences > Live Text**).
  o If you create a text item while another text item is selected, the new text item will inherit the parameters of the selected text item.
If you create a text item without another text item selected, the new text item will inherit the parameters of the last created text item.

**Note:** BrightAuthor 2.5 and earlier versions required a Background Text Color for each text field. Now you can use the checkbox beside Background Text Color to decide whether you want to include a Background Text Color. If you choose to include one, the **Transparency** setting will become enabled and you can edit the transparency of the Background Text Color. If you choose not to include a Background Text Color, characters in the text fields will appear directly over the background image.

- **Add Item:** Click to add a new text field. Select the text field in the preview image and edit the parameters as explained above.
- **Previous/Next:** Click these buttons to quickly switch between text fields.
- **Advanced:** Click to add commands. See [Chapter 4 – Making a Presentation Interactive](#) for details.

As mentioned earlier, Live Text can be layered over both images or videos.
**Live Text Images**

If you want to use a still image behind your Live Text, you should add the Live Text to an Images zone. Complete the following steps for each zone you want to contain Live Text:

1. Select an Images zone. Make the zone **Interactive**. Drag the **Live Text** icon from the **Other** tab.
2. In the **Add Live Text** window, type a State name and then click **Browse** beside **Background Image**. Locate and select your desired background image file.
3. Click **Add Text Item**. Adjust the **Size** and **Position** of your text field by clicking and dragging over the preview image, or inputting exact numbers in the corresponding fields.
4. Select your **Text Type** and input the desired text.
5. Click **Set Text Parameters** and edit text parameters as desired. See [Setting Zone Properties](#) for details on each parameter. Click **OK** when finished.
6. Repeat steps c through f for each text field.
7. Click **OK**.

**Live Text Videos**

Layering Live Text over a video requires two zones because you cannot add Live Text to a Video Only zone. Instead, you can add Live Text to an Image zone, and place it on top of a Video Only zone. To help you position text over the video, you need an image file cut from the video you want to use. Complete the following steps:

1. Under **Layout**, click **Add Zone**. Add a Video Only zone.
2. Click **Add Zone** again and add an Images zone. Resize the Images zone so that it completely covers the Video Only zone.
3. Click **Playlist**, and use the Zone dropdown list to select your Video Only zone. Drag the desired video file from the Media Library to the playlist area. Make the zone **Interactive**.
4. Use the dropdown list to select the Images zone. Make the zone **Interactive**. Drag the **Live Text** icon from the **Other** tab.
5. In the **Add Live Text** window, click **Browse** beside **Background Image**. Locate and select an image file taken from the video file used in the Video Only zone.
6. Click **Add Text Item**. Adjust the **Size** and **Position** of your text field by clicking and dragging over the preview image or inputting exact numbers in the corresponding fields.

7. Select your **Text Type** and input the desired text.

8. Click **Set Text Parameters** and edit text parameters as desired. See [Setting Zone Properties](#) for details on each parameter. Click **OK** when finished.

9. Repeat steps f through h for each text field.

10. When all text fields are in place, click **Clear** beside **Background Image**.

11. Click **OK**.

Clearing the Background Image removes the image from the Image zone. The text fields will appear directly over the video. By temporarily including a Background Image taken from the video, you can better position the text fields in relation to the video playing behind the Image zone.

**Interactive Menus**

Interactive Menus are DVD-style menus that users can navigate with interactive events. By linking separate media to items in the Interactive Menu, you can allow users to interactively transition to a new state of their choice. Because they can serve as a bridge to many items and outline everything available to the user, Interactive Menus make great Home Screens.

To create an Interactive Menu, add a Video or Images zone to your presentation. Set the zone to **Interactive** and drag the Interactive Menu icon from the **Other** tab to the playlist area. The **Add Interactive Menu** window is divided into two tabs, **General** and **Menu Items**.

**General**: In this tab, you will select an image for your Interactive Menu and define how a user navigates it.

- **State name**: Create a unique name for your Interactive Menu.
- **Background Image**: Click **Browse** to select an image you want to act as your menu display.
**Important:** The background image is not simply a background for the actual menu items. It must contain all images and text you want displayed in the menu.

- **Set as initial state:** Check this checkbox to set the Interactive Menu as the Home Screen.

The **Navigation** section is where you define how a user navigates across the menu. Click the dropdown menu for each option (Up, Down, Left, Right, Enter, Back, Next clip, Previous clip) and select the type of event you want to utilize (GPIO
Event, Serial input, etc.). A second dropdown menu or text field will appear. Specify the button or input you want to correspond to the action.

Let's say you want to define how to move **Up** in the menu, and you want to use a keyboard event. In the dropdown list across **Up**, select **Keyboard Input**. A text field will appear below where you can specify a button. Type “U” here. Now, when a user presses “U” on a keyboard, the cursor will move up along the menu items. You don’t need to define every possible action. You can simply leave the dropdown list on the default **None**. However, to create a more intuitive experience between the user and menu, it might be best to define each possible action. The following actions can be defined in the Navigation section:

- **Up, Down, Left, Right**: These are the primary actions a user will perform to navigate from one menu item to the next.
- **Enter**: With this button, a user can select a menu item and transition to a state associated with that menu item.
- **Back**: Once a user presses the defined input for **Enter** on a menu item, a state you have chosen in the **Menu Items** tab will play. However, if you define a **Back** button/input, the user can return to the menu at any point.
- **Next clip**: If a user is viewing a media file associated with a menu item, pressing the defined input for **Next clip** will play the media file that corresponds to the next menu item.
- **Previous clip**: Pressing the defined input for **Previous clip** will stop the media file currently playing, and play the media file associated with the previous menu item.
- **Advanced**: Click this arrow to add commands to your Interactive Menu. See Chapter 4 – Making a Presentation Interactive for details. Here you can also store the background image in a cache. Check the checkbox to save the background image for faster loading in the future.

**Menu Items**: In this tab, you will create the menu items and further specify how a user navigates across the menu.

- **Menu Item Number**: Every menu item has a unique menu item number. The first you create is 1, the second is 2, and so on. Here, you can navigate between the menu items you have created by clicking the **Previous** and **Next** buttons. Everything else in the window corresponds to the menu item you have selected here.

The Menu Items section is where you can create and adjust individual menu items.
• **Add Menu Item**: Press this button to create a Menu item. The Add Menu Item window will open. There are two items, Active Image and Inactive Image. The Active Image serves as a cursor that visually informs the user what Menu item they are on. The Inactive Image is what appears beside the current menu item when the user navigates to a different menu item. Use the Browse buttons to select each image. Click OK to create the menu item. By default, subsequent menu items you create will contain the same Active and Inactive Images.

**Tip**: *If you want nothing to appear beside a Menu item when it is not selected, choose an Inactive image that matches the color of the background.*

• **Position**: Adjust the position of your Menu item by inputting specific numbers. The X field corresponds to the position of the menu item on a horizontal axis. The Y field corresponds to the position of the menu item on a vertical axis. Alternatively, you can click the active image in the preview image and drag it to the desired position. The inactive image will appear in the same spot when the menu item is not selected.

• **Offset next**: Check this checkbox to specify a position for subsequent menu items in relation to the previous menu items. Input the data in the X and Y fields.

• **Selected Image**: This is the active image you selected when creating the Menu item. Click Browse to change the image at any point.

• **Unselected Image**: This is the inactive image you selected when creating the menu item. Click Browse to change the image at any point.

• **Store image in cache**: Check this box to save the corresponding image in a cache so that you can use it more readily in the future.

The Navigation section is where you determine how a user moves from one menu item to the next. Although the actions were previously defined in the General tab, this is where you specify which menu item a specific action will bring a user. The possible actions are Up, Down, Left, and Right. In this section, each action has a dropdown list that displays the menu item number for each created menu item. By default, None is selected for each.

Selecting a number in the dropdown list will allow the user to navigate from the current menu item to the specified menu item by performing the corresponding action. Let’s say you are adjusting the features of menu item number 1, meaning “1” is displayed between the Previous and Next buttons at the top of the window. If you click the dropdown list for the Down
action and select 2, the user can now navigate from Menu item 1 to Menu item 2 by pressing the Down button. Remember, the buttons are whatever you previously defined in the Navigation section of the General tab.

The Enter section is where you can determine what happens when a user presses the Enter button on a particular Menu item. Set the following parameters:
• **Play clip**: Click the **Browse** button to select a file you want to play when the user presses the **Enter** button. If you select an image, the option to specify a timeout period will appear.

• **Transition to new state**: Here a dropdown list contains all the media files previously placed in the playlist area of your zone. Select a file to allow the user to transition to that state after pressing **Enter**.

• **Return to prior state**: If you select this option, the presentation will display the previous state when a user presses **Enter**.

• **Remain on current state**: If you select this option, the state will not change when a user presses **Enter**. However, you can add commands to specify changes that occur while remaining on the Interactive Menu. Click the **Advanced** tab to reveal the commands section. See **Chapter 4 – Making a Presentation Interactive** for details.

Click **OK** when you are finished. Keep in mind that if you choose **Transition to new state** instead of **Play clip**, the state will not return to the Interactive Menu.

**Event Handlers**

There are a variety of cases in which you might want your presentation to sit at a blank screen. The Event Handler fills the role of an empty placeholder in your presentation. Here are a few cases where an Event Handler would be convenient:

• You want a blank screen for a Home Screen so no content will play until the presentation is activated.

• You want to add a **command** that is performed before the first file in the presentation plays.

• You want the presentation to sit at a blank screen when finished, instead of looping.

• You want a video file to remain on the final frame upon finishing, instead of looping.

Although Event Handlers contain no content, you can add commands and interactive events into and out of them. For example, if you set the Event Handler as the Home Screen and define a **BP900** event linked from the Event Handler to the first presentation item, the display will sit at a blank screen until a user presses the BP900 button, and then the first item will begin playing. Alternatively, if you set an Event Handler as the Home Screen and add a **Synchronize** command to it, you can synchronize your presentations and/or displays before the first files begin playing.
To use an Event Handler, click the Other tab under Media Library and drag the icon into the playlist area.

1. **State Name**: Enter a unique name for the Media Handler state.
2. **Stop Playback**: Check this box if you would like audio/video playback to end once a media file transitions to the Event Handler state. If this box is left unchecked, audio/video playback will continue after a transition to the Event Handler state and loop until the Event Handler state is exited.
3. **Set as initial state**: Check this box if you would like to make the Event Handler the home state of the presentation.

Define interactive events into and out of the Event Handler as you would with any other state. See Chapter 4 – Making a Presentation Interactive for details. If you define a Media End event after a video and link it to an Event Handler, the video will remain on the last frame when finished. For other file types such as images or audio, the display will sit at a blank screen when the files finish playing.

**Super States**

If you need to create large, complex interactive playlists, you will likely run into two problems: You'll find yourself having to create a large number of redundant events, and it will become difficult to keep track of numerous branching states and conditions. Super States are implemented to alleviate these problems and make complex interactive presentations manageable.

The primary mechanic of the Super State is that it functions as both a state and a self-contained interactive playlist. A Super State can be transitioned into and out of using any event, but clicking on it will reveal a new interactive playlist canvas contained within the original. There are several behaviors that are unique to this state:
• **Each Super State contains an initial state**: A transition to a Super State will point to the initial state within the Super State by default. However, you can point the transition to any other state within the Super State by opening the event and selecting the desired state from the **Specify next state** dropdown menu.

• **Super States can be nested inside other Super States**: You can use the breadcrumb trail above the playlist area to keep track of where you are within the hierarchy of Super States.

• **Super States can have Entry and Exit Commands**: Entry Commands are triggered when any state within the Super State is transitioned to. If a Super State is contained within one or more other Super States, a transition to or from that Super State will trigger Entr/Exit commands on all other Super States that will need to be moved through for the transition to reach its destination. Commands will be executed in sequential order, depending on whether the transition is ascending or descending through a hierarchy of Super States.
You can copy, paste, export, and import Super States: All events, states, commands, and other Super States contained within the Super State will be copied over as well.

Commands
Adding commands to your playlist allows you to add extended functionality to your presentations. Commands can help you control displays and devices (Display On, GPIO On, etc.) or perform additional actions when interactive events are performed (Pause Video, Set Volume, etc.).

You can add commands to interactive events or to states. If you add a command to the interactive event, the command will be performed when that event occurs. If you want to add a command to a state, you will need to choose between an Entry Command (executed upon entering the state) or an Exit Command (executed upon leaving the state). Some Commands (such as Switch Presentation) can only be added to Interactive Events.

Adding Commands to an Interactive Event
Double-click the event icon in the playlist area and click the Advanced tab. Click Add Command and use the dropdown list under Commands to choose the category of the command. Use further dropdown lists and fields to set additional Command Parameters. When adding a command to an interactive event, you can either select a Next State or choose to Remain on current state.

Adding Commands to a State or Media File
Double-click the media file thumbnail in the playlist area and click the Advanced tab. In the Entry Commands or Exit Commands section, click Add Command and use the dropdown list to specify a command. Use further dropdown lists and fields to set additional parameters for the command.
Note: There are a few other options under the Advanced tab. They will depend on the type of file you have selected. For image files, you will see a Store Image in Cache checkbox. Check this box to save the file in a cache and more readily use it in the future. For video files, you will see Video Display Mode. Depending on the type of video file, you can use the dropdown list to select 2D, 3D side-by-side, or 3D top-over-bottom. By default, 2D is selected.

These are the commands you can add to your presentations:

Set Panel Output: Sends a command to a BP900 or BP200 button panel. Use the dropdown list to select the type and enumeration of button pad to use. See the chapter on BP900 and BP200 Button Panels for more details.
  - Button number: Use this dropdown list to choose a specific button number or to choose all buttons on the panel.
  - Action: Use this dropdown list to specify the behavior of the button. You can choose to turn the button on or off. You can also set the button LED to fast blink, medium blink, or slow blink.

Set Audio: Changes the audio settings of a zone. Note that triggering the Set Audio command while an audio/video file is playing will cause playback to freeze (though the player will still respond to Interactive Events like Timeout, UDP Input, etc). You can also use the Set Audio command while displaying an image file, or you can attach the Set Audio command to an Interactive Event that transitions to or from an audio/video file.
  - Zone: Specifies the zone to which the settings will apply.
  - Audio Output: Enables or disables the Analog Stereo, HDMI, and SPDIF audio outputs.
    - Pass through: Supplies the un-decoded audio signal through the HDMI/SPDIF connector. Use this option if the presentation audio (for example, AC3 Dolby Digital) is being decoded on an external device.
    - Stereo: Supplies the decoded audio signal through the HDMI/SPDIF connector.
  - Audio Mixing: Sends the stereo, left-only, or right-only audio signal.

Connector Volume: Changes the audio settings of a specific connector.
  - Set: Specifies the volume level. Select the Analog, HDMI, and SPDIF connector in the dropdown list and enter a volume value between 0 and 100 in the field.
• **Increment**: Specifies how much the volume level increases with each interaction. Select the Analog, HDMI, or SPDIF connector in the dropdown list.

• **Decrement**: Specifies how much the volume level decreases with each interaction. Select the Analog, HDMI, or SPDIF connector in the dropdown list.

• **Mute**: Turns the connector audio output off. Use the checkboxes to select among the Analog, HDMI, and SPDIF connectors.

• **Unmute**: Turns the connector audio output on. Use the checkboxes to select among the Analog, HDMI, and SPDIF connectors.

**Zone Volume**: Sets the volume for a zone. Note that the **Connector Volume** command takes precedence over the **Zone Volume** command when both are active in a presentation.

• **Set**: Specifies an absolute volume level for a zone. Use the dropdown menu to select the zone to which this command applies and enter a volume value between 0 and 100.

• **Increment**: Specifies how much the volume level increases with each interaction. Use the dropdown menu to select the zone to which this command applies and enter an increment amount.

• **Decrement**: Specifies how much the volume level decreases with each interaction. Use the dropdown menu to select the zone to which this command applies and enter a decrement amount.

**Send**: Sends information using the following methods:

• **Send Zone Message**: Triggers a **Zone Message** event with the same command parameter as the Send Zone Message command.

• **UDP**: Sends a command to the device using UDP protocols.

• **Send IR Remote**: Sends a command via the 3.5mm IR Out port (4K and XD models only).

• **Send IR Remote (Pronto)**: Sends a command using Pronto Hex Code (PHC) via the 3.5mm IR Out port (4K and XD models only).

• **Send string (EOL)**: Sends the specified string to the specified serial port. This command adds a carrier return at the end of the string.
• **Serial string (no EOL)**: Sends the specified string to the specified serial port. This command does not add a carrier return at the end of the string.
• **Serial byte**: Sends the specified byte to the specified serial port.
• **Serial bytes (comma separated)**: Sends the specified bytes to the specified serial port in comma-separated format.
• **Send Plugin Message**: Sends the specified string to a custom script plugin attached to the presentation. Use the dropdown menu to select a desired script plugin. Please see the Parsers and Plugins tech note for more information on creating custom scripts that can receive plugin messages.

**Link**: Connects presentation zones or BrightSign players
• **Synchronize**: Specifies the Synchronization trigger.
• **Zones**: Specifies the Link Zones trigger.

**GPIO**: Sends a GPIO command.
• **On**: Turns on the specified GPIO output. Other GPIO outputs are not affected.
• **Off**: Turns off the specified GPIO output.
• **Set State**: Enables you to turn each GPIO line on or off.

**Video**: Changes the video playback settings:
• **Pause video**: Pauses video playback.
• **Resume video**: Resumes video playback.
• **Enable monitor power save mode**: Turns the monitor’s power saving mode on.
• **Disable monitor power save mode**: Turns the monitor’s power saving mode off.

**BrightControl**: Sends commands to monitors and other digital signage displays:
• **Display On**: Turns the display on.
• **Display Off**: Turns the display off.
• **Send Ascii String**: Sends a CEC command. The provided string will be converted to hexadecimal format before it is sent to the display.

• **Set Philips Volume**: Sets Philips TV volume.

**Other**: Sends various commands that are not contained within the above categories.

• **Pause**: Pauses presentation playback for a specified number of milliseconds.

• **Reboot**: Reboots the BrightSign player.

• **Set Variable**: Sets a new value for the specified **User Variable**.

• **Increment Variable**: Increases the value of the specified User Variable by 1.

• **Decrement Variable**: Decreases the value of the specified User Variable by 1.

**Note**: The *Increment Variable* and *Decrement Variable* commands have the following special rules:

- **If used on a number with a decimal value, the number will be converted to an integer by removing the decimal (i.e. the number is not rounded).**
- **If used on a string, the value will be converted to a zero. Then the increment/decrement action will be performed on the zero. Negative numbers are also possible.**

• **Reset Variable**: Resets the specified **User Variable** to its current default value.

• **Reset Variables**: Resets all **User Variables** to their current default values and all **Media Counters** to zero.

• **Switch to Presentation**: Switches to a different presentation. Before using this command, you must add additional presentation(s) to the **Switch Presentations** tab in the **Presentation Properties** window. The parameters set when creating the second presentation must match the first presentation. These parameters include the following: BrightSign Model, Connector Type, Screen Resolution, Monitor Orientation, and Monitor Overscan.

  - **Specify Presentation**: Choose the presentation to switch to from the dropdown list.
  - **Specify via user variable**: Choose the User Variable that will determine which presentation to switch to. The value of the User Variable must be identical to the name given to the target presentation in the **Switch Presentations** tab.
Conditional Targets

Conditional targets allow you to change the settings of an event transition depending on the value of a User Variable. You can set multiple conditional targets for a single event, and you can specify new commands to occur when the conditional target is met. With this feature, you can change the behavior of a presentation based on a wide array of interactive and networked conditions.

1. Select the Advanced tab while creating or editing an event.
2. Click the Set Conditional Targets button.

   **Note:** This option will only be available if you have created one or more User Variables in the File > Presentation Properties window.

3. Click Add Conditional Target in the Conditional Targets window, or click a preexisting Conditional Target to edit it.
4. In the first dropdown menu, select the User Variable that will trigger the Conditional Target.
5. In the second dropdown menu, select the conditional operator that will compare the current value of the variable against the value set in the field to the right. The transition behavior and Advanced Commands you specify in this window will only occur when the entire statement—the variable, the operator, and the target value—is true. These are the conditional operators that are currently available:
   a. Between
   b. Less than (<)
   c. Less than or equal (<=)
   d. Equals (=)
   e. Greater than or equal (>=)
   f. Greater than (>)

![Conditional Target Window](image)
Note: In the target value field, you can enter either a fixed integer or the name of another user variable (i.e. “only when Variable 1 is equal to 42” or “only when Variable 1 is equal to Variable 2”). Like the Set Variable command, you must enter the name of a target variable between two sets of dollar signs (e.g. “$$my_variable$$”).

6. Select **Transition to new state** if you want to use the dropdown list to specify which file in the playlist will be the next state.

7. Select **Return to prior state** if you want the presentation to revert to the previous media file when the interactive event is performed.

8. Select **Remain on current state** if you want the state to remain unchanged when the interactive event is performed.

9. Select the **Advanced** tab to add Commands to the Conditional Target. Commands will trigger when the conditional target is met. See Adding Commands for more information.

10. Click **OK** to save the conditional target.

**Dynamic User Variables**

There are several ways you can change the values of User Variables in an interactive presentation. See Setting Presentation Properties for more information about creating User Variables and setting default values.

**Web Browser**

You can view and update User Variables using a web browser. To do this, your computer must be connected to the same local network as the BrightSign player(s) you are using:

1. Navigate to **Tools > Setup BrightSign Unit**.
2. Check the **Enable local web server** box.
3. Enter a user name and password for the web server if desired.
4. Set the rest of the options in the **BrightSign Unit Setup** window and complete the unit configuration process (see Chapter 2 for more information on setting up units).
5. Wait for the player to complete the entire boot process.
6. Use the address bar of a web browser to navigate to device IP port 8008. For example, if the IP address of your BrightSign player is 192.168.1.2, then you would enter 192.168.1.2:8008. You will be provided with a web page that lists all User Variables and allows you to modify them.

**Note:** If you do not know the IP address of your player, you can obtain it by powering up the player without an SD card inserted: The IP address, along with other information about the unit, will be displayed on screen once the unit boots.

**UDP, Serial Input, or Plugin Message Events**

You can change the value of User Variables using the input from a UDP Input, Serial Input, or Plugin Message event:

1. Create a new UDP Input, Serial Input, or Plugin Message (or edit an existing one).
2. If using a UDP Input event, type `<any>` into the **Specify UDP input** field. The field can contain either the wildcard designator by itself or additional text with the wildcard designator (e.g. "message_<any>").
3. If you are using a Serial Input or Plugin Message event, enter the `<*>` wildcard designator into the **Specify serial input** or **Plugin message** field. The field can contain either the wildcard designator by itself or additional text with the wildcard designator (e.g. "message_<*>").
4. Check the box labeled **Assign input to variable**.
   a. Select **Specify fixed variable** if you want to choose a fixed User Variable in the BrightAuthor presentation. Use the dropdown list to choose which User Variable the UDP input will modify. The UDP/serial string must be input in the form of `<variable value>`.
   b. Select **Input specifies variable** if you want the UDP/serial input string to dynamically specify which User Variable is being modified. The UDP/serial string must be input in the form of `<variable name> : <variable value>`.

   **Note:** If you select **Input specifies variable**, you can modify more than one User Variable with a single event. Use the following UDP/Serial string: `<variable name> : <variable value> !! <variable name> : <variable value>`.
5. Check the box labeled **Assign wildcard to variable** to specify the value of a User Variable using the `<any>` or `<*>` wildcard designator. Select the User Variable to modify using the dropdown menu to the right.
**Note:** It is possible to check both **Assign input to variable** and **Input specifies variable** boxes for more complex functionality. For example, you use **Specify fixed variable** to assign the entire UDP string to one variable, while at the same time using **Assign wildcard to variable** to assign a subset of that string to another variable.

6. Press **OK** to save the settings.
Interactive events can include any of the following. For all interactive events, make sure you define the next state after dragging the icon onto the current state:

<table>
<thead>
<tr>
<th>Event</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Timeout</strong></td>
<td>Displays an item for a predetermined period of time before the next action occurs automatically. To define the length of the timeout interval, double-click the Timeout icon in the playlist area. In the <strong>Specify timeout (seconds)</strong> field, enter the number of seconds you want the item to display, and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td><strong>Media End</strong></td>
<td>Sets the action that occurs after a video or audio file finishes playing.</td>
</tr>
<tr>
<td><strong>GPIO Event</strong></td>
<td>Sets the action that occurs when a specific GPIO button/input is pressed or activated. By default, the playlist toolbar includes several GPIO buttons that you can use to define interactions. When creating a GPIO Event, you can specify a button number and determine whether the event should be triggered when the button is pressed down or released. You can also choose to have the event trigger on <strong>Press (First Touch)</strong> or <strong>Press Continuous</strong>. For <strong>Press</strong>...</td>
</tr>
<tr>
<td>Event</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Continuous</strong></td>
<td>You will need to specify how long the button should be pressed down (in milliseconds) to trigger the event.</td>
</tr>
<tr>
<td><strong>BP900/200</strong></td>
<td>Sets the action that occurs when a specific BP900 or BP200 button is pressed. There are six icons: BP900A, BP900B, BP900C, BP200A, BP200B, and BP200C. See <a href="#">BP900 and BP200 Button</a> for details.</td>
</tr>
</tbody>
</table>
| **Synchronize**| Synchronizes content with another BrightSign player on the same network. This event triggers when a Synchronize command with the same keyword as the Synchronize event is triggered on another player on the local network.  
When the **Synchronize Event** window opens, enter a trigger in the **Specify synchronization keyword** field, and then click **OK**. **Note:** The same event/trigger must be defined for each transition you want synchronized. |
| **UDP Input**  | Sets the action that occurs when the BrightSign player receives the specified UDP (User Datagram Protocol) input from a network device. Use this event when you want external control of the player using UDP (e.g. with the BrightSign App).  
Enter the command string that will trigger the event in the **Specify UDP input** field. If you would like the name of the UDP command button in the BrightSign App to be different from the UDP command string, enter the desired button label in the **Label** field. If you want to hide a UDP command from BrightSign App instances that connect to the player, uncheck the **Show in BrightSign App** box. |
<table>
<thead>
<tr>
<th>Event</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Serial Input</strong></td>
<td>Sets the action that occurs when a BrightSign player receives specific input from a device connected to the serial port.</td>
</tr>
<tr>
<td></td>
<td>Enter the port number of the input data in the <strong>Specify port</strong> field (this parameter is set to 0 by default). Set the serial string that triggers the next event in the <strong>Specify serial input</strong> field. You can use the &lt;<em>&gt; wildcard to allow partial string matches: For example, a serial input of “Error&lt;</em>&quot;&gt;code” would match both “Error 10 code” and “Error 20code” inputs.</td>
</tr>
<tr>
<td></td>
<td>You can also specify whether you want to assign input to a User Variable under the <strong>Advanced</strong> options. Select <strong>Input specifies variable</strong> if the name of the User Variable will be specified in the serial input string or <strong>Specify fixed variable</strong> if you want to choose the User Variable in BrightAuthor.</td>
</tr>
<tr>
<td><strong>Rectangular Touch</strong></td>
<td>Sets the action that occurs when the user touches the specified rectangular area on a touch screen.</td>
</tr>
<tr>
<td></td>
<td>When the <strong>Add Touch Event</strong> window opens, drag the box to resize the touch area (or enter the exact <strong>Size</strong> and <strong>Position</strong>). To add additional touch regions to the selected item, click <strong>Add Touch Region</strong>, define the parameters, and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td>Event</td>
<td>Description</td>
</tr>
<tr>
<td>----------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Keyboard Input</strong></td>
<td>Sets the action that occurs when a BrightSign player receives specific input from a keyboard.</td>
</tr>
<tr>
<td></td>
<td>When the <strong>Keyboard Input Event</strong> window opens, enter the keyboard input that triggers the next event in the <strong>Specify keyboard input</strong> field, and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td><strong>USB Input</strong></td>
<td>Sets the action that occurs when a BrightSign player receives input from a device connected to the USB port.</td>
</tr>
<tr>
<td></td>
<td>When the <strong>USB Input Event</strong> window opens, enter the USB input that triggers the next event in the <strong>Specify USB input</strong> field, and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td><strong>Remote Input</strong></td>
<td>Sets the action that occurs when BrightSign receives specific input from a remote control.</td>
</tr>
<tr>
<td></td>
<td>When the <strong>Remote Input Event</strong> window opens, enter the remote character that triggers the next event in the <strong>Specify remote input</strong> field, and then click <strong>OK</strong>. See Appendix A for remote control codes.</td>
</tr>
<tr>
<td>Event</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| **Zone Message** | Use this event, combined with the Send Zone Message command, to affect changes from one zone to another across multiple synchronized players with multi-zone presentations.  
When the **Zone Message Event** window opens, specify the zone message trigger. **Note:** *The same event/trigger must be defined for each transition you want synchronized.* |
| ![Zone Message](image) |                                                                                                                                                                                                                                                                                                                                               |
| **Link Zones** | Works similarly to the Zone Message event, but with more limited functionality. Only use Link Zones commands and events when you require close, millisecond-level synchronization of content between zones on the same player (as opposed to synchronizing across players).  
When the **Link Zones Event** window opens, enter the trigger in the **Specify link keyword** field, and then click **OK**. **Note:** *The same event/trigger must be defined for each transition you want synchronized.* |
| ![Link Zones](image) |                                                                                                                                                                                                                                                                                                                                               |
| **GPS**      | Sets the action that occurs when a BrightSign unit, connected to a compatible USB GPS device, enters or exits a defined geographical region.  
When the **GPS Event** window opens, select whether you want the event to trigger as the device enters the defined region or leaves the defined region. Set the center of the region by entering the **Latitude** and **Longitude**. Then, define the circular size of the region by entering the **Radius** in Miles or Kilometers.  
**Note:** *You can create more than one enter or exit region by adding multiple GPS events to a single state.* |
<p>| <img src="image" alt="GPS" /> |                                                                                                                                                                                                                                                                                                                                               |</p>
<table>
<thead>
<tr>
<th>Event</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Video Time Code</strong></td>
<td>Performs commands at specific times during video playback. To define the commands and times, drag the Video Time Code icon onto the current state (video file). When the Video Time Code Events window opens, click Add Time Code, enter the Timeout interval, select the Command and Parameters from the corresponding lists, and then click OK. For more details, see Commands.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Video Time Code" /></td>
</tr>
<tr>
<td><strong>Audio Time Code</strong></td>
<td>Performs commands at specific times during audio playback. To define the commands and times, drag the Audio Time Code icon onto the current state (audio file). When the Audio Time Code Events window opens, click Add Time Code, enter the Timeout interval, select the Command and Parameters from the corresponding lists, and then click OK. For more details, see Commands.</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Audio Time Code" /></td>
</tr>
<tr>
<td><strong>Time/Clock</strong></td>
<td>Performs commands at a specific time and date or at regular intervals on a recurring schedule. <strong>Single date/time event</strong> Specify the Date by entering it into the field or selecting it from the calendar view. Then specify the Time by using the dropdown menu. If you want the event to occur at an exact minute, type the desired time directly into the field. If you want to use the value of a User Variable to specify the date and time, select Specify with user variable and choose a variable you've created from the dropdown list. The value of the variable must be in this format: “yyyy-mm-ddThh:mm:ss”. For example, if you would like the event to occur on December 20, 2012 at 3:45PM, then you would use <img src="image" alt="Time/Clock" /></td>
</tr>
<tr>
<td>Event</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>the value “2012-12-20T15:45:00”.</td>
</tr>
<tr>
<td>Daily timeout event</td>
<td>Choose whether you want the event to occur <strong>Once per day</strong> or to be <strong>Periodic throughout the day</strong>. If you select <strong>Once per day</strong>, specify the <strong>Time</strong> using the dropdown menu (or, if you want the event to occur at an exact minute, type the desired time directly into the field). If you select <strong>Periodic throughout the day</strong>, specify the <strong>Interval between events</strong> and the times between which the interval occurs. You can also select days during which this event is active. <strong>Note</strong>: If you choose to make the timeout event <strong>Periodic throughout the day</strong>, the first event will occur at the beginning of the active period.</td>
</tr>
<tr>
<td>Plugin Message</td>
<td>Sets the action that occurs when a message is received from a <a href="#">custom script plugin</a> that is attached to the presentation. Use the <strong>Plugin name</strong> dropdown menu to determine which plugin the event can receive messages from. Enter the message string that will trigger the event in the <strong>Plugin message</strong> field. Plugin Message events can accept wildcards (&lt;*&gt;&gt;) as part of the message string. In the Advanced tab, please see the <a href="#">Parsers and Plugins</a> tech note for more information on creating custom scripts that send plugin messages.</td>
</tr>
</tbody>
</table>
User Defined Events
This feature allows you to save interactive events you use often so that you can use them more readily in the future. All individual events can be added to your toolbar for immediate use, but, with User Defined Events, the parameters for your event are saved.

For example, if you frequently use a 5 second Timeout event, you can create a User Defined Event with this specification. In the future, instead of having to set each Timeout event to 5 seconds, you can use your previously created User Defined Event. In addition, you can group multiple events into your custom event. When defining an interaction with it, any interactive event within the User Defined Event will cause a transition to the next state. This will save you time by eliminating the need for defining each individual event. Simply create a list of events, save it as a User Defined Event, and define the event between the two states.

Click the User Events tab under Media Library. To create/edit User Defined Events, click Manage. The Manage User Events window will open. This window contains a list of all previously created User Defined Events. Complete any of the following:

- **Create a User Defined Event**: Click Add User Event. When prompted, type a unique name for your User Defined Event. Click Add Event and use the dropdown list to select an interactive event. Repeat for each event you want included in the User Defined Event. Click OK when you are finished.
• **Edit a User Defined Event**: Click the appropriate name from the list in the Manage User Events window. Make the desired changes in the User Event window.

• **Organize User Defined Events**: Click the arrows to arrange the order of the list by moving a User Defined Event up or down.

• **Delete User Defined Events**: Click the X beside a name from the list. Or, click **Delete All** to erase the entire list.

To use a User Defined Event in a playlist, click the **User Events** tab under the Media Library. All previously created User Defined Events will be listed here. Drag the appropriate icon from the list onto the current state. In the **Events** window, specify which media file you want to be the **Next State**. Follow the usual steps for defining the event (see **Chapter 4 – Making a Presentation Interactive** for details).

You can also import previously created User Defined Events into BrightAuthor or export them from BrightAuthor. Click **File > Import User Events / Export User Events**. If you are importing, browse to the location where the events are stored. If you are exporting, browse to a location where you want to export all User Defined Events currently saved in BrightAuthor.
CHAPTER 6 – CREATING A BRIGHTWALL™

The BrightWall™ feature allows you to easily create, publish, and edit video-wall deployments. Video walls are created by synchronizing the playback of a number of units, each connected to a different screen on the wall, over a local network connection. Simple looping video playlists are the only presentation type supported by BrightWall. Images and interactive playlists are not supported: Use this FAQ to compare the capabilities of different synchronization options.

The process of publishing BrightWall presentations to players is significantly different from publishing standard presentations. See Chapter 9 > Publishing a BrightWall for more information.

**BrightWall Video Requirements**
For best results, we recommend using the .mp4 or .mov container for video files that make up a BrightWall presentation. Transport Stream (.ts) files are also supported, but they must begin with a presentation timestamp (PTS) offset of zero. Program Stream (MPEG-PS) files are not supported.

**Seamless Looping**
It is possible to create a seamlessly looping video wall if the video files are formatted appropriately. See the Seamless Looping FAQ for more details.

**Creating a BrightWall Presentation**
To create a new BrightWall presentation, navigate to Create > BrightWall™ (if the Create a new Video Wall window doesn’t open automatically, click File > New BrightWall™). A BrightWall presentation requires a BrightWall Configuration file to set the hardware, dimensions, and layout of the video wall. Once you create a BrightWall Configuration file, you can use that file to easily generate any number of BrightWall presentations for the same video-wall setup.

- **Save As**: Enter the name of the new BrightWall project.
- **Where**: Choose where to save the BrightWall project file. Note that the project file is different from the presentation files that will actually be published to the players.
• **Configuration file**: If you have created a BrightWall Configuration file, you can use it to automatically generate settings for the BrightWall project.

• **Create BrightWall Configuration**: Click this button to create a new BrightWall Configuration file. Use this option if you haven’t created a BrightWall Configuration file yet, or if you would like to create an additional BrightWall Configuration file with new settings.

Clicking the **Create BrightWall Configuration** button will open the **BrightWall Configuration** window, which provides the following options.

• **BrightSign Model**: Choose the BrightSign player model that will display the video wall. All players that are part of the video wall must be of the same model type.

• **Connector type**: Choose the connector (HDMI, VGA, Component) that each player will use to connect to its screen. All players that are part of a video wall must use the same connector.

• **Screen resolution**: Choose the resolution of each screen in the video wall. All video wall screens must have the same resolution. You can view all available screen resolutions on the Support Section of the BrightSign website.

  **Note**: Individual screens only support video files in landscape mode.

• **Monitor overscan**: Select an overscan setting to determine how each video fills the display screen.
  
  o **No overscan – use full screen**: Displays video to the edge of the video signal.
  
  o **Overscan – action safe**: Restricts the image display to an area that is compatible with most displays.
  
  o **Overscan – title safe**: Restricts the image display to an area that is much smaller than the image generated by the video signal.

• **Number of rows**: Specify the vertical length of the video wall (in number of screens).

• **Number of columns**: Specify the horizontal length of the video wall (in number of screens).

• **Domain**: Specify a domain number (between 0 and 127). This number must be unique for each video wall on the network. This will ensure that multiple video walls can run on the same local network without synchronization messages interfering with each other.

• **Bezel Width and Height**: Account for the bezel size of the monitors that make up the video wall. This allows for better alignment of videos in the video wall. These measurements only apply to Stretched BrightWall presentations. For Regular presentations, bezel width and height will need to be accounted for in the content creation application.
**Note**: The BrightWall Type (Stretched or Regular) is not specified in the BrightWall Configuration file. Instead, you set this option for each individual BrightWall presentation.

- **By percentage**: Enter the bezel width and height as percentages. Use the following calculation to determine bezel percentages:
  
  ▪ **Width**: The width of the bezel between active screens (i.e. the total of both left and right bezels) divided by the width of an active screen. The result is multiplied by 100. For example, a video wall made up of screens with a width of 42 inches and a 1 inch bezel on each side would be calculated as follows: \((2”/42”) \times 100 = 5\%\)
  
  ▪ **Height**: The height of the bezel between active screens (i.e. the total of both top and bottom bezels) divided by the height of an active screen. The result is multiplied by 100. For example, a video wall made up of screens with a height of 23.625 inches and a 1 inch bezel on each side would be calculated as follows: \((2”/23.625”) \times 100 = 8\%\)

  **Note**: Bezel width and height percentages must be specified as integers (i.e. whole numbers that are positive).

- **By measurement**: Enter the bezel width, bezel height, screen width, and screen height in millimeters (mm). BrightAuthor will make the calculations automatically.

- **Save As**: Click this button to save the BrightWall Configuration file. It will then be used as the Configuration File for the BrightWall presentation.

Once you’ve created or selected a BrightWall Configuration file, click **Create BrightWall Presentation**. The **BrightWall™ Presentation Properties** window will open:

**Main**

- **Type**: Choose whether the BrightWall presentation is *Regular* or *Stretched*:
  
  ▪ **Regular**: Each panel of the BrightWall presentation is made up of a different video file. To create a single video surface out of multiple screens, video assets will need to be tailored for the video wall using the source application (e.g. Adobe After Effects): You will need to split the videos into their respective screens and adjust for bezel width before adding the assets to BrightAuthor.
• **Stretched**: The video wall is made up of a single video. BrightAuthor automatically splits the video among the screens. This option allows you to display video files, as well as Streaming Video, Live Video, and RF Input.

- **View mode**: Choose the view mode of the presentation. In *Regular* presentations, this option applies to videos on individual screens, similar to the View Mode option found in the Zone Properties menu. In *Stretched* presentations, this option applies to the entire wall. The following descriptions apply to *Stretched* presentations only:
  - **Scale to Fill**: The video will be stretched over all screens in the video wall. If the aspect ratio of the video wall does not match the ratio of the video content, the video will likely appear stretched or distorted.
  - **Letterboxed and Centered**: The video will not be stretched. Instead, it will appear at the center of the video wall at its original resolution, which may cover one or multiple screens. Areas of the video wall that are not filled by the video will display the background color of the presentation.
  - **Fill Screen and Centered**: The video will be stretched to the height or width of the video wall (whichever length is greater). If the aspect ratio of the video wall does not match the ratio of the video content, the video will be cut off at the height or the width (whichever length is lesser).

**Audio**

- **Audio Output**: Enables or disables the Analog, HDMI, and SPDIF audio outputs. In BrightWall presentations, only the master unit (i.e. the player driving Screen 1) outputs audio, so these settings do not affect any of the slave units in the presentation.
  - **Pass through**: Supplies the un-decoded audio signal through the HDMI connector. Use this option if the zone audio (for example, AC3 Dolby Digital) is being decoded on an external device.
  - **Stereo**: Supplies the audio as a stereo signal.

- **Audio Mixing**: Enables the stereo, left-only, or right-only audio signal.

**Adding Video to a BrightWall Presentation**

The process of creating a video playlist for a BrightWall will differ depending on whether you created a *Regular* or *Stretched* presentation.
For a Regular BrightWall

Each screen in a video wall has a distinct playlist. You can switch among screens by selecting them in the Screen section.

To create a regular BrightWall, you will need to add a different video file to each screen. The Media Library of a Regular BrightWall has special properties that help streamline playlist creation:

- A Video with a file name in the format “VideoName_Number” appears only in the Media Library of the screen corresponding to its number.
Adding a video with a “VideoName_Number” file name to a screen will add all other videos with the same format to their respective screen playlists. This behavior will only occur if the quantity of “VideoName_Number” files corresponds to the number screens in the BrightWall presentation.

**Example:** Your BrightWall project consists of four screens. The video is split into four files, each file representing ¼ of the entire wall: “Intro_1.mpg”, “Intro_2.mpg”, “Intro_3.mpg”, and “Intro_4.mpg”. Only “Intro_1” will appear in the Media Library of Screen 1. Adding “Intro_1” to Screen 1 will automatically add “Intro_2” to Screen 2, “Intro_3” to Screen 3, and “Intro_4” to Screen 4. If your BrightWall project is expanded to six screens, then adding “Intro_1” will not affect the playlists of the other screens because there are only four “Intro” video files.

**For a Stretched BrightWall**
The entire video wall has the same playlist. Adding a video file, Streaming Video, Live Video, or RF Input to the playlist will split the video among the screens during playback.

**Configuring a BrightWall Presentation**
To configure a BrightWall presentation, navigate to File > BrightWall™ Properties.

**Main**
- **Type:** Choose whether the BrightWall presentation is Regular or Stretched:
  - **Regular:** Each panel of the BrightWall presentation is made up of a different video file. To create a single video surface out of multiple screens, video assets will need to be tailored for the video wall using the source application (e.g. Adobe After Effects): You will need to split the videos into their respective screens and adjust for bezel width before adding the assets to BrightAuthor.
  - **Stretched:** The video wall is made up of a single video. BrightAuthor automatically splits the video among the screens. This option allows you to display video files, as well as Streaming Video, Live Video, and RF Input.
- **View mode:** Choose the view mode of the presentation. In Regular presentations, this option applies to videos on individual screens, similar to the View Mode option found in the Zone Properties menu. In Stretched presentations, this option applies to the entire wall. The following descriptions apply to Stretched presentations only:
o **Scale to Fill**: The video will be stretched over all screens in the video wall. If the aspect ratio of the video wall does not match the ratio of the video content, the video will likely appear stretched or distorted.

o **Letterboxed and Centered**: The video will not be stretched. Instead, it will appear at the center of the video wall at its original resolution, which may cover one or multiple screens. Areas of the video wall that are not filled by the video will display the background color of the presentation.

o **Fill Screen and Centered**: The video will be stretched to the height or width of the video wall (whichever length is greater). If the aspect ratio of the video wall does not match the ratio of the video content, the video will be cut off at the height or the width (whichever length is lesser).

**Configuration**

- **Configuration file**: Use the [Browse](#) button to locate and select a preexisting BrightWall Configuration file to use with the BrightWall project.

- **Edit BrightWall Configuration**: Edit the selected BrightWall Configuration file.

- **Create BrightWall Configuration**: Create a new BrightWall Configuration file. See the [Creating a BrightWall Presentation](#) section for more details.

**Audio**

- **Audio Output**: Enables or disables the Analog, HDMI, and SPDIF audio outputs. In BrightWall presentations, only the master unit (i.e. the player driving Screen 1) outputs audio, so these settings do not affect any of the slave units in the presentation.

  - **Pass through**: Supplies the un-decoded audio signal through the HDMI connector. Use this option if the zone audio (for example, AC3 Dolby Digital) is being decoded on an external device.

  - **Stereo**: Supplies the audio as a stereo signal.

- **Audio Mixing**: Enables the stereo, left-only, or right-only audio signal.

**Completing a BrightWall Presentation**

Before you can publish a BrightWall presentation, you will need to save it by navigating to **File > Save** or **Save As**. If you would like to publish a BrightWall presentation using the BrightSign Network, click the **Upload to network** button once
you’ve signed into your account. You can also export a BrightWall presentation for use on another computer by navigating to File > Export.

When you’re ready to publish to your video wall, navigate to the Publish tab and click the **Video Walls** option.

**Creating a BrightWall on the BrightSign Network**
Creating a BrightWall and distributing a BrightWall presentation to it via the BrightSign Network requires several steps within BrightAuthor. Follow these steps to create a BrightWall group, create a BrightWall within the BrightWall group, and publish your presentation to the BrightWall group:

1. Sign in to your BrightSign Network account by navigating to **Tools > Sign In to BrightSign Network**.
2. After creating your BrightWall presentation, click the **Upload to network** button in the top-right. This will upload both the BrightWall presentation and BrightWall configuration file to the BrightSign Network.
3. Navigate to the **Manage > Status** tab.
4. Expand the **BrightWall Groups** section at the bottom of the screen.
5. Click **Add BrightWall Group**.
6. Enter a **BrightWall group name** and select a **BrightWall configuration**. The BrightWall configuration will be applied to every BrightWall created within the group. Click **OK** when finished.
7. Once you’ve created a BrightWall group, you will need to set up players as part of the BrightWall configuration:
   a. Navigate to **Tools > Setup BrightSign Unit**.
   b. Select the **BrightWall Group** option under **Networked with the BrightSign Network**.
   c. Use the **BrightWall Group** dropdown list to select the BrightWall group created in steps 5 and 6.
   d. Click the **Add BrightWall** button to add a new BrightWall to the BrightWall group. Enter a **BrightWall name** and click **OK**.
   e. Use the **Screen Number** dropdown list to specify the section of the BrightWall to which the player belongs. Screens are numbered by row, starting from the top-left section of the BrightWall (the example diagram to the right shows the numbering of a 4x3 BrightWall).
   f. Enter the rest of the player configuration settings as desired and set up the player—see
Chapter 6 – Creating a BrightWall

8. Repeat steps 7a through 7f to set up every player in the BrightWall—make sure to use the same BrightWall Group and BrightWall Name for all players in the BrightWall.

9. Navigate to the Publish > BrightSign Network tab.

10. Select the BrightWall Presentations option.

11. Under Select BrightWall Group to Schedule, select the BrightWall group you created in steps 5 and 6.

12. Add one or more BrightWall presentations to the schedule—see the Publishing with BrightSign Network section for more details on scheduling.

13. Click Publish schedule. Make sure all the players in the BrightWall are powered up and connected to the Internet. Allow time for the players to downloaded the content, reboot, and synchronize playback.

Adding a New BrightWall to the Group

Use the Add BrightWall option during unit setup to add additional BrightWall(s) to the BrightWall group. A new BrightWall will use the same configuration and be scheduled with the same presentations as other BrightWall(s) in the group.
Using Configuration Files
Each BrightWall presentation within a BrightWall group must use the same configuration file. If you want to create additional BrightWall presentations with different configuration files, you will need to create additional BrightWall groups in the Manage > Status tab.

If you don’t have the original configuration file (for example, if the user who created the original configuration file is on a different PC), you will need to retrieve it from BSN:

1. Navigate to the Manage > Presentations tab.
2. Expand the BrightWall Configurations section.
3. Right-click the original configuration file and select Download to save the file to your hard drive.
4. When creating a new BrightWall presentation, use the Browse button to locate and select this configuration file.
The **BP900 and BP200 button panels** are LED-based touch devices that allow you to add interactivity to your BrightAuthor presentations. These button panels are compatible with any BrightSign device that has a USB port.

There are a total of six event icons: BP900A, BP900B, BP900C, BP200A, BP200B, and BP200C. The letters A, B, and C correspond to USB ports. If the event you are defining is for a button pad connected to USB port 1, use A. If it is for a button pad connected to the second port, use B. Let’s say you are using an XD1132 and, therefore, have two available USB ports. If you want to connect two button boards, a BP900 and a BP200, you would use the BP900A and BP200B icons to define events for each.

**Using BP900 and BP200 Events**

1. Make your presentation interactive by clicking **Interactive** in the upper-right side of the playlist area.
2. Define the BP900 or BP200 interactive event:
   a. Choose the proper event icon based on what kind of button pad you are using (BP900 or BP200), and how many button pads you are connecting.
   b. Define the BP900 or BP200 event as you would any other event. See **Chapter 4 – Making a Presentation Interactive** for details.
   c. The **BP900 Event** or **BP200 Event** window will automatically open. Specify the following parameters for your event:
      - **Specify Button Number**: Select a button on the button pad that you want the user to press to transition to the next state.
      - **Important**: Specifying **Any Button** will enable only the button numbers used in other BP200 or BP900 events in the presentation (or numbers enabled in the **Presentation Properties > Buttons** window):
For example, if there are defined BP900 events for buttons 1 and 4, then a BP900 event set to **Any Button** will trigger for buttons 1 and 4 only.

- **Press (First Touch)**: Determine whether you want the transition to occur after one push of the button.

[Image of BP900A Event window]

- **Press Continuous**: Determine whether you want the user to continually press the button. Specify a repeat interval in the text field (in milliseconds).
- **Transition to new state**: Click to specify which media file in your playlist will be the next state when the specified button is pushed.
- **Return to prior state**: Click to revert the presentation to the previous media file when the specified button is pushed.
- **Remain on current state**: If you select this option, the state will not change when the interactive event is performed. This option is useful for creating changes within one media file. You can create these changes by adding commands.

- **Advanced**: Click the Advanced arrow to reveal the display options and commands section. Here you can set how you view the interactive events between states in the playlist area. **Show line** draws a line between the media files. **Show label** creates a label either to the **Right** or **Bottom** of the media file that indicates transitions from states.

  d. **Click OK**. Repeat Steps a through c to define the remaining button pad events.
CHAPTER 8 – PUBLISHING PRESENTATIONS

After you create and save a presentation, you’re ready to publish it to your BrightSign player or players. There are four ways to publish a presentation:

- Local Storage
- BrightSign Network
- Local Networking
- Simple File Networking

The method you use to publish should depend on several factors, such as whether your player is networked, what kind of network you have access to, and how many players you have.

Publishing with Local Storage
Publishing a presentation using Local Storage lets you copy your presentations to an SD card or USB flash drive. When you want to update your scheduled presentations, you must save the updated content on the SD card or USB flash drive and insert it into your BrightSign player.

Unless you are updating content, an SD card or flash drive should always remain connected to the BrightSign player. However, if your BrightSign player has a USB port, it is recommended that you create setup files with an SD card, leave it permanently in the player as internal storage, and use a USB flash drive whenever you need to update content. You can publish updated content to the USB flash drive, insert it into the BrightSign to update the SD card, and then remove the flash drive.

To publish via Local Storage, complete the following steps:
1. Save the presentations you want to publish by clicking File > Save… As. You will also be prompted to save a presentation if there are unsaved changes to the presentation when you switch to the Publish tab.
2. Add the presentations you want to publish:
   a. Click the Publish tab.
   b. Click Local Storage (below the Publish tab).
   c. Choose whether you want to publish Presentations or Video Walls.
   d. Click Browse under Presentations to navigate to and select the folder where your presentations are stored.

3. Create schedules for each presentation you wish to publish:
   a. Select a presentation from the list in the Presentations section.
   b. Drag the presentation to a time slot during which you want it to play.
   c. Click and drag the selection handles to adjust playing time within one day.
   
   **Note**: Alternatively, you can schedule a presentation by double-clicking a blank area on the schedule to open the Schedule Presentation window.
   
   d. If you want the presentation to be a recurring event, double-click a presentation timeframe in the calendar. In the Schedule Presentation window, set the following parameters:
      
      - **Presentation**: Specify which presentation you want to schedule.
      - **Active all day, every day**: Check this box if you want the presentation to play 24 hours a day.
      - **Event time**: Specify the timeframe when you want the presentation to play by using the dropdown lists beside Start and End.
      - **Recurring Event**: Check this box if you want the presentation to recur during specified times.
      - **Recurring pattern**: Specify the frequency for the recurrence. If you click Daily, you can specify Every day, Every weekday, or Every weekend. If you click Weekly, you can view a checklist of every day of the week. Specify the individual days of the week when you want the presentation to play.
      - **Range of recurrence**: Use the calendar beside Start to specify the first day you want the presentation to play. If you want the event to stop recurring at some point, click End by and use the calendar to specify the date. If you don’t want it to stop, click No end date.
e. Click **OK**. The adjustments you made will be represented in the calendar.

f. Repeat steps b through e for each presentation you want to schedule in an empty timeslot.

g. If you would like to **interrupt** a scheduled presentation with another presentation, drag and drop the new presentation into an occupied timeslot (you can also schedule an overlap in the **Schedule Presentation** window). A **Schedule Conflict** window will appear, providing the following options:

- **Keep existing events, cancel new event**: Cancels the new schedule presentation action.
• **Keep existing events, adjust new event**: Opens the **Schedule Presentation** window, allowing you to schedule the new presentation in an empty timeslot. If you schedule the presentation in an occupied timeslot, the **Schedule Conflict** window will appear again.

• **Remove existing events, use new event**: Completely removes the presentation currently occupying the timeslot.

• **Interrupt existing events with new event**: Schedules an interrupt in the presentation currently occupying the timeslot. The date field will be split into two columns: The left column shows the primary scheduled presentation in blue; the right column shows the interrupting presentation in green. Primary scheduled presentations can be interrupted with multiple presentations, but interrupting presentations cannot overlap with each other.

4. **(Optional) Specify debugging, logging, and firmware preferences**:
   a. Under **Debugging**, you may check one of the following:
      • **Enable serial debugging**: The autorun script will output debugging information related to the presentation to the RS-232 serial port (as well as over Telnet and SSH if these features are enabled).
      • **Enable system log debugging**: The autorun script will output debugging information related to the presentation to the **Log** tab in the **Diagnostic Web Server**.
   b. Click **Specify Logging** and use the checkboxes in the **Logging** window to have the player generate logs while it operates.
   c. Click **Specify Firmware Update** to indicate what firmware version you want the player to be updated to. The **Firmware Update** window is divided by BrightSign generation. In the section that corresponds to your player model, select a firmware version or **Do not update** and then click **OK**. You can also use the **Update type** dropdown menu to determine the behavior of the firmware update:
      • **Standard**: The `.bsfw` update file deletes itself from the local storage once the firmware update process is complete and the player reboots.
      • **Different**: The update will only be applied if the version of the `.bsfw` update file does not match the current firmware version of the player. The file is not deleted after the update process is completed.
      • **Newer**: The update will not be applied if the current firmware version of the player is newer than the version of the update file. The file is not deleted after the update process is completed.
• **Save**: The `.bsfw` update file is not deleted after the update is applied. The device will only reboot once the storage device containing the update file is removed.

5. Select **Standalone Unit** if you would like to publish the selected presentation to the player using an SD card.
   a. (Optional) Click the **Specify Password** button if you would like to set up, change, or remove password protection for USB content updates. The password protection feature helps ensure that a player will not be updated with incorrect schedules or data. When the USB Content Update Password window opens, select one of the following:
   - **Keep Password**: Leaves the current content update password for the player unchanged.
   - **Set New Password**: Changes the content update password for the player. Enter the new password in the field.
   - **Clear Password**: Removes the content update password. This allows USB updates to be published to the SD card without restrictions.

6. Select **Standalone unit with setup** to publish the player setup files and presentation schedule at the same time. When you click the **Publish** button, the **BrightSign Unit Setup** window will open, prompting you to configure the player for **Standalone use**.

7. Select **Setup unit for BrightSign Network** to include player setup files for the BrightSign Network with the published presentation. This option is useful if you want to ensure that a newly set up player will run a presentation even if it cannot initially connect to the BrightSign Network. Once the player connects to the BrightSign Network, it will update to the current presentation and schedule for its assigned group. When you click **Publish**, you will be prompted to **set up the player for the BrightSign Network**.

8. Select **Publish for USB update** if you want to use a USB flash drive to update the SD card in the BrightSign player. You can use this feature to update content on a standalone player without ever needing to remove the SD card.

   **Important**: A schedule must already be published to the SD card for the USB update to work. Publish an initial schedule via the SD card first; you can then use the USB update feature for subsequent publishing operations.
a. (Optional) Click the **Specify Password** button if you are publishing a USB content update to a player or set of players with password protection. Enter the **USB Content Update Password**. You must enter the same upgrade password designated for the player or else the player content upgrade will fail. You can choose the password when you set the player up for standalone use or when you use the **Set New Password** feature (see step 5a above).

**Note:** *If no update password is currently set for the player, entering a phrase in this field will designate it as the new update password.*

9. Select **USB update (FW only)** if you want to use a USB flash drive to update the firmware on the player (without publishing a new presentation). You can use this feature to update the firmware on a player without ever needing to remove the SD card or publish a presentation to the player. Use the **Specify Firmware Update** button (described in step 4c above) to determine the update version.

10. Publish the presentation to your storage device:
   a. Insert a storage device into your computer (SD card or USB flash drive).
   b. Under **Publish to**, click **Browse** to navigate to and select the drive where your storage device is located.
   c. Click **Publish**. When the **Publish complete** window opens, click **OK**.

11. Update your BrightSign player:
   a. Turn off the BrightSign player by unplugging the power adapter (or Ethernet cable if the player is being powered by PoE).
   b. Insert the storage device from step 4 into the player.
   c. Turn on the BrightSign unit by reconnecting the power.

**Note:** *If an SD card is already in the player and you are updating it via USB, you don’t need to turn off the player. Insert the USB flash drive into the player, wait until the Update Complete message appears on the display, and then remove the flash drive.*
Publishing with BrightSign Network

Publishing with BrightSign Network enables you to distribute your presentation to your BrightSign players using an Internet connection.

BrightSign Network requires a subscription, so you must first contact BrightSign to obtain an account name, user name, and password. Once your BrightSign players are set up with BrightSign Network, you can upload your presentations to the BrightSign Network server, publish schedules, and manage content. Your players will update their content automatically whenever they connect to the server.

Publishing with BrightSign Network sends presentations and schedules to groups instead of players. Groups can contain any number of players, and you can move BrightSign players from one group to another at any point. See Managing Your Network for details.

To publish with BrightSign Network, complete the following steps:

1. Sign into BrightSign Network by clicking Tools > Sign in to BrightSign Network.
2. Open the presentation you wish to publish by selecting File > Open presentation.
3. Click Upload to network (in the upper-right portion of the screen) to upload the presentation to the server.
4. Specify to which group you want to publish:
   a. Click the Publish tab in the upper-left portion of the screen.
   b. Click BrightSign Network (above the calendar).
   c. Choose whether you want to publish Presentations or Video Walls.
   d. Under Selected Group to Schedule, use the dropdown list to specify the group to which you want to publish.
5. Create schedules for each presentation you want to publish:
   a. Select a presentation from the Presentations dropdown list.
   b. Drag the presentation to a time slot during which you want it to play.
   c. Click and drag the selection handles to adjust playing time within one day.
**Note**: Alternatively, you can schedule a presentation by double-clicking a blank area on the schedule to open the *Schedule Presentation* window.

d. If you want the presentation to be a recurring event, double-click the highlighted presentation name in the calendar. In the *Schedule Presentation* window, set the following parameters:

- **Presentation**: Specify which presentation you want to schedule.
- **Active all day, every day**: Check this box if you want the presentation to play 24 hours a day.
• **Event time**: Specify the time during the day when you want the presentation to play by using the dropdown lists beside **Start** and **End**.

• **Recurring Event**: Check this box if you want the presentation to recur during specified times.

• **Recurring pattern**: Specify the frequency for the recurrence. If you click **Daily**, you can specify **Every day, Every weekday, or Every weekend**. If you click **Weekly**, you can view a checklist of every day of the week. Specify the individual days of the week when you want the presentation to play.

• **Range of recurrence**: Use the calendar beside **Start** to specify the first day you want the presentation to play. If you want the presentation to stop recurring at some point, click **End by** and use the calendar to specify the date. If you don’t want it to stop, click **No end date**.

e. Click **OK**. The adjustments made will be represented in the calendar.

f. If prompted, indicate whether you want to replace the existing schedule and then click **OK**.

g. Repeat steps b through e for each presentation you want to schedule in an empty timeslot. If you drag and drop a new presentation into an occupied timeslot, the **Schedule Conflict** window will appear, providing the following options:

   • **Keep existing events, cancel new event**: Cancels the new schedule presentation action.
   
   • **Keep existing events, adjust new event**: Opens the **Schedule Presentation** window, allowing you to schedule the new presentation in an empty timeslot. If you schedule the presentation in an occupied timeslot, the **Schedule Conflict** window will appear again.
   
   • **Remove existing events, use new event**: Completely removes the presentation currently occupying the timeslot.

6. (Optional) Specify debugging and firmware preferences:

   a. Under **Debugging**, you may check one of the following:

      • **Enable serial debugging**: The autorun script will output debugging information related to the presentation to the RS-232 serial port (as well as over Telnet and SSH if these features are enabled).
      
      • **Enable system log debugging**: The autorun script will output debugging information related to the presentation to the **Log** tab in the **Diagnostic Web Server**.
b. Click **Specify Firmware Update** to indicate what firmware version you want the player to be updated to. The **Firmware Update** window is divided by BrightSign generation. In the section that corresponds to your player model, select a firmware version or **Do not update** and then click **OK**.

7. Publish the presentation:
   a. Click **Publish Schedule**.
   b. When the **Publish Complete** window opens, click **OK**.
Publishing with Simple File Networking

Simple File Networking enables you to distribute your presentation to your BrightSign players via a web folder. Your player must be [set up for Simple File Networking](#) with the correct [URL for web folder](#) used during setup.

1. In BrightAuthor, save the presentations you want to publish by clicking **File > Save... As**
2. Add the presentations you want to publish:
   a. Click the **Publish** tab in the upper-left side of the screen.
   b. Click **Simple File Network** (above the Calendar).
   c. Choose whether you want to publish **Presentations** or **Video Walls**.
   d. Under **Presentations**, click **Browse** to navigate to and select the folder where your presentations are stored.
3. Create schedules for each presentation you want to publish:
   a. From the list under **Presentations**, select a presentation.
   b. Drag the presentation to a time slot during which you want it to play.
   c. Click and drag the selection handles to adjust playing time within one day.
   **Note:** Alternatively, you can schedule a presentation by double-clicking a blank area on the schedule to open the **Schedule Presentation** window.
   d. If you want the presentation to be a recurring event, double-click the highlighted presentation name in the calendar. In the Schedule Presentation window, set the following parameters:
      - **Presentation**: Specify which presentation you want to schedule.
      - **Active all day, every day**: Check this box if you want the presentation to play 24 hours a day.
      - **Event time**: Specify the time during the day when you want the presentation to play by using the dropdown lists beside Start and End.
      - **Recurring Event**: Check this box if you want the presentation to recur during specified times.
      - **Recurring pattern**: Specify the frequency for the recurrence. If you click **Daily**, you can specify Every day, Every weekday, or Every weekend. If you click **Weekly**, you can view a checklist of
every day of the week. Specify the individual days of the week when you want the presentation to play.

- **Range of recurrence**: Use the calendar beside **Start** to specify the first day you want the presentation to play. If you want the event to stop recurring at some point, click **End by** and use the calendar to specify the date. If you don’t want it to stop, click **No end date**.

e. Click **OK**. The adjustments made will be represented in the calendar.

f. If prompted, indicate whether you want to replace the existing schedule and then click **OK**.

g. Repeat steps b through e for each presentation you want to schedule in an empty timeslot.

h. If you would like to **interrupt** a scheduled presentation with another presentation, drag and drop the new presentation into an occupied timeslot (you can also schedule an overlap in the **Schedule Presentation** window). A **Schedule Conflict** window will appear, providing the following options:

- **Keep existing events, cancel new event**: Cancels the new schedule presentation action.
- **Keep existing events, adjust new event**: Opens the **Schedule Presentation** window, allowing you to schedule the new presentation in an empty timeslot. If you schedule the presentation in an occupied timeslot, the **Schedule Conflict** window will appear again.
- **Remove existing events, use new event**: Completely removes the presentation currently occupying the timeslot.
- **Interrupt existing events with new event**: Schedules an interrupt in the presentation currently occupying the timeslot. The date field will be split into two columns: The left column shows the primary scheduled presentation in blue; the right column shows the interrupting presentation in green. Primary scheduled presentations can be interrupted with multiple presentations, but interrupting presentations cannot overlap with each other.

4. (Optional) Specify debugging and firmware preferences:

   a. Under **Debugging**, you may check one of the following:

   - **Enable serial debugging**: The autorun script will output debugging information related to the presentation to the RS-232 serial port (as well as over Telnet and SSH if these features are enabled).
• **Enable system log debugging**: The autorun script will output debugging information related to the presentation to the Log tab in the Diagnostic Web Server.

b. Click **Specify Firmware Update** to indicate what firmware version you want the player to be updated to. The Firmware Update window is divided by BrightSign generation. In the section that corresponds to your player model, select a firmware version or **Do not update** and then click **OK**. You can also use the **Update type** dropdown menu to determine the behavior of the firmware update:

  • **Standard**: The .bsfw update file deletes itself from the local storage once the firmware update process is complete and the player reboots.
• **Different**: The update will only be applied if the version of the .bsfw update file does not match the current firmware version of the player. The file is not deleted after the update process is completed.

• **Newer**: The update will not be applied if the current firmware version of the player is newer than the version of the update file. The file is not deleted after the update process is completed.

• **Save**: The .bsfw update file is not deleted after the update is applied. The device will only reboot once the storage device containing the update file is removed.

5. Publish the presentation:

   a. Under **Simple File Networking Parameters**, click **Set Parameters**.

   b. Under **Unit Configuration**:
      
      • **URL for web folder**: Type the URL for your web folder. This must match the URL you entered when setting up your device for Simple File Networking.

      • **Content Check Frequency**: Use the dropdown list to specify how often you want the player to connect to the server to check for content and scheduling updates.

      • (Optional) **Simple File Networking Authentication**: Enables digest authentication between the BrightSign player and the web server.

      • (Optional) **Enable basic authentication**: Passes credentials to the web server in unsecured packets that are easily readable by others. Use this option only if it is absolutely required by the configuration of your web server.

      • (Optional) **Limit content downloads**: Check this box and use the dropdown lists beside **Start of range** and **End of range** to specify the times during the day when content can be downloaded.

   c. (Optional) Under **Logging**, check any of the following boxes to enable the corresponding logs:
• **Enable playback logging**: Creates a log that records start and end times, zone names, media types, and file names.

• **Enable event logging**: Creates a log that records timestamps, state names, zone names, event types, and event data.

• **Enable state logging**: Creates a log that records current and last state names, timestamps, and media types.

• **Enable diagnostic logging**: Creates a log that records timestamps, firmware and script versions, and the current presentation.

d. Under **Upload Logs**, use the following checkboxes to determine the settings for uploading logs to the server.

   • **On startup**: Uploads log files each time the player is powered on.

   • **At specific time each day**: Uploads log files daily at the specified time. Use the dropdown menus to determine a time.

e. (Optional) Under **Rate Limit Network Download Traffic**, set parameters for download traffic. The options are divided into **Outside content download window**, **During content download window**, and **During initial downloads**.

   • Click **Unlimited download rate** to set no limit.

   • Click **Default limit** to use the default limit on downloads.

   • Click **Specify limit** to enter a customized limit on downloads in the text field (in Kbits/seconds).

   e. Click **OK**.

f. Under **Publish to**, click **Browse** to navigate to and select the location where you want to store the files.

   • If you have a mapped drive or shortcut that points to your web folder, publish to that location.

   • If you use FTP to transfer files to your web folder, publish to a folder on your computer and then use FTP software to copy the files to your web folder.

   g. Click **Publish**. When the **Publish Complete** window opens, click **OK**.
Publishing with Local Networking

Publishing a presentation with a local network lets you distribute your presentation to BrightSign players without using an Internet connection. This is convenient if you only have a small number of BrightSign players that are all on the same local network. With Local Networking, the BrightSign player does not need to poll a remote web server to receive updates. Instead, you select one or more BrightSign players in BrightAuthor and publish a presentation directly to them. Updates will then be sent to the BrightSign player immediately.

1. Save the presentation you want to publish by clicking File > Save As

2. Add the presentation you want to publish:
   a. Click the Publish tab in the upper-left side of the screen.
   b. Click Local Network (above the Calendar).
   c. Choose whether you want to publish Presentations or Video Walls.
   d. Under Presentations, click Browse to navigate to and select the folder where your presentations are stored.

3. Create schedules for each presentation you want to publish:
   a. From the list under Presentations, select a presentation.
   b. Drag the presentation to a time slot during which you want it to play.
   c. Click and drag the selection handles to adjust playing time within one day.
   d. If you want the presentation to be a recurring event, double-click the highlighted presentation name in the calendar. In the Schedule Presentation window, set the following parameters:
      - Presentation: Specify which presentation you want to schedule.
      - Active all day, every day: Check this box if you want the presentation to play 24 hours a day.
      - Event time: Specify the time during the day when you want the presentation to play by using the dropdown lists beside Start and End.
• **Recurring Event**: Check this box if you want the presentation to recur during specified times.

• **Recurring pattern**: Specify the frequency for the recurrence. If you click Daily, you can specify Every day, Every weekday, or Every weekend. If you click Weekly, you can view a checklist of every day of the week. Specify the individual days of the week when you want the presentation to play.

• **Range of recurrence**: Use the calendar beside Start to specify the first day you want the presentation to play. If you want the presentation to stop recurring at some point, click End by and use the calendar to specify the date. If you don’t want the presentation to stop, click No end date.

e. Click OK. The adjustments made will be represented in the calendar.

f. If prompted, indicate whether you want to replace the existing schedule and then click OK.

• **Keep existing events, cancel new event**: Cancels the new schedule presentation action.

• **Keep existing events, adjust new event**: Opens the Schedule Presentation window, allowing you to schedule the new presentation in an empty timeslot. If you schedule the presentation in an occupied timeslot, the Schedule Conflict window will appear again.

• **Remove existing events, use new event**: Completely removes the presentation currently occupying the timeslot.

• **Interrupt existing events with new event**: Schedules an interrupt in the presentation currently occupying the timeslot. The date field will be split into two columns: The left column shows the primary scheduled presentation in blue; the right column shows the interrupting presentation in green. Primary scheduled presentations can be interrupted with multiple presentations, but interrupting presentations cannot overlap with each other.

4. (Optional) Specify debugging and firmware preferences:

e. Under **Debugging**, you may check one of the following:

• **Enable serial debugging**: The autorun script will output debugging information related to the presentation to the RS-232 serial port (as well as over Telnet and SSH if these features are enabled).

• **Enable system log debugging**: The autorun script will output debugging information related to the presentation to the Log tab in the Diagnostic Web Server.
a. Click **Specify Firmware Update** to indicate what firmware version you want the player to be updated to. The **Firmware Update** window is divided by BrightSign generation. In the section that corresponds to your player model, select a firmware version or **Do not update** and then click **OK**. You can also use the **Update type** dropdown menu to determine the behavior of the firmware update:

- **Standard**: The `.bsfw` update file deletes itself from the local storage once the firmware update process is complete and the player reboots.
- **Different**: The update will only be applied if the version of the `.bsfw` update file does not match the current firmware version of the player. The file is not deleted after the update process is completed.
• **Newer**: The update will not be applied if the current firmware version of the player is newer than the version of the update file. The file is not deleted after the update process is completed.
• **Save**: The `.bsfw` update file is not deleted after the update is applied. The device will only reboot once the storage device containing the update file is removed.

5. Publish the presentation:
   a. Under **Publish**, select a BrightSign player. You can publish to multiple players at once by holding down the **Ctrl** key while clicking each player.
      • If publishing to a new player, click **New unit**. Then click the button. The **Add BrightSign Unit** window will open. Type the IP address of the new BrightSign unit, and click **OK**.
      • If you want to publish to a previously added BrightSign player, click **Networked units**. Select a unit from the list of all networked units. Click to refresh the list.
      • If the Local Web Server of the player is password protected, it will be listed as “Access to [player IP address] denied”. You will be prompted to enter a User name and Password when you attempt to publish to it. Alternatively, you can right click the player and select **Specify User Name / Password**.
   
   b. Click **Publish**.
   
   c. When the **Publish Complete** window opens, click **OK**.

**Note**: When publishing to a new player, the **BrightSign Unit Setup** window will open after you click **Publish**. See [Adding a Player to Your Local Network](#) for more details.
Publishing a BrightWall™ Presentation
To publish a BrightWall presentation, navigate to the Publish tab, choose your desired publishing option, and select BrightWall Presentations in the top left.

Scheduling BrightWall presentations requires the same steps as scheduling standard presentations. Note that BrightWall presentations and standard presentations cannot be placed on the same schedule.

Local Storage
Once you have finished scheduling your BrightWall presentation(s), click the Publish button to bring up the Publish BrightWall window:

- **Publish each screen in a subfolder of a parent folder**: The project and media files for each screen will be published in separate subfolders of the specified parent folder. Use this option if you don’t want to immediately publish to the SD cards of all the players in the video wall while in BrightAuthor. This option is also useful if you’d like the entire BrightWall presentation contained in a package that can be easily transported between directories, computers, etc.

- **Publish each screen individually**: You will be given a separate prompt for publishing the project files of each screen. Use this option if you want to immediately set up the SD cards for players in the video wall.

BrightSign Network
Select a BSN BrightWall Group using the dropdown menu under Select BrightWall Group to Schedule. The BrightWall configuration file assigned to the group determines which presentations are available in the BrightWall Presentations list: A BrightWall presentation will not appear in this list if it uses a different configuration file from the group.

If you haven’t created a BrightWall Group yet, navigate to the Manage > Status tab to create one. Once you’ve created a BrightWall Group, return to the Publish > BrightSign Network tab and click the button to Refresh the dropdown list. See the Creating a BrightWall on the BrightSign Network section for a complete outline of the BSN BrightWall process.

Once you’ve selected a BrightWall Group, click Publish Schedule to assign the schedule to the BrightWall Group.
Local Network
Once you have finished scheduling your BrightWall presentation(s), click the **Publish** button to bring up the **Publish BrightWall** window:

1. Select a networked player next to each **Screen Name**. Make sure the specified players correspond to the correct screen-location numbers in the video wall. The screen-location numbers are shown in the screen layout window of the BrightWall presentation.

2. Click the **Refresh** button to refresh the dropdown lists of players currently active on the local network.
3. Click the **Add** button to add new networked players to the dropdown lists of players on the local network.
4. Once all of the target players have been specified, click **Publish** to publish the video wall.

Simple File Network
Once you have finished scheduling your BrightWall presentation(s), click the **Publish** button to bring up the **Publish BrightWall** window:

- **Publish each screen in a subfolder of a parent folder**: The project and media files for each screen will be published in separate subfolders of the specified parent folder. You will then need to upload the parent file to your file server.
CHAPTER 9 – CUSTOMIZING PRESENTATIONS

This chapter will describe the different ways you can customize your presentations.

Setting Zone Properties
Whether you’re creating a single-zone or a multi-zone presentation, you can customize the settings for each zone.
  
  1. Open a presentation project by clicking **File > Open Presentation**.
  2. Click on the **Edit** tab and then the **Playlist** subgroup.
  3. Below **Zone** in the upper-left portion of the screen, click the zone whose properties you want to change.
  4. Click **Zone Properties**. Different options will appear depending on the type of zone that is selected.
  5. Click **OK**.
  6. Repeat steps 2 – 4 for each zone you want to edit in your presentation.

Editing Video Only and Video or Images Zones

4K242, XD232, XD230, HD222, HD1022, HD120, HD220, HD1020

- **View mode**: Use the dropdown list to specify a setting for videos.
  - **Scale to fit**: Scales the video to fill the screen without maintaining the aspect ratio. The video may appear stretched.
  - **Letterboxed and centered**: Centers the video and adds black borders on the top and bottom. The aspect ratio is maintained.
  - **Fill screen and centered**: Centers the video and fills the screen. The aspect ratio is maintained.

- **Audio Output**: Enables or disables the Analog and HDMI audio outputs for the zone.
  - **Pass through**: Supplies the un-decoded audio signal through the HDMI connector. Use this option if the zone audio (for example, AC3 Dolby Digital) is being decoded on an external device.
  - **PCM audio**: Supplies the decoded audio signal through the HDMI connector.
• **Audio Mixing**: Sends the stereo, left-only, or right-only audio signal.
• **Image mode**: Use the dropdown list to specify a setting for images.

**Note**: *This option also appears when editing Images zones, but not when editing Video Only zones.*
  - **Center Image**: Centers the image without scaling. This may result in cropping if the image is too large.
  - **Scale to Fit**: Scales the image to fit the zone. The image is displayed as large as possible while keeping the correct aspect ratio.
  - **Scale to Fill and Crop**: Scales the image to completely fill the zone while maintaining the aspect ratio.
  - **Scale to Fill**: Scales the image to fill the zone without maintaining the aspect ratio.
• **Initial volume (Video)**: Sets the initial volume for audio files (0-100).
• **Initial volume (Audio)**: Sets the initial volume for video files (0-100).
• **Minimum Volume**: Sets the minimum volume for the zone (0-100).
• **Maximum Volume**: Sets the maximum volume for the zone (0-100).

**Note**: *The Maximum Volume setting will be overridden by other volume settings in a presentation, including the Initial Volume setting for the zone and volume commands attached to events or states.*

4K1042, 4K1142, XD1032, XD1132, XD1030, XD1230, LS422

• **View mode**: Use the dropdown list to specify a setting for videos.
  - **Scale to fit**: Scales the video to fill the screen without maintaining the aspect ratio. The video may appear stretched.
  - **Letterboxed and centered**: Centers the video and adds black borders on the top and bottom. The aspect ratio is maintained.
  - **Fill screen and centered**: Centers the video and fills the screen. The aspect ratio is maintained.
• **Audio Output**: Enables or disables the Analog, HDMI, and SPDIF audio outputs for the zone.
  - **Pass through**: Supplies the un-decoded audio signal through the HDMI/SPDIF connector. Use this option if the zone audio (for example, AC3 Dolby Digital) is being decoded on an external device.
  - **Stereo**: Supplies the decoded audio signal through the HDMI/SPDIF connector.
• **Audio Mixing**: Sends the stereo, left-only, or right-only audio signal.
• **Image mode**: Use the dropdown list to specify a setting for images.
Note: This option also appears when editing Images zones, but not when editing Video Only zones.

- **Center image**: Centers the image without scaling. This may result in cropping if the image is too large.
- **Scale to fit**: Scales the image to fit the zone. The image is displayed as large as possible while keeping the correct aspect ratio.
- **Scale to fill and crop**: Scales the image to completely fill the zone while maintaining the aspect ratio.
- **Scale to fill**: Scales the image to fill the zone without maintaining the aspect ratio.

- **Initial volume (Audio)**: Sets the initial volume for audio files (0-100).
- **Initial volume (Video)**: Sets the initial volume for video files (0-100).
- **Minimum Volume**: Sets the minimum volume for audio files (0-100).
- **Maximum Volume**: Sets the maximum volume for audio files (0-100).

**Note**: The **Maximum Volume** setting will be overridden by other volume settings in a presentation, including the **Initial Volume** setting for the zone and volume commands attached to events or states.

### Editing Ticker Zones

- **Number of lines**: Set the number of lines of text in the Ticker zone.
- **Time to display each line**: Set how long each line displays in the Ticker zone (in seconds).
- **Rotation**: Use the dropdown list to select the angle of text in the Ticker zone.
- **Alignment**: Use the dropdown list to set whether text is left aligned, right aligned, or centered in the Ticker zone.

**Note**: If you’re using a right-to-left language (such as Hebrew or Arabic) in your ticker zone, the right/left alignment settings will be inverted. For example, setting a ticker zone with an Arabic RSS feed to “Right aligned” will actually align the text to the left side of the zone.

- **Text appearance**: Specify how the text will appear on screen:
Chapter 9 – Customizing Presentations

- **Animated**: Text is placed on screen from left to right (similar to a Teletype style ticker).
- **Static Text**: Lines of text appear without any animation.
- **Scrolling**: Text scrolls across the screen from right to left (similar to a news or stock ticker). If this option is selected, the **Number of Lines** parameter will be limited to 1 and the **Time to Display Each Line** parameter will have no effect.

  **Note**: Scrolling text is only available on 4Kx42, XDx32, XDx30, and HDx22 models.

- **Foreground text color**: Click **Choose** and select a color for text in Ticker or Clock zones.
- **Background text color**: Click **Choose** and select the color behind text in Ticker or Clock zones.
- **Transparency**: Set the transparency of the Background text color in Ticker or Clock zones.
- **Font**: Click **Browse** and set a font for text in Ticker or Clock zones. You can use any TrueType font. Click **Reset to System Font** to reset the font.

**Advanced**: Click the **Advanced** arrow to reveal the following options:

- **Background bitmap**: Click **Browse** to navigate to and select a file for a background image. Click **Yes** or **No** to determine whether you want to stretch the image to fill the zone. You can add a background bitmap to Ticker or Clock zones.
- **Safe text region**: Define the location (X,Y fields) and size (Width, Height fields) of the text region within the zone.

**Editing Audio Only and Enhanced Audio Zones**

Audio Only zones allow you to play audio files using a standard or interactive playlist. Enhanced Audio zones provide similar functionality, but allow cross-fading between audio files: Fading occurs from silence at the beginning of the audio playlist and to silence at the end of the audio playlist; cross-fading occurs between audio files.

**Note**: Cross-fading will not work in Enhanced Audio zones if the audio tracks use different sampling rates (for example, if the first file is sampled at 48kHz and the second is sampled at 44kHz).
• **Audio Output**: Choose to output audio via **HDMI**, **Analog Stereo**, and/or **SPDIF**. Note that analog and SPDIF outputs are only available on certain models.
  
  o **Pass through**: Supplies the un-decoded audio signal through the HDMI/SPDIF connector. Use this option if the zone audio (for example, AC-3 Dolby Digital) is being decoded on an external device.
  
  o **Stereo**: Supplies the decoded audio signal through the HDMI/SPDIF connector.

• **Audio Mixing**: Sends the stereo, left-only, or right-only audio signal.

• **Initial Volume**: Set the initial volume for audio files (0-100).

• **Minimum Volume**: Sets the minimum volume for audio files (0-100).

• **Maximum Volume**: Sets the maximum volume for audio files (0-100).

**Note**: The **Maximum Volume** setting will be overridden by other volume settings in a presentation, including the **Initial Volume** setting for the zone and volume commands attached to events or states.

• **Fade (in seconds)**: Sets the duration of cross-fading between audio files, as well as the fade in and fade out durations at the beginning and ending of a playlist.

**Editing Images Zones**

• **Image mode**: Use the dropdown list to specify a setting for images.

**Note**: *This option also appears when editing Images zones, but not when editing Video Only zones.*

  o **Center Image**: Centers the image without scaling. This may result in cropping if the image is too large.
  
  o **Scale to Fit**: Scales the image to fit the zone. The image is displayed as large as possible while keeping the correct aspect ratio.
  
  o **Scale to Fill and Crop**: Scales the image to completely fill the zone while maintaining the aspect ratio.
  
  o **Scale to Fill**: Scales the image to fill the zone without maintaining the aspect ratio.

**Editing Clock Zones**

• **Rotation**: Use the dropdown list to select the angle of text in the Ticker zone.

• **Foreground text color**: Click **Choose** and select a color for text in Ticker or Clock zones.

• **Background text color**: Click **Choose** and select the color behind text in Ticker or Clock zones.
• **Transparency**: Set the transparency of the Background text color in Ticker or Clock zones.
• **Font**: Click **Browse** and set a font for text in Ticker or Clock zones. You can use any TrueType font. Click **Reset to System Font** to reset the font.

**Editing Background Image Zones**
You cannot click **Zone Properties** for a Background Image zone. Choose a background image by selecting the Background Image Zone and dragging a file to the playlist area. If you only want a background color (instead of an image), do not add a Background Image zone. The background screen color can be changed in the **Presentation Properties** window. See [Chapter 11 > Presentation Properties](#) for details.

**Importing and Exporting**
There are three types of import/export actions available from the **File** menu: Export Presentation, Import/Export User Variables, and Import/Export User Events.

**Export Presentation**
Exporting a BrightAuthor presentation makes it easier to transfer that project between different PCs and versions of BrightAuthor. Navigate to **File > Export**… and select a folder for export. All relevant presentation files, including media files and user defined events, will be placed in the target folder.

**Import/Export User Variables**
Use these actions to transfer the **User Variable** set of one presentation to another. This saves time when you are creating multiple presentations that use the same set of User Variables. The User Variable set is exported as a `.buv` file, which is also an editable `.xml` document.

Note that importing networked User Variables to a new presentation does not import any Data Feeds to which those variables are linked. If you would like to import networked User Variables, you will need to recreate the feeds in the **Presentation Properties > Data Feeds** tab and reassign them to the variables.
Import/Export User Events
These actions allow you to transfer User Defined Events between presentations. This is useful when creating multiple presentations that use many of the same or similar events.

RF Channel Scanning
Before you can use the RF In state to display live video, you will first need to perform a channel scan. You can perform a channel scan either as an independent action (similar to setting up a player) or as a state in an interactive presentation. The user interface for the Scan Setup window is the same for both methods. See Chapter 3 > Tuner Scan for more information about using channel scanning in an interactive presentation.

1. Navigate to Tools > Setup RF Channel Scan.
   a. **Channel Map**: Select QAM, ATSC, or ATSC and QAM (consult your service provider for details).
   b. **Modulation Type**: Select QAM 64, QAM 256, or QAM 64 and QAM 256 (consult your service provider for details).
   c. **First RF Channel** (optional): You can choose to limit the range of the channel scan by selecting the first channel to scan.
   d. **Last RF Channel** (optional): You can choose to limit the range of the channel scan by selecting the last channel to scan.

   **Note**: Each channel takes approximately one second to scan. Specifying upper and lower limits will reduce the amount of time it takes to perform the scan. You should only use these two options if you are familiar with the channel map of the cable source.

2. Click OK and write the channel scan settings to an SD card or USB drive.
3. Power off your BrightSign XD1230.
4. Insert the SD card or USB drive into the player and power it back on. The progress of the channel scan will be displayed on screen.
5. Once the scan is complete, the channel settings will be written to the internal registry of the player (i.e. the non-removable storage). You can now use the RF In state to tune to any virtual channels that were detected in the channel scan.

Publishing Channel Scan Results
If you are connecting multiple XD1230 players to the same cable source, you can transfer the results of a channel scan from one player to another during the setup process.

1. After performing a channel scan, reinsert the SD card or USB drive into your PC.
2. In BrightAuthor, navigate to Tools > Setup BrightSign Unit.
3. Specify device settings as desired (see Chapter 2 – Setting up BrightSign Units for more details).
4. Under RF Channel Scan Data (optional), click browse and locate the “ScannedChannels.xml” file in the SD card or USB drive directory. Click Open.
5. Publish the setup files to the player as outlined in Chapter 2. The player will now have the same channel configuration as the original XD1230.

Presentation Tree View
The Presentation Tree View feature allows you to view a presentation as a set of expandable/collapsible zones, states, events, and commands. You can use this feature to easily navigate all state information in a presentation without double-clicking numerous icons and navigating through tabs. You can access this feature by navigating to File > View Presentation Tree.
You can edit a range properties that apply to the presentation that is currently open. To edit presentation properties, open a presentation project and navigate to File > Presentation Properties.

**Main**

Set any of the following:

- **Connector type**: Use the dropdown list to indicate the type of connector you are using for your display (HDMI, VGA, or Component).
- **Screen resolution**: Use the dropdown list to set a resolution supported by your display.
- **Background screen color**: Click Choose to select a background color that appears behind your zones.
- **Language**: Use the dropdown list to select a language for your presentation.
- **RF channel scan file**: Choose an RF channel scan XML file to associate with the presentation. All RF In states in the presentation will use this channel scan file. If you specify a different channel scan file in an RF In state, the RF
channel scan file in Presentation Properties will change as well.

**Note:** A player can only contain a single RF channel manifest at any one time. Playing the presentation associated with the RF channel scan file will overwrite any previous RF channel configuration on the player. Furthermore, if you use a Tuner Scan state to create a new RF channel manifest while the presentation is running, the RF channel manifest specified in Presentation Properties will be overwritten.

- **Delay schedule change until current media item completes playback:** By default, a player will switch from one scheduled presentation to another at the specified time, without regards to where playback is in the current presentation. Check this box to have the player wait until a media item completes playback to switch to a new scheduled presentation. For multi-zone presentations, the first media item to complete playback, no matter the zone, will trigger the scheduled presentation change.

**I/O**

Click **Input** or **Output** next to each GPIO port to indicate whether the port is sending or receiving information.

**Interactive**

Set any of the following:

- **Serial**: Most standard RS-232 serial devices enumerate on port 0. If you are connecting a USB-serial device (such as a GPS receiver), it will enumerate on port 2. You will also need to check the GPS Receiver box for USB-serial GPS devices to work with the player. For each serial port, you can specify the following: **Baud rate**, **Data bits**, **Parity**, **Stop bits**, **Protocol**, **Send EOL**, and **Receive EOL**. Check the **Invert Signals** checkbox to invert the send pin and receive pin of the serial port.

- **UDP**: Set the **UDP Destination Address** by entering a **Specific IP Address** in dotted quad form or by selecting **All devices on the local subnet**. You can also specify the **UDP Destination Port** (for triggering other networked devices via the Send UDP command) and **UDP Receiver Port** (for triggering UDP Input events on the player).

- **Synchronization**: Check the **Enable enhanced synchronization** box to use a player synchronization scheme similar to the BrightWall™ feature. When this feature is enabled, interactive presentations using Synchronization events can be easily linked by a master/slave scheme: The presentation sending a Synchronize command acts as
the master, while the presentation(s) using Synchronize events act as slaves. Synchronize events associated with slave presentations will trigger within a few milliseconds of the Synchronize command associated with the master presentation.

- **Master**: The presentation sending Synchronize commands. A master presentation cannot contain Synchronize events (i.e. you cannot chain one master presentation to another).
- **Slave**: The presentation receiving Synchronize commands via Synchronize events.
- **Domain**: This number needs to be unique for each set of master/slave presentations on the network. This will ensure that multiple groups of synchronized presentations can operate on the same local network without synchronization messages interfering with each other.

- **Touch**: Select a cursor option to determine whether the cursor is always hidden, always visible, or present only if there is more than one touch region on the screen (i.e. **Auto display cursor**). Check the **Flip coordinates** checkbox to reverse the coordinates of the check screen. Use this option only if the touch screen coordinates appear to be reversed.

**Buttons**

Use the dropdown list to select the type of button panel (BP200 or BP900) you wish to configure. The A, B, and C letters after the button panel number specify which device is enumerated first; this is only applicable if you are connecting more than one BP device of the same model number to the player.

Choose one of the following:

- **Automatically configure which buttons are enabled**: Only buttons that are configured with BP200/BP900 events in the presentation will be enabled. All other buttons will not light up or react to button presses.
- **Specify which buttons are enabled**: Only the specified buttons will be enabled regardless of whether there are BP200/BP900 events in the presentation that are configured to use them.

**Important**: A BP200/BP900 event set to the **Any Button** option will only react to button numbers enabled using the above options.
Audio

Set any of the following:

- Set the **Minimum Volume** and **Maximum Volume** for the **Audio** output (0 – 100).
- Set the **Minimum Volume** and **Maximum Volume** for the **HDMI** audio output (0 – 100).
- Set the **Minimum Volume** and **Maximum Volume** for the **SPDIF** audio output (0 – 100).

**Note:** The **Maximum Volume** settings for **Audio**, **HDMI**, and **SPDIF** will be overridden by other volume settings in a presentation, including the **Initial Volume** setting for a zone and volume commands attached to events or states.

![Presentation Properties](image)

Media List

Set any of the following:

- **Return to start after inactivity**: Check the **Yes** box to set Media Lists to return to the start of the list after a designated period of inactivity.
- **Inactivity timeout (seconds)**: If you checked **Yes** above, type a number in the text field to specify the period of inactivity before Media Lists restart.

Autorun

If you would like to specify a different autorun file for the presentation, click **Select custom Autorun**. Click **Browse** to locate and select the autorun file.
Click **Add Script Plugin** to add a custom script to your BrightAuthor presentation. Script plugins are custom pieces of BrightScript code that extend the functionality of BrightAuthor. Please see the [Using BrightAuthor Plugins and Parsers](#) tech note for more information.

**Note:** *Because you must edit custom autoruns every time the firmware version changes, we recommend using script plugins (which are nearly immune to changes in the system software) for advanced presentation development.*

![Add Script Plugin](image)

**Image Cache**

A list of all media files in your playlist is displayed here. Check the boxes to store certain files in an image cache for faster loading.

**Variables**

Use this tab to configure the device web page, enable Media Counters, and create User Variables.
Device Web Page Display
The device web page allows you view and edit User Variables over your local network. In order to display a standard or custom device web page, you must first enable the Local Web Server during player setup.

- **No device web page**: Choose this option if you would like to enable the Local Web Server but do not want the User Variables webpage to be accessible.
- **Standard device web page**: The default device web page lists all User Variables and their default/current values on a sparsely formatted page.
- **Custom device web page**: This option allows you to use a device web page with custom appearance, formatting, and functionality. See the Creating a Custom Device Web Page tech note for more information.
- **Alphabetize variable names**: This option will determine how variable fields are ordered on the device web page. If this box is checked, the variables will be listed alphabetically, rather than by order of creation.

Media Counters
Media Counters are values that record how many times a file has played in a presentation. They can be viewed in Live Text or extracted from the BrightSign player via USB. Media Counters are not recorded unless you check the **Automatically create media counter variables** checkbox in the Variables tab. When enabled, Media Counters are recorded for every file in the presentation. However, in Live Text, only Media Counters that are individually added can be viewed. For details on retrieving all Media Counters via USB, see Using advanced tools.

User Variables
User Variables are customizable values that can be used in **Commands** or displayed in **Live Text**. When used in Live Text, User Variables display the current value of the variable. This value can continually change during a presentation. The value can also be changed during a presentation using the **Set Variable** or **Reset Variable** commands.

Check the box labeled **Reset variables to their default value on presentation start** if you would like all variables to be reset to their current default values whenever the presentation begins. Use the **Update frequency for networked variables** dropdown menu to determine how often networked User Variables should be refreshed by Data Feeds that are assigned to the presentation.
Adding User Variables

- **Name**: Enter a unique name for the User Variable.
- **Default Value**: This is the value of the User Variable if it is not modified. Whenever a User Variable is reset (via the Reset Variable command), it will return to this default value.

**Note**: Setting a new Default Value and republishing the presentation will not set the value of that variable to the new default value. Instead, the presentation will retain whatever value it has already been assigned. To set variables to their new default values, you will need to check the box labeled **Reset variables to their default value on**
**presentation start** and republish the presentation. To set a single variable to its new default value, use the **Reset Variable** command after republishing.

- **Access**: Select **Shared** to make the User Variable accessible to other presentations scheduled on the player. If two presentations use a variable with the same name, the value of the variable with the **Shared** attribute will be used for the variable with the **Private** attribute.

- **Type**: There are three types of User Variable.
  - **Local**: Local variables can be changed with the **Set Variable/Reset Variable** commands or via the **Local Web Server**. They can also be set with properly formatted serial and UDP commands.
  - **Networked**: Networked variables are set and modified using **Data Feeds** (RSS, Live Data, or Dynamic Playlists). To create a networked User Variable, you must first specify the Data Feed it will be linked to. Select the desired Data Feed from the dropdown list and click **Validate** to ensure the link is operational and has correct formatting for an RSS feed.
    
    **Note**: Every RSS entry has a `<title>` tag and a `<description>` tag: use the `<title>` tag to designate the name of the User Variable being modified; use the `<description>` tag to change the value of the User Variable.
  - **System**: System variables are not determined by the user, but by independent system parameters, such as firmware/autorun version number, IP address, RF channel count, and various types of EDID (extended display identification data) information received from the display over HDMI.
    
    **Note**: Displays will often lack a complete set of EDID parameters. Make sure to test the EDID values of a certain model before using them in a presentation.

To delete a User Variable, click the X beside the appropriate variable. You can also use the **Delete Unused User Variables** button to delete all user variables that are not currently in use by Live Text states, commands, events, conditional targets, etc.

**Integrating User Variables with Commands**

User Variables can be used in the following commands: Set Volume, Increment Volume, Decrement Volume, Send UDP, Serial-send string (EOL), Serial-send string (no EOL), Serial-send byte, Serial-send bytes (comma separated),
Synchronize, Send Zone Message, Link Zones, GPIO On, GPIO Off, GPIO Set State, BrightControl – Send Ascii String, BrightControl – Philips Set Volume, Pause.

For example, if you add a Set Volume command to your presentation and use a static value like 50, the volume will always be set to 50 when the command occurs. If you use a User Variable instead, the volume will be set to the current value of the variable, which could be any value based on Set Variable commands and any number of other factors.

To utilize a User Variable in a command, first add the desired command (see Commands for details). In the Parameters field, type the exact name of the variable between two dollar signs on each side (e.g. “$$variable1$$”). BrightAuthor will not recognize the variable without these dollar signs.

**Data Feeds**

Use this tab to create and edit data feeds, which you can use when creating Live Text, RSS, MRSS, and Dynamic Playlist states. Data feeds can also be used to generate Networked User Variables. Click Add Live Data Feed to bring up the feed-creation window:

- **Feed Name**: Give the data feed a name. You will be able to locate the data feed by this name when you are creating a Live Text element, specifying an RSS, MRSS, or Dynamic Playlist feed state, or creating Networked User Variables.

  **Note**: BrightAuthor does not prevent you from inputting an RSS feed URL into an MRSS state (or vice versa); however, the presentation will fail to display any content if it is published in this state.

- **Url**: Enter the web address of the RSS or MRSS feed into this field. If you want the presentation to retrieve a feed from an RSS formatted text file on the SD card, use the “file:///path” URL format (e.g. “file:///filename.xml”).

- **Live Data Feed**: If you have a BrightSign Network subscription, you can publish RSS feeds to the BrightSign Network servers using the Live Data Feed feature. See the Live Text FAQ for instructions for creating Live Data Feeds in the BrightSign Network Web UI and using them in BrightAuthor.

- **Live Media Feed**: If you have a BrightSign Network subscription, you can publish MRSS feeds to the BrightSign Network servers using the Live Media Feed feature.
• **Dynamic Playlist**: If you have a BrightSign Network subscription, you can use Dynamic Playlists as Data Feeds.

• **Download content specified in data feed**: Check this box to have the player download and store media files specified in the Data Feed. You can then playback the media files using a Media List or Play File state. Each media item must be specified as a download URL in a separate Value field of the BSN Data Feed (or the <description> fields of an RSS feed). Note that this is different from the download and playback features of MRSS feeds and Dynamic Playlists.

![Data Feed Configuration Window](image)

• **Refresh**: If you have recently created or renamed Dynamic Playlists or Live Text feeds using the BrightSign Network, click this button to update the content in the Live Data Feed and Dynamic Playlist dropdown lists.

• **Data feed content usage**: Determine how you wish to utilize the data downloaded from the feed:
  - **Text**: The feed will be displayed as text in a Ticker zone or Live Text feed.
o **MRSS Feed**: The feed will be used to download and play media in a Media RSS or Live Text state.

o **Content for Image List, Video List, Audio List, or Play File**: The player will download and store media files specified in the Data Feed. You can then play back the media files using a Media List or Play File state. Each media item must be specified as a download URL in a separate Value field of the BSN Data Feed (or the <description> fields of an RSS feed). Note that this is different from the download and playback features of MRSS feeds and Dynamic Playlists.

- **Validate**: Click this button to ping the web address you entered in the **Url**, **Live Data Feed**, or **Dynamic Playlist** field. Use this feature to check whether you entered the address of your RSS feed correctly.

- **Update Interval**: Use the dropdown list to specify how often you want the content of an RSS feed to be refreshed using the provided URL.

**Important**: *If the amount of time it takes to cycle through all the entries in the Data Feed is longer than the Update Interval, the presentation will never display all items in the feed. Make sure to specify an Update Interval that is long enough to display the entire feed.*

- **Plugin Script**: This is an advanced feature: You may optionally choose to have the RSS feed parsed by a piece of customized BrightScript code. This occurs after the feed is retrieved from the network and before it is provided to Live Text and other presentation features. To add a plugin, specify the location of the file that contains the BrightScript code by clicking the **Browse** button.

**Note**: *The parser file must have a .brs extension.*

- **Parser Function Name**: Enter the name of the subroutine that parses the RSS feed. Ensure that this name matches the name of the BrightScript subroutine; otherwise, a runtime error will occur during presentation playback.

**HTML Sites**

**Note**: *If you want to use the application cache for HTML5 sites (which allows the player to cache remote HTML content on the local storage), you will need to enable the Limit storage space by function option in Edit > Preferences > Storage. Note that an HTML5 site must be configured properly for caching to work.*
Use this tab to add HTML5 sites to your presentation. You must add sites in this tab before you can use HTML5 states in the Interactive Playlist. Click the Add HTML Site button and specify the following:

**Note:** You must use a WebKit-based browser (e.g. Chrome, Safari) to access the JavaScript console.

- **HTML site name**: The designation of the HTML5 site. You will use this name to select the site when creating an HTML5 state.
- **Local Content**: Select this option if you plan on displaying HTML5 content using page and media files located on the local storage of your computer. Click the **Browse** button to locate the .html file that you wish to display.
- **URL**: Select this option if you wish to play an HTML5 page from a web address.

**Note:** BrightSign players are not designed to be used as general-purpose web browsers. Many web pages have elements that will not display correctly on a BrightSign player. Make sure to thoroughly test a web page before using it as digital signage.
• **Query string (optional):** Enter a query string to be appended to the site URL using the following format: "http://www.example.com/over/there?my_query_string". You can specify the query string as either a static value or a User Variable. To utilize a User Variable, type the exact name of the variable between two sets of dollar signs (e.g. "$$variable1$$"). BrightAuthor will not recognize the variable without these dollar signs.

**Settings**

• **Enable Javascript console:** Check this box to enable the JavaScript console for HTML sites. To access the JavaScript console while the player is running, open a web browser on a device connected to the same local network as the player. Then, enter the IP address of the player, followed by port number 2999 (for example, “http://10.1.0.154:2999”). You will be able to inspect any page added to the HTML Sites tab, not just those currently running.

**Automatically generate user variables for the selected data feeds**

You can use Data Feeds to populate a set of User Variables for HTML5 pages. The User Variables can then be retrieved using JavaScript. Use the `<title>` tag of the Data Feed to specify the Name of a variable and the `<description>` tag to specify its default value.

• **Access:** Select Shared to make the User Variable accessible to other presentations scheduled on the player. If two presentations use a variable with the same name, the value of the variable with the Shared attribute will be used for the variable with the Private attribute.

• **Plugin Script:** This is an advanced feature: You may optionally choose to have the feed parsed by a piece of customized BrightScript code. This occurs after the feed is retrieved from the network and before it is used to provide User Variable values to the HTML page. To add a plugin, specify the location of the file that contains the BrightScript code by clicking the Browse button.

• **Parser Function Name:** Enter the name of the subroutine that parses the feed.

**Switch Presentations**

Use this tab to publish additional presentations to the SD card along with the primary presentation. You can use the Switch to Presentation command to switch to another presentation while a presentation is running.
**Files**

Use this tab to publish additional files to the SD card along with the presentation. This feature is useful if you frequently publish files that are not used in the presentation itself (for example, a media file being utilized by a custom script) and you want to automate the process of publishing both presentation files and custom files.

**UDP**

This tab provides an easy way to keep track of all UDP events within an interactive presentation. Note that you can edit the **Label** and change the **Show in BrightSign App** option within individual **UDP Input events** as well.
CHAPTER 11 – EDITING PREFERENCES

Whenever you create a new project, various presentation settings are based on the default settings. If you often use the same set of properties, you can save time by changing the default property settings to what you use most often.

Keep in mind that changing default settings in the Video, Images, Interactive, Clock, and Live Text tabs does not adjust values in the current project. The Networking, UI, Backups, and Storage tabs are related to other aspects of the publishing process, and will therefore apply to the current presentation as well. To edit default settings, navigate to Edit > Preferences on the menu bar.

**Video**
- **Volume**: Specify a value between 0 and 100.
- **Live video – time on screen**: Set a default period for live videos to remain on screen (in seconds).

**Images**
- **Slide transition**: Use the dropdown list to set an effect for image transitions.
- **Slide delay interval**: Set how long each image displays (in seconds).

**Interactive**
Set a default timeout period for media files (in seconds).

**Clock**
Use the dropdown list to link the date and time format to a language. To customize the format, click **Customize** to open the **Clock Localization** window.
• **Date**: Use the **Edit** field to customize the date format on the player (refer to the chart of terms for different abbreviation styles). Use the **Preview date** button to see an example of how the date format will look. You can also customize how months and days are displayed in both **Short** and **Long** form.

• **Time**: Use the **Edit** field to customize how time is displayed on the player (refer to the chart of terms for different measurements). Use the **Preview time** button to see an example of how the time format will look. You can also customize how the AM and PM abbreviations are formatted.

**Note**: A BrightSign Network account can only have one date and time setting: Changing the date/time format for one presentation, and then uploading it to the BrightSign Network, will change the date/time format for all presentations on your account. Similarly, a standalone player can only have one date/time format, even if there are multiple presentations scheduled on the player.

**Live Text**

• **Alignment**: Use the dropdown list to set whether Live Text is left aligned, right aligned, or centered.

• **Foreground text color**: Click **Choose** and select a color for Live Text.

• **Background text color**: Use the checkbox to determine whether you want to include a background text color for text fields. Click **Choose** and set a default color for the backgrounds.

• **Transparency**: Drag the bar to set the transparency for background text colors.

  **Note**: Transparency does not appear in the Live Text image preview. You will need to publish the presentation to a BrightSign player to view the level of transparency.

• **Font**: Click **Browse** and set a font for Live Text. You can use any TrueType font. Click **Reset to System Font** to reset the font.

• **Font size**: Click **Automatic** or **Fixed point size** to enter a value for Live Text font size (1-500).

  **Note**: Changes to the default text preferences apply only to Live Text states created after presentation preferences are saved; these changes are not applied to preexisting Live Text states.
Networking
Check the boxes to enable/disable the following: BrightSign Network, Local Networking, Bonjour, and Simple File Networking.

*Note*: If you are publishing with Local Networking and are not seeing your BrightSign players on the network, disabling Bonjour can help.

Proxy Server
Check the Use Proxy Server box if BrightAuthor must communicate with the Internet through a proxy server. Enter the Address and Port of the proxy server. If the proxy server requires authentication, you will be prompted to enter login credentials. If the proxy uses a Windows domain for authentication, you will also need to specify a domain name.

UI
- **Publishing**: Check or uncheck these boxes to change the behavior of BrightAuthor while publishing:
  - Show file overwrite dialog?: Displays a dialog box asking whether you want to overwrite preexisting files when publishing a presentation.
  - Copy and replace duplicate files when publishing locally?: Overwrites media files with the same name when publishing locally.
  - Show Save Schedule dialog?: When you exit the Publish tab, displays a dialog box asking if you would like to save the schedule as a separate file. You can then use this schedule file with any presentation by navigating to Schedule > Open while in the Publish tab.
- **Save properties**: Check the Show Save Properties dialog box to display a dialog box whenever you exit the Presentation Properties window and have made changes to the settings. The dialog box will ask you whether you want to apply the new settings to the current presentation or to all future presentations in addition to current presentation.
- **Content Update Password Cleared Warning**: Check this box to display a dialog box whenever you publish a content update that will clear the Content Update Password.
- **Transitions**: Use these options to specify the display behavior of transitions in the interactive playlist.
Display Mode: Specifies how BrightAuthor draws event connections between states in the interactive playlist area.

- **Automatic**: BrightAuthor will attempt to use the best display mode for the current situation.
- **Always display line**: Displays event lines between states.
- **Always display label**: Displays numbered event labels that show connections between states.
  - **Label Location**: Displays the numbered event labels either on the **Bottom** or on the **Right** of states.

**Backups**

- **Automatically backup BrightAuthor presentation files**: Check this box to enable automated saving of BrightAuthor presentation files. Specify how often you want a backup to occur.
- **Backup a maximum of this number of backups**: Specify how many backup copies of a single presentation can exist. Once this limit is reached, BrightAuthor will begin overwriting backup copies beginning with the oldest file.

**Storage**

Checking the **Limit storage space by function** box allows you to divide the presentation storage device into different segments. You can then allot maximum sizes to those segments to ensure that a certain type of data does not take up too much space on the storage device.

Note that, if you select **Specify absolute size**, it is possible to specify a combined set of segments that is larger or smaller than the absolute size of your storage device. If you select **Specify percentages**, you will need to ensure that the percentages add up to 100% (which is equivalent to the absolute size of the storage device).

The segment types are specified as follows:

- **Published data**: The maximum size allotted to all presentation and content files that are written to the storage device during the publish process. This includes audio, video, images, text, and HTML content files.
- **Dynamic data**: The maximum size of all dynamic content, including Dynamic Playlists and MRSS feeds. When this segment runs out of space, dynamic content files will be deleted to create space, starting with the oldest files first.
- **HTML data**: The maximum size of the HTML application cache.
- **HTML local storage**: The maximum size of all JavaScript variables and data.
CHAPTER 12 – MANAGING YOUR NETWORK

You can use BrightAuthor to manage the players on your BrightSign Network account, as well as the players on your local network.

**Status**
The **Status** window allows you to view the status of players and groups on your BrightSign Network account. To use the Status window, you must first sign into BrightSign Network by clicking **Tools > Sign in to BrightSign Network**.

**Groups**
You can use Groups to distribute presentations to a specific set of BrightSign players. **Publishing** a presentation to a group delivers it to all BrightSign players within that group. BrightAuthor includes two default groups: **Default** and **LocalTest**. However, you can create additional groups as needed:

- **To create a group**: Click **Add Groups** (beneath the **Groups** window). Type a name for the group, and then click **OK**.
- **To delete a group**: Right-click a group, and then click **Delete**.
- **To move a device to a different group**: Click the arrow for the group that contains the device. Then click the device and drag it to the desired new group.

Click the arrow beside a group to view details about players within that group:

- **Status**: A range of colors (green, yellow, red) used to indicate the status of a BrightSign player. Please see this [FAQ](#) for more information on what each color means.
- **Name**: The name of the player.
- **Description**: The description given to the player.
- **Active Presentation**: The name of the current presentation being run on the player.
- **Last connection**: The last time the player checked in with the BrightSign Network servers.
• **Checks for content every**: The interval for synchronizing with the BrightSign Network servers to determine if there is new content to download. This interval can be modified by right-clicking the player and selecting **Edit**.

Right-click a player to access options associated with it:

• **View Remote Snapshots**: Opens a window that allows you to view Remote Snapshot images taken by the player. When the window opens, the latest snapshot will be displayed. Past snapshots are displayed as thumbnails below. Double click a snapshot thumbnail to view it as a full size image. The number, quality, and frequency of snapshots is determined during the **Unit Setup** process.
Note: The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.

- **Refresh**: Click this button to get the most up-to-date snapshot(s) from the player.
- **Date/Time**: The timestamp indicating when the snapshot was taken. The timestamp is formatted as follows: `yyyy:mm:dd hh:mm:ss`
- **Serial Number**: The serial number of the player taking the snapshot.
- **Model**: The model number of the player taking the snapshot.
- **Firmware**: The firmware version of the player taking the snapshot.

- **Edit**: Opens the Edit Unit window, which allows you to edit many of the parameters set during the Unit Setup process, including the name/description, group, and Remote Snapshot settings.
- **Delete**: Removes the player from the BrightSign Network. The player will continue playing content, but it can no longer be updated or monitored. The only way to get the player back on the BrightSign Network is to perform the Unit Setup process again.
- **Info**: Provides details about the player hardware, software, networking, and subscription status.
- **Download Progress**: Displays the progress of the most recent content synchronization process.

(Optional) Sort the list by clicking the column you want to use as the sorting criteria. For example, click the Status column to sort by status, then click it again to switch between ascending and descending order.

**BrightWall Groups**
Use the BrightWall Groups section to manage players that are assigned to BrightWall video walls.

Note that the structure of BSN BrightWall Groups is different from that of standard BSN Groups:

- **Each player is part of a BrightWall**: It has a Number indicating the section of the BrightWall to which it belongs. Screens are numbered by row, starting from the top-left section of the BrightWall (the example diagram to the right shows the numbering of a 4x3 BrightWall).
- **Each BrightWall consists of a number of players**: The Status will only display green if all players in the BrightWall are green or red if all players in the BrightWall are red. If the players are a mix of red, green, or yellow, the Status will display yellow.
Each BrightWall group consists of one or more BrightWall(s): BrightWall(s) within the same BrightWall group use the same Configuration File. This means that each BrightWall group represents a certain BrightWall configuration (for example, a 3x2 video wall using HDMI, with a 3% bezel ratio). Like standard BSN groups, BrightWall(s) within the same BrightWall group are assigned the same schedule.

Note how each BrightWall within a BrightWall group has the same configuration, and how each player can only be assigned to one BrightWall at a time.
Creating BrightWall Groups

To create a BrightWall group, click **Add BrightWall Group** (located below the **BrightWall Groups** window) and enter the following:

- **BrightWall group name**: The name of the BrightWall group
- **BrightWall configuration**: The BrightWall Configuration file that will be associated with the BrightWall group. To add a BrightWall Configuration file to the list, upload a BrightWall presentation that uses the file to the BrightSign Network in the **Create > BrightWall** tab.

Players and BrightWall(s) are added to a BrightWall group during the **Unit Setup** process.

Presentations

The **Presentations** tab allows you to view all presentations, BrightWall presentations, and BrightWall configuration files uploaded to the BrightSign Network.

Click the **Presentations** button to view a list of all presentations uploaded to the BrightSign Network:

- **Active**: A checkmark will be displayed in this field if the presentation is currently assigned to one or more groups. Use the **Current Active Groups** button to view the **Current Active Groups** list.
- **Name**: The name of the presentation
- **Date modified**: The last time the presentation was modified in BrightAuthor or uploaded via the BrightSign Network WebUI

Right-click a presentation to preform an action:

- **Delete**: Removes the presentation from BSN. This action cannot be performed if the presentation is currently assigned to a group.
- **Download**: Downloads the presentation file and assets to the specified folder. You cannot download presentations that were created with the WebUI.
BrightWall Presentations
Click the ☑️ button next to **BrightWall Presentations** to view a list of all BrightWall presentations uploaded to the BrightSign Network:

- **Active**: A checkmark will be displayed in this field if the BrightWall presentation is currently assigned to one or more BrightWall groups. Use the ☰️ button to view the **Current Active BrightWall™ Groups** list.
- **Name (BrightWall Configuration)**: The name of the BrightWall presentation, as well as the configuration file used for that presentation
- **Date modified**: The last time the BrightWall presentation was modified in BrightAuthor

Right-click a BrightWall presentation to perform an action:

- **Delete**: Removes the BrightWall presentation from BSN. This action cannot be performed if the BrightWall presentation is currently assigned to a BrightWall group.
- **Download**: Downloads the BrightWall presentation file, configuration file, and assets to the specified folder.

BrightWall Configurations
Click the ☑️ button next to **BrightWall Configurations** to view a list of all BrightWall configuration files uploaded to the BrightSign Network:

**Note**: *Currently, the only way to upload a BrightWall configuration file to BSN is to upload a BrightWall presentation that uses the configuration file.*

- **Active**: A checkmark will be displayed in this field if the configuration file is being used for one or more BrightWall presentations. Use the ☰️ button to view the **Current Active BrightWall™ Groups** list.
- **Name**: The name of the BrightWall configuration file
- **Creation date**: The date that the BrightWall configuration file was created in BrightAuthor

Right-click a configuration file to perform an action:

- **Delete**: Removes the configuration file from BSN. This action cannot be performed if a BrightWall presentation that uses the configuration file is currently assigned to a BrightWall group.
- **Download**: Downloads the configuration file to the specified folder.
Library
The Library tab allows you to see all content files (images, audio, video) that have been uploaded to your BrightSign Network account. Files with a green check mark are currently active. You can perform any of the following actions:
- Switch between thumbnail and list view by clicking the icons in the upper-right portion of the screen.
- View item info: Right-click an item and click Info. Here you can view the file size, type, date modified, and date uploaded, as well as all presentations and all Dynamic Playlists using the file.
- Delete an item: Right-click a file and click Delete. Keep in mind that you can only delete files that aren’t currently active.
- Refresh the library: Click the Refresh button in the upper-right portion of the screen.

Dynamic Playlist
The Dynamic Playlist tab allows you to view all Dynamic Playlists on your BrightSign Network account, as well as the presentations that contain Dynamic Playlists and the time/date when they were last modified. Dynamic Playlists with a green checkmark are currently part of a presentation. You can perform any of the following actions:
- Delete a playlist: Right-click a Dynamic Playlist and then select Delete.
- View info: Right-click a Dynamic Playlist and then click Info to see when the Dynamic Playlist was last modified, as well as a list of all presentations that contain the Dynamic Playlist.
- Sort the list: You can order the list of Dynamic Playlists by clicking the column you want to use as the criteria. For example, to sort by name, click the name column, then click it again to switch between ascending and descending order.
- Refresh the list: Click the Refresh button in the upper-right portion of the screen.

Live Data Feed
The Live Data Feed tab allows you to view all Live Data Feeds on your BrightSign Network account, as well as the presentations that contain Dynamic Playlists and the time/date when they were last modified. Live Data Feeds with a green checkmark are currently part of a presentation. You can perform any of the following actions:
- Delete a feed: Right-click a Live Data Feed and then select Delete.
• View info: Right-click a Live Data Feed and then click Info to see when the Live Data Feed was last modified, as well as a list of all presentations that contain the Live Data Feed.
• Sort the list: You can adjust the list of Live Data Feeds by clicking the column you want to use as the criteria. For example, to sort by name, click the name column, then click it again to switch between ascending and descending order.
• Refresh the list: Click the Refresh button in the upper-right portion of the screen.

HTML Site
The HTML Site tab allows you to view all HTML sites that have been uploaded to your BrightSign Network account, as well as the presentation that contain the sites and the time/date when they were last modified. HTML sites with a green checkmark are currently part of a presentation. You can perform any of the following actions:
• Delete a site: Right-click an HTML site and then select Delete.
• View info: Right-click an HTML site and then click Info to see when the site was last modified, as well as a list of all presentations that contain the site.
• Sort the list: You can adjust the list of HTML sites by clicking the column you want to use as the criteria. For example, to sort by name, click the name column, then click it again to switch between ascending and descending order.
• Refresh the list: Click the Refresh button in the upper-right portion of the screen.

Local Network
The Local Network tab allows you to perform a number of remote operations on players located on your local network. If Bonjour has been enabled in the Edit > Preferences > Networking tab, then players set up for Local File Networking will be discovered automatically. If Bonjour is not enabled, you can populate the list of players by clicking the Add BrightSign button in the bottom left and entering the IP address of the player.

Note: If you do not know the IP address of your player, you can obtain it by powering up the player without an SD card inserted: The IP address, along with other information about the unit, will be displayed on screen once the unit boots.
To perform an operation, select a player from the list (or select multiple players by holding down the Shift button) and right-click the selection:

- **View Remote Snapshots**: Opens a window that allows you to view Remote Snapshot images taken by the player. When the window opens, the latest snapshot will be displayed. Past snapshots are displayed as thumbnails below. Double click a snapshot thumbnail to view it as a full size image. The number, quality, and frequency of snapshots is determined during the **Unit Setup** process.

  **Note**: The Remote Snapshot feature is not available for the LS422, HD220, or HD1020.

  - **Refresh**: Click this button to get the most up-to-date snapshot(s) from the player.
  - **Date/Time**: The timestamp indicating when the snapshot was taken. The timestamp is formatted as follows: `yyyy:mm:dd hh:mm:ss`
  - **Serial Number**: The serial number of the player taking the snapshot.
  - **Model**: The model number of the player taking the snapshot.
  - **Firmware**: The firmware version of the player taking the snapshot.

- **Remove Unit(s)**: Removes one or more players from the Local Network list. This action only affects the **BrightAuthor UI**; it does not change the settings of players in any way.

- **Show All Units**: Adds back all players that have been removed from the list using the **Remove Unit(s)** command.

- **Info**: Displays information about the selected player, including the **Unit ID** (i.e. serial number), **IP address**, **Model**, **Firmware version**, and **Autorun version**.

- **Specify User Name / Password**: Attempts to access the player to obtain further information about it. This action should be used when the player **Name** is listed as "Access to [player IP address] denied".

- **Access Diagnostic Web Server**: Opens a web browser window or tab to access the player **Diagnostic Web Server**.

- **Access Device Web Page**: Opens a web browser window or tab to access the player Device Web Page (i.e. **Local Web Server**).
User Permissions
Administrators of BrightSign Network accounts can create separate accounts with access to their BrightSign Networks. These accounts (called User Accounts) can be assigned to roles with various sets of permissions in both the BrightSign Network WebUI and in BrightAuthor.

Access to the BrightSign Network features in BrightAuthor will depend on permissions that were determined by the Account Administrator. Regardless of permissions, BrightAuthor appears the same to all users. However, attempting to use blocked features will result in an error message. If you are an Account Administrator, you must use the WebUI to change a User Account’s permissions in BrightAuthor.

Using Advanced Tools
Advanced tools let you remotely control units on your BrightSign Network or set up a USB flash drive to retrieve device data and perform device actions. After you set up a USB flash drive, inserting it in a BrightSign player will extract the specified data or perform the specified actions (e.g. reboot the player). The Advanced Tools window is divided into three tabs: the Setup USB Drive tab, as well as the Update Autorun and Unit Control tabs, which are only available if you have a BrightSign Network account.

Complete the following steps to set up a USB flash drive:

1. Click Tools > Advanced.
2. Click the Setup USB Drive tab. The following checkboxes determine what actions you want to occur when the USB flash drive is inserted into the player:
   - Copy variables database: Extracts the data for all User Variables and Media Counters.
   - Copy log files: Extracts all log files.
   - Delete log files: Deletes all log files on the BrightSign player.
   - Reset Variables: Resets all User Variables to their default values.
   - Reboot: Reboots the BrightSign player.
Display status on screen during data capture: Displays the status on the display while the USB flash drive is inside the BrightSign player.

3. Click Setup drive and navigate to the location of the USB flash drive on your computer.
4. When the Setup Complete window opens, click OK.
5. Remove the USB flash drive from your computer and insert it in the player.
6. If you are extracting data from the player, reinsert the USB flash drive into your computer to retrieve the data.

Note: You can retrieve data from multiple players using a single USB flash drive. The filename of each variable, media counter, and log record will include the serial number of the applicable player, so the number of unique player records you can put on a USB flash drive is limited only by storage space.

Complete the following steps to update the autorun on players linked to your BrightSign Network account:

1. Sign in to BrightSign Network by clicking Tools > Sign in to BrightSign Network.
2. Click Tools > Advanced.
3. Click the Update Autorun tab. A list of all your groups is displayed here. Check the checkboxes and then click Update now to update the Autorun version for those groups.

Note: Visit this FAQ to learn how to distribute custom autorun scripts using the BrightSign Network.

Complete the following steps to remotely control players linked to your BrightSign Network account.

4. Click the Unit Control tab.
5. In the Serial Number field, type the serial number of the unit you want to control.
6. Click the Action dropdown list to select the action you want to perform:
   - Reboot unit: Restarts the BrightSign.
   - Upload logs: Uploads log files based on the upload logs setting you selected when setting up the unit.
   - Recover – reformat: Puts the unit in recovery mode and reformats the unit’s storage card.
• Recovery—don’t reformat: Puts the unit in recovery mode and downloads the latest Autorun script to the storage card without reformatting it.

7. (Optional) Click Add action to add another action, or remove an action by clicking Remove action.

8. Click Close.

Using the Diagnostic and Local Web Server

The Diagnostic Web Server gives you the ability to perform various system functions—such as rebooting the player, changing display settings, and retrieving log files—from a web browser (see the Diagnostic Web Server User Guide for more details). The Local Web Server is necessary for Local File Networking. It also gives you access to the User Variables webpage, which allows you to modify User Variables using a web browser or the BrightSign App. Both features are enabled during the player setup process.

Follow these steps to connect to the Diagnostic Web Server and User Variables page using a web browser:

Note: Your PC or mobile device must be connected to the same local network as the BrightSign player.

1. Power off the BrightSign player.

2. Remove the SD card and USB drive (if applicable).

3. Power on the player and wait several minutes. The IP address of the player, along with the serial number and firmware version, will appear on the display.

4. To access the Diagnostic Web Server, enter the displayed IP address into the address bar of the browser on your PC or mobile device (for example, “10.0.1.199”). To access the User Variables webpage, enter the displayed IP address plus port 8008 (for example, “10.0.1.199:8008”).

5. Enter your user name and password (if applicable).
For additional Frequently Asked Questions, go to http://support.brightsign.biz/forums.

Can I use BrightAuthor 4.0 or later with the HD210, HD410, HD810, HD1010, HD1010w, or TD1012?
No, these legacy models are only supported by BrightAuthor versions 3.8 and earlier.

Can I open the autoplay.xml file using BrightAuthor?
No. The autoplay.xml file that is generated when you publish a presentation is a playlist file. This file includes only the information required for playback on a BrightSign player. It is not the same as a presentation project file.

How do I use a different font?
To use a different font, browse to a folder on your computer that has a true type font (e.g. in a Ticker zone, click Zone Properties, and then click Browse beside font). This font will be copied to the SD card when you publish the presentation. You can use your own custom fonts or download free TrueType fonts from the web.

Can I export a template?
Yes. Although there isn’t a template export option, you can save a presentation project with the desired template layout, and then transfer it to another computer. You can then open the project in BrightAuthor, and then save the template (Layout > Save Template).

Why does BrightAuthor take a long time to process my folder?
If the folder you selected has a large number of images and videos, the Media Library may take a few minutes to update. Please be patient.
Why can’t BrightAuthor locate my files when I try to publish my presentation?

If you copy a presentation project from one computer to another, or move or rename files used in a BrightAuthor project, BrightAuthor cannot locate the files, and you will receive an error message when you try to publish. To resolve the error, you must remove the files from each zone’s playlist in the presentation and then add them again.

Why are some of my videos missing thumbnails in the Files tab?

The thumbnails are generated by codecs installed on your computer. You can download codecs to resolve the problem. For example, if you’re missing thumbnails for your transport streams, you can try downloading a codec such as K-Lite.

What do I do if BrightAuthor crashes while I’m using it?

For any errors or crashes you encounter while using BrightAuthor, please post a description of the problem in the forums (http://support.brightsign.biz/forums) or send us an email at support@brightsign.biz and include the following information:

- Steps to duplicate the problem (or indicate that you can’t duplicate it)
- Any error dialogs you saw, including text in the dialog
- The contents of your event log right after the crash. You can find the log in this folder:
  C:\Users\Owner\AppData\Local\BrightSign\BrightAuthor\n    o Look for a subfolder named after the BrightAuthor version number, such as 2.4.0.
- A copy of the presentation project where you experienced the problem
Currently, BrightAuthor only supports the NEC remote control protocol. If you’d like to send or receive IR commands using Pronto Hex Code (PHC), you will need to use a custom script plug-in (see the BrightSign GitHub™ page for more details).

Complete the following steps to set up your BrightSign player to communicate with an IR transmitter or receiver:

1. Create an Interactive Presentation.
2. Define either a Remote Input event or a Send IR Remote command.
3. Specify the remote input with any of the following remote control codes:

   WEST
   EAST
   NORTH
   SOUTH
   SEL
   EXIT
   PWR
   MENU
   SEARCH
   PLAY
   FF
   RW
   PAUSE
   ADD
   SHUFFLE
   REPEAT
   VOLUP
   VOLDWN
4. Repeat the above steps for each remote input you want to define.
APPENDIX B – CHANGE LOG

Version 3.5
April 11, 2013
- Revised Chapter 2 > Setting up a Player for Standalone Use Chapter 8 > Publishing with Local Storage to include information about publishing with USB drives and using password protection for these content updates.
- Added additional information about using Portrait Orientation to Chapter 3 > Creating a Full-Screen Presentation.
- Revised the explanation in Chapter 4 > Event Handlers to include new Stop Playback functionality.
- Added a note to Chapter 5 > Ticker Zones explaining how to use alignment settings with right-to-left languages.

April 29, 2013
- Revised Chapter 10 > Using Advanced Tools to include an explanation of using a USB flash drive to retrieve records from multiple devices.

May 9, 2013
- Clarified how Live Text Data feeds and RSS feeds operate in a Live Text state. See Chapter 4 > Live Text for more details.

Version 3.7
June 8, 2013
- Added an RF Channel Scanning section to Chapter 9 to reflect the change in RF channel scanning functionality.
- Modified RF In state description in Chapter 3 to reflect change in RF channel scanning functionality. Also added Tuner Scan state description in Chapter 3.
- Added chapter names to page footers to enable easier navigation.
• Created a new chapter, “Chapter 10 – Presentation Properties” to house descriptions of all tabs in the Presentation Properties window.
• Revised Chapter 10 > Variables to reflect User Variable system overhaul.
• Revised Chapter 10 > Autorun to describe new BrightAuthor plugin feature.
• Made several changes to Chapter 4 > Commands to reflect changes to the UI.
• Added new section, Chapter 3 > Audio Streams, to reflect new audio streaming feature.
• Revised the description of the Change Presentation command in Chapter 4 > Commands to reflect changes to the UI.
• Revised the description of the Set Audio command in Chapter 4 > Commands to reflect changes to the UI.
• Added description of Send IR Remote to Chapter 4 > Commands and revised Appendix A to reflect this new addition.

June 19, 2013
• Added description of the new Diagnostics feature in the Advanced Network Setup window.
• Revised documentation of HTML5 states to reflect changes in functionality.
• Expanded the explanation of the Serial Input Event in Chapter 5.
• Documented expanded functionality of Conditional Targets in Chapter 4.
• Expanded explanation of using Twitter feeds in Chapter 3 > Live Data, Text, RSS, Twitter, and Media RSS Feeds.
• Documented new the new behavior of text items in a Live Text state in Chapter 4 > Live Text.
• Clarified and revised documentation of the UI tab in the Edit > Preferences window.

June 27, 2013
• Instructions for adding media items to a playlist now include the new ability to drag-and-drop files from a Windows Explorer window.
• All descriptions of accessing the Local Web Server (i.e. User Variables webpage) via port number 8080 have been changed to port number 8008 to reflect changes in the system software.
• Added a separate Twitter section and revised instructions for adding a Twitter feed to reflect changes to the API.
• Expanded the explanation for enabling a proxy server in Chapter 2 > Setting up BrightSign units.
• Added a description of Simple File Networking Authentication to Chapter 2 > Setting up BrightSign units.

July 18, 2013
• Added several caveats concerning using RSS feed URLs in MRSS states (and vice-versa).
• Added descriptions for the new Enable Update Notifications option to each publishing method section in Chapter 2.

July 29, 2013
• Added a note about distributing custom autoruns via the BrightSign Network to Chapter 11 > Using Advanced Tools.

August 14, 2013
• Documented the ability to publish to multiple players at once using Local File Networking in Chapter 8 > Publishing with Local Networking.

August 28, 2013
• Revised the description of the variable value operation in Chapter 4 > Conditional Targets to match expanded functionality.
• Revised the Publishing with Local Storage section of Chapter 8 to reflect the new Setup Unit for BrightSign Network option and attendant changes in the UI.
• Added a new section, Importing and Exporting, to Chapter 9. It details the Export Presentation, Import/Export User Variables, and Import/Export User Events actions in the File menu.
• Added a description of the Plugin Message event to Chapter 5.
• Added a description of the Send > Send Plugin Message Command to Chapter 4 > Commands.

October 7, 2013
• Added a note about support for Pronto Hex Code (PHC) to Appendix A.
• Expanded description of Data Feeds to include local file URLs in Chapter 10 > Data Feeds.
• Added additional information to **Chapter 9 > Importing and Exporting** about importing User Variable sets that contain networked user variables.
• Added notes to several sections concerning file formatting for SD cards.

**Version 3.8**

January 27, 2014
• Added a new chapter that covers the process of creating BrightWall video wall presentations: **Chapter 6 – Creating a BrightWall**.
• Revised **Chapter 9 > Publishing with Local Storage**, **Publishing with Local File Networking**, and **Publishing with Simple File Networking** to include information about the new *presentation interrupt* scheduling functionality.
• Added the new **Publishing a BrightWall Presentation** section to **Chapter 9** to cover the process of publishing a BrightWall video presentation.
• Revised **Chapter 4 > Media Lists and Play Files** to include new “Populate from Data Feed” and “Add all Content from Media Library” features.
• Revised the **UDP Input** event entry in **Chapter 5** to include new options that correspond to the BrightSign App.
• Revised the **GPIO Event** entry in **Chapter 5** to include new repeating press detection.
• Added new **Super State** section to **Chapter 4**.
• Revised **Chapter 4 > Commands** to reflect the separation of Commands into Entry and Exit Commands for states.
• Added new Copying, Exporting, and Importing States section to **Chapter 4**.
• Revised **Chapter 4 > HTML** to include the new **Custom fonts** feature.
• Added further information to **Chapter 1 > Step 5: Add Your Content** concerning the new Image Resize prompt.
• Added the new **Send IR Remote (Pronto)** and **Reset Variable** commands to **Chapter 4 > Commands**. Also revised the description of **Set Variable**, **Increment Variable**, and **Decrement Variable**.
• Added note concerning audio Dynamic Playlists vs. image/video Dynamic Playlists to **Chapter 3 > Dynamic Playlists**.
• Revised **Chapter 11 > HTML Sites** to include new features and functionality.
• Added description of new firmware update options in Chapter 9 > Publishing with Local Storage, Publishing with Simple File Networking, and Publishing with Local Networking.
• Documented new functionality for limiting Twitter feeds to a number of most recent tweets in Chapter 3 > Twitter.
• Documented new background screen color functionality in every section of Chapter 2.
• Documented new Advanced Network Setup > Unit Configuration > Specify hostname option in every section of Chapter 2.
• Added a description for the new Edit > Preferences > Backups tab in Chapter 10 > Changing Preferences.
• Added a description for the new UDP tab in File > Presentation Properties.
• Added a new section to Chapter 10 titled Editing Audio Only and Enhanced Audio Zones. Also added a description of Enhanced Audio zones to Chapter 3 > Creating a Multi-Zone Presentation.

March 26, 2014
• Added a note concerning .mov files with compressed atoms to Chapter 1 > Step 5: Add Your Content.
• Added a note concerning image cropping and Live Text background images to Chapter 3 > Live Text.

April 4, 2014
• Added instructions for accessing the JavaScript console once it is enabled to Chapter 11 > HTML Sites.

May 1, 2014
• Added a caveat to Chapter 9 > Editing Audio Only and Enhanced Audio Zones about using audio files with different sample rates in Enhanced Audio zones.
• Removed the Editing Other Zones section from Chapter 10 and added the Editing Images Zones, Editing Clock Zones, and Editing Background Image Zones sections as a replacement.
• Expanded documentation for the Presentation Properties > Interactive tab in Chapter 11.
• Expanded documentation for the Synchronize event in Chapter 5.

May 5, 2014
• Revised language of notes related to formatting cards using FAT32 vs. NTFS.
May 30, 2014
- Added further description of how default variables work in Chapter 11 > Variables. This includes a note about how to revert one or all variables to new default values.
- Clarified the descriptions of the Reset Variable and Reset Variables commands in Chapter 4 > Commands.

June 10, 2014
- Added note about limited support for WMA files to Chapter 1 > Add Your Content.

August 12, 2014
- Clarified which events/transitions are copied when a state (or set of states) is copied/exported in Chapter 4 > Copying, Exporting, and Importing States.
- Added a description of the new USB update (FW only) publishing feature in Chapter 9 > Publishing to Local Storage.
- Added .m2ts as a supported video container to Chapter 1 > Step 5: Add Your Content.
- Grouped the topics of creating/including Dynamic Playlists and Live Data Feeds into a single place: The new Creating Dynamic Playlists and Live Data Feeds section in Chapter 3.
- Separated Media RSS Feed instructions into their own section (Chapter 3 > Media RSS Feeds). RSS Feeds and Text Feeds are now part of a separate section (Chapter 3 > RSS Feeds and Text Feeds).
- Added an explanation of how to use User Variables to specify video/Mjpeg stream URLs in Chapter 3 > Video and Mjpeg Streams.
- Added a description of the Default download rate limit in Chapter 2 > Adding a Player to the BrightSign Network and Chapter 2 > Adding a Player to your Simple File Network.
- Split the Live Video and SignChannel section into two different sections: Live Video and SignChannel
- Added notes to the Live Video and RF In sections concerning displaying both states at the same time (i.e. not to do that).

August 22, 2014
- Created an entry for the new Limit storage space by function feature in Chapter 10 > Changing Preferences.
Appendix B – Change Log

Version 4.0

September 29, 2014

• Changed mention of model numbers in many sections to bring the user guide up to date with the release of 4K models.
• Added an explanation of using custom MRSS fields to the Chapter 4 > Live Text section.
• Moved the Customizing Templates section to Chapter 3 and renamed it Customizing Zone Layouts. This position and naming better reflects most use cases.
• Added documentation for additional z-ordering options to the Customizing Zone Layouts section.
• Added a description for the Assign wildcard to user variable? option to Chapter 4 > Dynamic User Variables. Also added Plugin Messages to the description of assigning inputs and wildcards.
• Revised the Editing Ticker Zones entry in Chapter 10 to include the new Scrolling Ticker option.
• Added a description for the new Standalone with unit setup publishing option in Chapter 9 > Publishing with Local Storage.
• Revised Chapter 13 to provide a comprehensive set of information. Also added an explanation of how to access the DWS/LWS from the Manage > Local Network tab.
• Revised Chapter 4 > Image, Audio, Video Lists to note the specific limitations of media lists with Enhanced Audio zones.
• Added a note to Chapter 11 > Data Feeds about using Update Intervals that are smaller than the amount of time it takes to cycle through a Data Feed.

September 29, 2014

• Added a more comprehensive description of how to use Data Feed download URLs with Play Files to Chapter 4 > Image, Audio, and Video Play Files.
• Added further caveats to Chapter 6 that BrightWall presentations support looping video playlists only—and not images.
October 6, 2014
- Corrected the description of serial port enumeration behavior in Chapter 11 > Interactive.

October 14, 2014
- Added a description of the Enable native video plane playback option to the Chapter 3 > HTML5 section.
- Expanded the Chapter 3 > Video and Mjpeg Streams section to include more information.

October 17, 2014
- Clarified how the BP200/BP900 Any Button option works in Chapter 8.
- Expanded the descriptions of button panel options available in Chapter 11 > Interactive.
- Clarified how BP200/BP900 transitions work with Play Files in Chapter 4 > Video Play Files, Image Play Files, and Audio Play Files.

November 6, 2014
- Added more detailed information about the Enable serial debugging and Enable system log debugging options in Chapter 9.

Version 4.1
December 2, 2014
- Updated the Variables, Data Feeds, and HTML Sites sections in Chapter 11 to reflect new options and features.
- Removed Chapter 7 – TD1012 because this unit is no longer supported in BrightAuthor version 4.0.0.x and later.
- Added a note to Chapter 6 > BrightWall Video Requirements about using files for seamlessly looping video walls.
- Documented the Remote Snapshot feature for Local File Networking setup in Chapter 2 > Adding a Player to your Local Network.
- Added documentation for the Remote Snapshot feature to Chapter 12 > Local Network.
- Revised Chapter 4 > Editing Media Properties to reflect new options in the Media Properties window.
• Added a description of the Enable Local Storage and Query string options to Chapter 10 > HTML Sites.
• Added an entry for the new Audio Timecode Event to Chapter 5.
• Added the new Presentation Tree View section to Chapter 9.
• Added a description of the proxy server fields in Chapter 11 > Networking.
• Revised Chapter 4 > Image Play Files, Video Play Files, and Audio Play Files to include new features and functionality.
• Revised Chapter 4 > Image Lists, Video Lists, and Audio Lists to reflect new workflow for populating media from a Data Feed.
• Updated player setup and Standalone update steps to reflect the fact that some models can be powered by Ethernet.
• Changed company address on title page.

December 30, 2014
• Revised Chapter 6 > Configuring a BrightWall Presentation to reflect the fact that the Interactive tab has been removed.

January 14, 2015
• Noted the fact that Remote Snapshot is not supported on LSx22 or HDx20 models.

February 3, 2015
• Added further description of the BrightControl – Send Ascii String command in Chapter 4 > Commands.
• Revised statements about supported models throughout the document.

February 18, 2015
• Revised the BrightWall video requirements.

April 10, 2015
• Added additional description to the Custom Fonts feature for HTML states.
• Revised **Chapter 6 > Configuring a BrightWall Presentation** again to reflect the fact that the **Interactive** tab has been removed.

April 15, 2015
• Removed the **HTML local storage** option description from **Chapter 10 > HTML Sites** and added it **Chapter 11 > Storage**.

April 23, 2015
• Added Remote Snapshot parameters to SFN and BSN configurations in Chapter 2.
• Added BSN BrightWall parameters to Chapter 2.
• Revised Chapter 6 to account for new BrightWall creation workflow.
• Added the **Creating a BrightWall on the BrightSign Network** tab to Chapter 6.
• Revised **Chapter 12 > Status** to account for new BSN BrightWall parameters.
• Revised **Chapter 8 > Publishing a BrightWall Presentation** to account for new BSN BrightWall publishing.

May 1, 2015
• Added additional information to **Chapter 10 > Data Feeds** concerning the **Parser Function Name**.

May 8, 2015
• Added a note to **Chapter 8 > Publishing with Local Storage** noting that you have to publish a presentation with an SD card first in order to use the USB update feature.
• Revised **Chapter 12 > Presentations** to account for new BSN BrightWall features.

May 18, 2015
• Revised the BSN BrightWall section of **Chapter 8 > Publishing BrightWall Presentations**.